X
Tapnite tukaj za mobilno različico spletne strani.

Forum za podporo

When I type ALT-e, Firefox opens the Edit pulldown menu. I don't want this behavior. How do I DISABLE or redefine ALT-e to another keyboard shortcut?

Objavljeno

I want to use the ALT-e shortcut for a particular add-on. I want to either disable ALT-e from opening the browser Edit menu or redefine another shortcut to open the Edit menu, freeing ALT-e for another use.

I want to use the ALT-e shortcut for a particular add-on. I want to either disable ALT-e from opening the browser Edit menu or redefine another shortcut to open the Edit menu, freeing ALT-e for another use.
Citiraj

Dodatne podrobnosti o sistemu

Nameščeni vtičniki

  • Shockwave Flash 32.0 r0

Program

  • Uporabniški agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:68.0) Gecko/20100101 Firefox/68.0

Več informacij

cor-el
  • Top 10 Contributor
  • Moderator
17278 rešitev 156200 odgovorov

That is not possible. You can't disable or change these accelerator keys. You will have to use another shortcut like Alt+Ctrl+E. Note that Alt+Shift is reserved for access keys on web pages including about pages like about:preferences.

That is not possible. You can't disable or change these accelerator keys. You will have to use another shortcut like Alt+Ctrl+E. Note that Alt+Shift is reserved for access keys on web pages including about pages like about:preferences.
Vam je bilo v pomoč?
Citiraj
jscher2000
  • Top 10 Contributor
8520 rešitev 69619 odgovorov

Firefox doesn't currently have a way to let extensions take over built-in keyboard shortcuts. I hope that is added in the future.

Interestingly, Alt+e doesn't give the warning that it is a built-in keyboard shortcut, even though it is a menu hotkey. I wonder why not??

For Windows

You could completely disable Alt from triggering menus on the menu bar as a workaround. Then instead of Firefox intercepting Alt+e for that purpose, the keyboard shortcut will pass through to other processes. Here's how:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box above the list, type or paste menuacc and pause while the list is filtered

(3) Double-click the ui.key.menuAccessKey preference to display a dialog where you can edit the value from 18 to 0 (that's a zero) and then click OK.

(4) Do a normal Firefox Exit and restart.

Firefox doesn't currently have a way to let extensions take over built-in keyboard shortcuts. I hope that is added in the future. Interestingly, Alt+e doesn't give the warning that it is a built-in keyboard shortcut, even though it is a menu hotkey. I wonder why not?? '''''For Windows''''' You could '''completely disable Alt from triggering menus''' on the menu bar as a workaround. Then instead of Firefox intercepting Alt+e for that purpose, the keyboard shortcut will pass through to other processes. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''menuacc''' and pause while the list is filtered (3) Double-click the '''ui.key.menuAccessKey''' preference to display a dialog where you can edit the value from 18 to 0 (that's a zero) and then click OK. (4) Do a normal Firefox Exit and restart.
Vam je bilo v pomoč?
Citiraj
cor-el
  • Top 10 Contributor
  • Moderator
17278 rešitev 156200 odgovorov

Note that it isn't advised to make changes to these ui.key.* prefs. You can easily forget about this change and then wonder why you can't use the Alt key to access the Menu bar (i.e. you need to use F10 or have the menu bar visible permanently).

Note that it isn't advised to make changes to these ui.key.* prefs. You can easily forget about this change and then wonder why you can't use the Alt key to access the Menu bar (i.e. you need to use F10 or have the menu bar visible permanently).
Vam je bilo v pomoč?
Citiraj

Lastnik vprašanja

jscher2000 said

. . . For Windows You could completely disable Alt from triggering menus on the menu bar as a workaround. Then instead of Firefox intercepting Alt+e for that purpose, the keyboard shortcut will pass through to other processes. Here's how: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste menuacc and pause while the list is filtered (3) Double-click the ui.key.menuAccessKey preference to display a dialog where you can edit the value from 18 to 0 (that's a zero) and then click OK. (4) Do a normal Firefox Exit and restart.

This is a very interesting idea. I tried it, and it did in fact disable the ALT trigger, but the ALTs did not pass through. There may be something else blocking them.

By the way, the add-on I'm using is FoxScroller. I want to define ALT-<anykey> as the START/STOP shortcut.

''jscher2000 [[#answer-1235739|said]]'' <blockquote> . . . '''''For Windows''''' You could '''completely disable Alt from triggering menus''' on the menu bar as a workaround. Then instead of Firefox intercepting Alt+e for that purpose, the keyboard shortcut will pass through to other processes. Here's how: (1) In a new tab, type or paste '''about:config''' in the address bar and press Enter/Return. Click the button accepting the risk. (2) In the search box above the list, type or paste '''menuacc''' and pause while the list is filtered (3) Double-click the '''ui.key.menuAccessKey''' preference to display a dialog where you can edit the value from 18 to 0 (that's a zero) and then click OK. (4) Do a normal Firefox Exit and restart. </blockquote> This is a very interesting idea. I tried it, and it did in fact disable the ALT trigger, but the ALTs did not pass through. There may be something else blocking them. By the way, the add-on I'm using is FoxScroller. I want to define ALT-<anykey> as the START/STOP shortcut.
Vam je bilo v pomoč?
Citiraj
Vprašajte

Morate se prijaviti v svoj ​​račun, če hočete odgovarjati na prispevke. Začnite novo vprašanje, če še nimate računa.