Iskanje po podpori

Izogibajte se prevarantski tehnični podpori. Nikoli vam ne bomo naročili, da pokličete telefonsko številko ali nam pošljete osebne podatke. Sumljivo dejavnost prijavite z gumbom »Prijavi zlorabo«.

Learn More

All addons are disabled in private mode

  • 8 odgovorov
  • 1 ima to težavo
  • 32 ogledov
  • Zadnji odgovor od atata

more options

All of my addons are disabled in private mode. All settings are reset in private mode, including smooth scrolling. Looking at addons in private mode displays message about "Firefox changing" everything again and displays no addons with message "You don't have any addons of this type installed". Looking at addons in normal mode shows that all addons are enabled, working and "Allowed" for private mode. Did firefox drop support for addons completely in private mode? This is very sad.

All of my addons are disabled in private mode. All settings are reset in private mode, including smooth scrolling. Looking at addons in private mode displays message about "Firefox changing" everything again and displays no addons with message "You don't have any addons of this type installed". Looking at addons in normal mode shows that all addons are enabled, working and "Allowed" for private mode. Did firefox drop support for addons completely in private mode? This is very sad.

Izbrana rešitev

Hi atata, how do you switch between normal and private modes? Is it just a matter of opening a link in a new private window, or are you changing settings and restarting, or using a desktop shortcut, or ??

Preberite ta odgovor v kontekstu 👍 0

Vsi odgovori (8)

more options
more options

In Firefox 67 you can set via the about:addons page what extensions to allow in PB mode. You can click an extension to open its details. You will notice "Run in Private Windows" with "Allow" and "Don't Allow" choices. You will notice a purple label on the main "Add-ons _> Extensions" page.

  • ALLOWED IN PRIVATE WINDOWS
more options

Izbrana rešitev

Hi atata, how do you switch between normal and private modes? Is it just a matter of opening a link in a new private window, or are you changing settings and restarting, or using a desktop shortcut, or ??

more options

jscher2000 said

Hi atata, how do you switch between normal and private modes? Is it just a matter of opening a link in a new private window, or are you changing settings and restarting, or using a desktop shortcut, or ??


I am choosing hamburger > New Private Window


cor-el said

In Firefox 67 you can set

I cannot. The option does not work.


WestEnd said

Have you read this yet? https://support.mozilla.org/en-US/kb/private-browsing-use-firefox-without-history

I did, there's nothing new there

more options

Can you attach a screenshot that shows the page that opens if you click an extension?

more options

See also these prefs on the about:config page.

  • extensions.allowPrivateBrowsingByDefault
  • <strike>extensions.privatebrowsing.notification</strike> (might not be there)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Spremenil cor-el

more options

If I set extensions.allowPrivateBrowsingByDefault = true then I'm not seeing the purple label and the setting on the details page because extensions are automatically allowed in PB mode when possible.

more options

I cannot reproduce this anymore somehow.

Earlier today I've reopened a new private window three times, but all addons were disabled in it and all settings were reset, including smooth scrolling and all task bar buttons. Main window was still open and with working addons and correct settings. Now I open private and the addons are there.