Zobrazenie otázok označených: Zobraziť všetky otázky
  • Vyriešené
  • Archivované

Middle-Clicking on a hyperlink is no longer opening new windows and I would like it do so.

This is driving me nuts. My desired behavior is that, when I middle-mouse-click on a hyperlink, Firefox launches a new window (not a tab) with that URL. This is how it wa… (ďalšie informácie)

This is driving me nuts.

My desired behavior is that, when I middle-mouse-click on a hyperlink, Firefox launches a new window (not a tab) with that URL.

This is how it was working before a power interruption forced my computer to restart tonight, and my desired behavior has gone away.

The middle mouse button works for other functions; and, middle-clicking on bookmarks in my bookmark bar does launch a new window with that bookmark as expected. However, middleclicking a hyperlink does nothing.

I have browser.tabs.opentabfor.middleclick = false and in the options menu, "open links in tabs instead of new windows" is unchecked. Additionally I have set browser.link.open_newwindow = 2.

Can anyone help me here? This is driving me slightly batty.

Otázku položil(a) ShadowDragon8685 Pred 2 rokmi

Na otázku odpovedal(a) jscher2000 - Support Volunteer Pred 1 rokom

  • Archivované

Tabs sometimes do not load pages when I middle-click on links from website or from bookmarks

At several occasions, but not in a reproducible manner, when I open pages' links (or bookmarks toolbar's links) using middle-click button (i.e. using "Open Link in a new … (ďalšie informácie)

At several occasions, but not in a reproducible manner, when I open pages' links (or bookmarks toolbar's links) using middle-click button (i.e. using "Open Link in a new tab"), the tab opens up, shows the URL it should load, but seems to stop there and never actually loads the website. Sometimes, the URL won't even show up in the omnibar. When this happens, the "Reload current page" is grayed out, so I need to click the omnibar and hit enter to force the URL to load, or click the original link again. Most of the time, reclicking with middle button on the same link works fine again. I did not see any common pattern regarding which links generate this behavior or not, but I will keep trying to find out.

This behavior does occur even in safe-mode (all addons disabled).

Otázku položil(a) simon.budin Pred 2 rokmi

Posledná odpoveď od gumby_dammit223 Pred 1 rokom