Zobrazenie otázok označených: Zobraziť všetky otázky

Firefox 92 causes cross domain authentication errors

I currently run several environments for Dynamics 365 products. Our clients can choose to use our authentication (ADFS 4.0) or we set up a SSO option for them (normally … (čítať viac)

I currently run several environments for Dynamics 365 products. Our clients can choose to use our authentication (ADFS 4.0) or we set up a SSO option for them (normally also ADFS of some flavor). The piece that is similar between both is that the domain they authenticate to would not be the same as the application they are necessarily using. For example my clients have a mixture of on premise and cloud deployments but if they are SSO only pull their tokens from one domain.

Anyways the real TLDR as I can determine is as follows:

Has anyone seen a problem with firefox 92 stripping out headers? My scenario is I have an AD FS server that I use for single sign on with a domain name that is different from the application that it federated with. When I attempt to login using Firefox, the traffic flows as: 1. Hit the app url and get 302 redirected to the IDP 2. enter credentials at the IDP and get redirected to the app url 3. the app has an internal and external claims URL, so the internal claims url 302 redirects me to the external url 4. FF brings up the external url, but does NOT pass the MSISAuth and MSISAuth1 cookies from the IDP 5. The app thinks I've not authenticated, so it 302 redirects me back to the IDP 6. The IDP sees the MSISAuth and MSISAuth1 cookies, so it knows it authenticated me and it 302 redirects me back to the app wash, rinse, repeat for 5 times until AD FS realizes that I've done this 5 times, then it throws an error at me to stop the loop. This was working fine in FF 91 and it currently works in Chrome and Edge. The expected flow is almost the same, except that the app get's the cookies presented to it from AD FS. I was thinking this was something to do with Enhanced Tracking Protection. When I selected Custom and unchecked all the options (I think this disables ETP) I still get the cookies stripped from the header. I re-enabled ETP with standard protections and manually added the URLs using the steps outlined at https://bugzilla.mozilla.org/show_bug.cgi?id=1432644#c27. Is this a bug where FF doesn't honor the settings to disable ETP in V92? The reason I was thinking that ETP was to blame is the IDP has a domain of IDP.example and the app has the URL's of internalclaim.app and externalclaim.app.

I feel like I am missing something obviously here but I can't find it. If I create a CRM deployment using the same domain as our ADFS servers it works fine. If I use what our public designation is, it fails. SSO obviously fails. It only started after upgrading to 92 and that is consistent amount all of our clients. I have tried to go through every advance config that was touched with the 92 upgrade and nothing there seems to help. We compared our UAS to a friend of ours who is not having issues since the 92 release and they look the same. If this was a system 92 problem I would expect the internet to be exploding by now but it is not. It makes me think there is something I am missing in our fundamental set up but for the life of me I can't identify a missing update, compatibility issue, known issue blah blah blah. Edge, Chrome, Safari they all still work fine. It is just the Firefox 92 update that all of a sudden killed our authentication.

Otázku položil(a) christopher.butler.02 Pred 2 mesiacmi

Firefox creating new users and instances

I always have to close all Firefox instances from task manager all the time and then open firefox -p and delete users. It creates them again and again. Is there no way to… (čítať viac)

I always have to close all Firefox instances from task manager all the time and then open firefox -p and delete users. It creates them again and again. Is there no way to stop this?

Otázku položil(a) Amay Pred 2 mesiacmi

Add-ons will not properly display in the overflow menu, showing a minimized box and a scrollbar instead.

When viewing extensions in the overflow menu, items become cutoff. Sometimes a scrollbar will be displayed, allowing you to view the rest. At other times, you are not abl… (čítať viac)

When viewing extensions in the overflow menu, items become cutoff. Sometimes a scrollbar will be displayed, allowing you to view the rest. At other times, you are not able to navigate to the other information at all. I tried to use ctrl + (+ or -) to try and zoom out, but only the size was able to become bigger or smaller, not the scaling.

Otázku položil(a) zacharypalko Pred 2 mesiacmi

Firefox container tab

I am using different container/color tab for opening stories on Medium. Somehow the google script used by Medium website is able to figure out that am logged in as a user… (čítať viac)

I am using different container/color tab for opening stories on Medium. Somehow the google script used by Medium website is able to figure out that am logged in as a user on my main tab. If in the same tab container, I go to google.com/gmail.com, it asks me to sign in. How can we avoid this?

Otázku položil(a) KJ Pred 2 mesiacmi

Video speed control not working - Ubuntu

Hi! I use Firefox on Ubuntu 20.04.3. I tried to speed up video on Sharepoint. Right click -> speed -> 2.0 and nothing happend. When I right click -> speed again… (čítať viac)

Hi! I use Firefox on Ubuntu 20.04.3. I tried to speed up video on Sharepoint. Right click -> speed -> 2.0 and nothing happend. When I right click -> speed again, I saw that speed still 1.0. Then I went to google, found that Sharepoint allow speed up videos only in HTML5 player. Then I knew that to do that in Firefox I should disable Hardware acceleration, so I did it, but it didn't help. OpenH264 Video Codec provided by Cisco add-on is activate.

Then I decided that's Ubuntu. I install ubuntu-restricted-extras, ffmpeg packages (to support h.264 video), restarted, but again that didn't work.

youtube.com/html5 saying that everything fine.

Otázku položil(a) Sergey K Pred 2 mesiacmi

Firefox used to have a setting to open 1, 3 or all previous session tabs, now that option is gone and defaults to open all tabs

Firefox used to have a setting to open 1, 3 or all previous session tabs, now that option is gone and defaults to open all tabs. The problem didn't affect me until I made… (čítať viac)

Firefox used to have a setting to open 1, 3 or all previous session tabs, now that option is gone and defaults to open all tabs. The problem didn't affect me until I made a full Win 8.1 64-bit reinstall, I overwrote the entire previous profile with about 950 tabs; I made sure that profile specific files weren't overwritten, I checked internally with Total Commander looking for the specific profile name in all files of the old profile; anyway, the new firefox with the old profile quickly killed any operational capability of my PC, not even the mouse or the keyboard lights would work, until many minutes later, then slowly I could move the mouse to the upper right corner for the [ X ] to kill firefox. While trying to uninstall Firefox uninstaller offered to "refresh" so I did, and here I am

Is there something in about:config I can modify? I really need that option back, is a royal PIA as Firefox is working now, and a very very stupid idea to remove such important option.

Plugins, add-ons have nothing to do, Can anyone let Mozilla know about this, they killed the Feedback option on the Browser.

Otázku položil(a) saull28 Pred 2 mesiacmi

Firefox Not Restoring Last Session And Resets My Settings After PC Restart

I'm using Firefox for years but never faced this issue. If I close Firefox and open again my open tabs are restoring, settings and prefrences not changing. But if I resta… (čítať viac)

I'm using Firefox for years but never faced this issue. If I close Firefox and open again my open tabs are restoring, settings and prefrences not changing. But if I restart my pc and start Firefox, session not restoring, opened tabs are not restoring.

I've tried backup and restore my profile (Files can see on attachment). After restoring profile tabs are opening, my old settings are there, until I restart my pc. What should I do now?

Otázku položil(a) oknksk Pred 2 mesiacmi

something wrong with youtube loading

When i use other browser it works just fine but when i use firefox this happens. I can click on the video but the page would not load either (second image). I already tri… (čítať viac)

When i use other browser it works just fine but when i use firefox this happens. I can click on the video but the page would not load either (second image). I already tried: -safe mode -re installing firefox -clearing cache -switch profile nothing works

Otázku položil(a) aldynoah98 Pred 2 mesiacmi

Swipe gestures not working

Greetings, One of the arguably most useful gestures for laptop users is still missing/broken on Firefox on windows. It's the two-finger swipe that allows to navigate forw… (čítať viac)

Greetings, One of the arguably most useful gestures for laptop users is still missing/broken on Firefox on windows. It's the two-finger swipe that allows to navigate forward or backward in history by swiping left or right.

This feature is present in Chrome and even Edge since many months, yet it has never worked on Firefox, on any of my windows devices.

I've been using Firefox Dev since 12+ months, keeping both it and windows 10 always up to date, the gestures never worked (yet they are activated in the about:config page, see attached images).

What's most disappointing is that the gestures work without any issue on the MacOS version of Firefox.


some useful info: Firefox version: 94.0b3 (latest as of today) Windows version: 21H1 build 19043.1266 (latest as of today)

If someone manages to get the two-finger swipe gesture to work on windows please let me know.

I hope this can get fixed soon, especially because the feature seems to be already built into Firefox, it just doesn't work in the windows release. In the meanwhile I'm switching to chrome

Otázku položil(a) edocs Pred 1 mesiacom

When "\\?\" in entered into the address bar of the Firefox Flatpak, "clarkcountynv.gov" is visited.

Why does typing "\\?\" into the address bar of http://dl.flathub.org/repo/appstream/org.mozilla.firefox.flatpakref cause "http://maps.clarkcountynv.gov/openweb/?getParcel… (čítať viac)

Otázku položil(a) BEEDELL ROKE JULIAN LOCKHART Pred 1 mesiacom

Minimise maximise and close buttons not working

Hi, I'm running FF beta on Surface pro 7 with Windows 11 beta and the three buttons top right have just stopped working. Same thing for all users. All other tab buttons e… (čítať viac)

Hi, I'm running FF beta on Surface pro 7 with Windows 11 beta and the three buttons top right have just stopped working. Same thing for all users. All other tab buttons etc working fine. Any ideas?

Otázku položil(a) M Pred 1 mesiacom

Caches the server response, even if it has changed

I have a VPN for work, some internal sites are inaccessible without this VPN. When I try to access them with the VPN turned off I legitimately get a 403. However, when I … (čítať viac)

I have a VPN for work, some internal sites are inaccessible without this VPN. When I try to access them with the VPN turned off I legitimately get a 403. However, when I turn on the VPN firefox keeps showing 403 while other browsers work fine. This also works the other way around. When I turn off the VPN and try to go to one of the internal sites I don't get a 403 (as I should), instead firefox gets stuck at the page loading stage and nothing happens. There seems to be some kind of caching or optimization going on, but it's terribly interfering. Deleting cookies, caches, etc doesn't help at all. The only thing that helps in this situation is restarting firefox.

Otázku položil(a) exdis Pred 1 mesiacom

Firefox dropdown menus and toolbar popups inconsistently work

Both drop-down menus (e.g., the drop-down for "Which topic best describes your question?") and popup menus for add-ons in the bookmark bars work inconsistently or not at … (čítať viac)

Both drop-down menus (e.g., the drop-down for "Which topic best describes your question?") and popup menus for add-ons in the bookmark bars work inconsistently or not at all. The right-click menu and the 3-bar menu often fail to work on the first few tries, but eventually open. (And in the case of the 3-bar menu, it often opens without certain options, like "Settings," "More tools," and "Help," though these usually appear after waiting a few seconds.) Other menus, like drop-down menus on website or several pop-ups for addons, don't work at all, no matter how many times I try.

The issue isn't solved by starting in Troubleshooting mode (insofar as they can be reproduced -- some things, like the add-on popups, can't be since the add-ons are disabled) or by clearing the cache.

I'm running Firefox Nightly 95.0a1 (2021-10-06) (64-bit) on Arch Linux, though the same issue seems to affect Firefox 93.0.

Thanks very much in advance for any help.

Otázku položil(a) raghav1 Pred 1 mesiacom

Mute Tab Stops Working

I have one pinned tab that I want to keep the sound muted on because it's a simple game that I play occasionally. The problem I'm having though is whenever I close the li… (čítať viac)

I have one pinned tab that I want to keep the sound muted on because it's a simple game that I play occasionally. The problem I'm having though is whenever I close the lid on my laptop for the night, then reopen it in the morning, the tab is no longer muted. Laptop is set to sleep when closing the lid. I just want to set the tab to mute permanently. Is there a way to do that without adding yet another extension to my growing list of extensions? Or is this unmute behavior not supposed to happen and something is amiss? Any help would be appreciated. Thank you! Windows 10 Asus VivoBook 1T C drive 1T D drive 16G ram

Otázku položil(a) nightsmusic Pred 1 mesiacom

Default Browser box under Settings in Firefox

In Firefox, I click on settings/General settings and I see the Default Browser box. It is checked , HOWEVER the whole area is slightly blurred and I cannot uncheck the bo… (čítať viac)

In Firefox, I click on settings/General settings and I see the Default Browser box. It is checked , HOWEVER the whole area is slightly blurred and I cannot uncheck the box. Not that I want to, but the system has taken over and will not allow me to uncheck it. At the same time this happened, Microsoft EDGE is starting to come up at various places when another app launches my web browser. Hewlett Packard is a good example. So, I tried to completely uninstall edge, with no luck. THAT uninstall box is also slightly blurred or faded, same as the Firefox default browser is. It is like Windows 10 is trying to take over my system completely. I hope you have had experience with this since they are now messing with your controls and your settings! Please help.

Otázku položil(a) rhsbdld Pred 1 mesiacom

Firefox color - dark theme

I'm trying to customize colors of Firefox developer edition. I would like to have a dark toolbar bit i don't wont to enable dark mode for any website. I have installed Fi… (čítať viac)

I'm trying to customize colors of Firefox developer edition. I would like to have a dark toolbar bit i don't wont to enable dark mode for any website.

I have installed Firefox color and whenever i choose a darker color for the toolbar all websites are displaying their dark versions (it behaves like the dark mode is turned on).

I have tried to manual set browser.theme.content-theme and browser.theme.toolbar-theme but after every restart these get overridden.

Does anyone know how to make this happen?

The funny thing is that everything was fine before today's update...i tried reinstalling Firefox and also i tried disabling all extensions...

Otázku položil(a) dario.jakovljevic1 Pred 1 mesiacom

Firefox opens google search result links in a new tab as "https://www.google.com/url?sa=..."

Any chromium-based browser opens links from google search result in a new tab directly, but firefox (and Tor too) opens them with an address as "https://www.google.com/u… (čítať viac)

Any chromium-based browser opens links from google search result in a new tab directly, but firefox (and Tor too) opens them with an address as "https://www.google.com/url?sa=..." and further redirects to actual link's address.

Sample: firefox: 1. Search in google: funny cats 2. Click cmd+mouse on result #3 with link "www.funnyawesomecats.com" 3. New tab opens with address like "https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&ved=..." 4. After some delay page redirects to actual link "www.funnyawesomecats.com"

In contrast, any Chromium browser opens links in a new tab directly without intermediate redirection. Also, Firefox open links from a google search directly (i.e. without any issue) only on the current search page, but not on a new tab.

_______ Mac OS Firefox 95, 95b

Otázku položil(a) ammozoom Pred 4 týždňami

How to automatic download images https request

I'm searching for script and extension but found nothing. automatic download cached images is impossible so i'm only ask how to automatic download images https request. T… (čítať viac)

I'm searching for script and extension but found nothing.

automatic download cached images is impossible so i'm only ask how to automatic download images https request.

Thank you

Otázku položil(a) mangarockad Pred 3 týždňami

Format URL in Network Monitor

How can I exclude `http://domain.com` part from URL column? The urls I'm working with look like this `http://domain.com/path/to/resource` `http://domain.com/another/path/… (čítať viac)

How can I exclude `http://domain.com` part from URL column? The urls I'm working with look like this `http://domain.com/path/to/resource` `http://domain.com/another/path/to/resource` So `http://domain.com` part takes too much space in URL column, but displaying just File column is not informative in this case.

Otázku položil(a) kio21 Pred 3 týždňami

Firefox 95.0b7 (32-bit) Is So Broken!

I have no idea what's happened with this update, but it is beyond broken. Even in troubleshooting mode with everything turned off, pages take forever to load, everything … (čítať viac)

I have no idea what's happened with this update, but it is beyond broken. Even in troubleshooting mode with everything turned off, pages take forever to load, everything is terribly slow, it's cyclical like something is updating in the background, but it's happening on every single page and it's taken any productivity to a standstill. It has only started happening with this update. Didn't happen prior to this. It's obviously not my extensions since they're all disabled in troubleshooting mode, there's nothing out of the ordinary showing in the task manager, I thought it might be when my Gmail tab updates, but even with that tab closed, it's still ongoing. I can't work like this. Is there a way to revert to the previous iteration until the next update comes through?

Windows 10, Asus VivoBook, 16G Ram, 1T C Drive, 1T D Drive

Otázku položil(a) nightsmusic Pred 2 týždňami