Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Táto téma bola uzamknutá a archivovaná. Ak potrebujete pomôcť, založte prosím novú otázku.

Firefox 29 fails to exit properly and remains running in task manager.

  • 42 odpovedí
  • 206 má tento problém
  • 13736 zobrazení
  • Posledná odpoveď od John99

more options

This is a continuation of a thread found here: https://support.mozilla.org/en-US/questions/997448 by Compumind.

I reported I was having the same experience, especially when opening links from emails in Thunderbird. I also reported I was forced to revert to FF 28.

Moses replied in above thread and suggested: (1) Download a fresh installer from https://www.mozilla.org/firefox/all/ to a convenient location. (Scroll down to your preferred language.)

(2) Exit out of Firefox.

(3) Rename the folder

C:\Program Files (x86)\Mozilla Firefox

to

C:\Program Files (x86)\OldFirefox

(4) Run the installer you downloaded in #1. It should automatically connect to your existing settings.

I followed these instruction carefully but no joy. Upon installing FF 29, not only would it refuse to exit (using "exit") and remain running in the Task Manager until I killed it after opening links from Thunderbird, but I found it refused to exit after simple browsing and following links.

Moses had asked I not reply in original thread so I am re-posting here.

I believe this is a serious bug. With Firefox 28...no problems except a minor one I reported here: https://bugzilla.mozilla.org/show_bug.cgi?id=1002089

Again I am forced back to FF 28, though I miss the beautiful interface and security fixes, I need to have a browser that works properly. My wife has never even seen the Task Manager before so this is problem.

Besides the "educated guesses" made with this post, the only other thing outside of usual that I do, is to have a security policy regarding cookies (don't accept by default...I make exceptions for cookies I want to retain and have a several that are only "allow for session.") I also have FF set to delete browsing history on exit, but that takes a split second.

I look forward to when this issue can be addressed successfully and I am able to use FF 29 (and have it exit properly...I can't expect my wife to follow all these instructions and close it often manually in the task manager...nor do I want to do this.)

Good luck on all the Mozilla projects. Having installed FF 29 twice and then reverted back to 28 twice, I am going to wait and see how this plays out. Please don't send me the standard, "start in safe mode", "restart with add-ons disabled", "reset Firefox" (last time that destroyed my browser completely) stuff. I do not believe this is what's happening.

Moses added that there is a problem with email notifications going through, so take your time, friends.

Upravil(a) Axis dňa

Vybrané riešenie

I now (temporarily) believe this bug or issue has its roots in the "Clearing of History on Exit" setting.

I took the plunge after some further playing around with the PortableFirefox 29 and reading the blog post linked here:

[https://support.mozilla.org/en-US/que.../997918#answer-566755]

...and installed FF 29 over my previous FF28 on my box. I have unchecked the "Clear History on Exit" which was only deleting my history, not cookies or anything else, cor-el. My setting are not to accept cookies unless I make an exception. Until the FF developers find a way to make this functional, I will have to simply delete history manually.

By the way, John99, you would want privacy.sanitize.sanitizeOnShutdown set to "False", not "True" if you want to stop the automatic (attempt) at deletion of history on exit.

I have been running for about 6 hrs. without experiencing the "hanging" bug. So I can live with that for now until this bug is fixed. It should be fixed...browsers are supposed to be able to do things like that.

On the other hand, I might find things go bad...but so far I am not having a problem.

I have been running for several hours and will let you know later whether things change.

Kind Regards,

Axis

Čítať túto odpoveď v kontexte 👍 12

Všetky odpovede (20)

more options

Does this issue still happen if you boot the computer in Windows Safe Mode?

Boot the computer in Windows Safe Mode with network support (press F8 on the boot screen) as a test.

more options

Add me to the group of folks with this problem and who have rolled back to FF 28 (with updates turned off).

Before I rolled back, I uninstalled FF 29, ensured that all files (including profiles) had been deleted, and then reinstalled. Same problem.

It occurs every 2 or 3 times I launch FF, requiring me to use the task manager to kill the orphaned process. Of course, when someone less technical in the house uses one of our PCs, they have no idea what to do.

I had the installation configured to clear items on exit, so I also suspected that may have been the issue. I could have unchecked that setting, but actually need that capability so I have rolled back.

I am not feeling great about being on FF 28 from a security POV...so if this is not fixed soon, I'll be switching to another browser.

Upravil(a) scuba dňa

more options

Last I looked it seemed possible some fixes may make it into Firefox 30.

Remember Private Browsing Windows may be used, (Ctrl+Shift+P) as long as you close those before exiting Firefox it should close without hanging.

more options

UPDATE

Note one potential fix is now in the very recent Firefox Beta 30b8 Initial reports suggest this fixes the issue. (Bug1005487#c38) If you have been suffering from this problem and want a fix now instead of in a few weeks time you may wish to download and install the Beta version of Firefox.

The beta version is effectively a release candidate but is only intended for advanced users or testers. I would be interested to hear feedback from those of you that do test this out.

Beta version download


P.S.

If you should install Firefox beta please take care to NOT use any option to remove personal information. Do NOT remove the Firefox profile,the beta should install over the top of the Release version, there is normally no need even to uninstall the Release first.

Upravil(a) John99 dňa

more options

"Clearing of History on Exit" setting

  1. Tools
  2. Options
  3. Privacy

Un-checking this box seems to resolve the issue for me, odd...

You would think that ensuring FF closes properly without process's hanging (showing as a running process under the task manager) should be a simple fix for the devs???

Upravil(a) Dr. User dňa

more options

Hey FF and Mozilla - I am not a tech person and don't have hours to spend re-doing my entire FF, especially as it's not a clear fix anyway. I also have the problem that firefox.exe does not stop running even after I close FF. This is a security issue, not just an annoyance. Comment by a Forum Moderator. This is NOT a security issue. Developers believe this issue is fixed in Firefox 30 Beta 8. If you wish to not wait for 30 to be released, download the beta at mozilla.org/firefox/beta. Stop dawdling and please fix this as an urgent security matter. If I hit Exit or ALT+F4 or the X button, FF should DIE. Got it? Thanks.

Upravil(a) Moses dňa

more options

ginz,

We are just fellow users trying to help one another so there is no point in shouting here that you want fixes. If you can code yourself you could get involved with the fixes.

Obviously few people code. My coding skills and experience are minimal. There are things that anyone can do to help. Possibly in future you may consider yourself doing your bit by testing some of the pre release versions. Anyone can do that. If problems are spotted in pre-release versions and reported then; with any luck; they do not go into the final releases. Chances are anyone now having the problem would have noticed the problem on the Beta or Aurora channel Six or 12 weeks prior to the Release.

This issue is (AFAIK) not a security problem. You should still be able to manually clear History before closing down, or use Private browsing. Besides if you restrict Firefox to single users or groups of user per OS account there is no need to clear History anyhow as it is only the authorised user/s that use the account and see the History.


Dr User

As is often the case part of the issue is Firefox is used on many different platforms and OS es with all sorts of customisations and addons. As I understand it the environment and specific use pattern has a lot to do with whether or not Firefox will hang when History is cleared on closed own.

This is something that may well affect millions of users but it is still an issue that only a minority of users see.

There were proposals to attempt to push the fix through early, of course if no one tests it it may not get approved and could be delayed another 6 or 12 weeks.

more options

Same problem since “upgrade” to 29 and 29.0.1. Also set to accept cookies but clear history on close. Started on my laptop first so I avoided updating on main PC which wasn't hanging, once I updated main PC to 29 Firefox hangs on that also (wife uses it and makes me help her get that “stupid Firefox working again”, she restarts the computer ugggh) . Had disabled all plug-ins and still hangs. I use Adobe Acrobat, Shockwave Flash, Silverlight Plugin, and occasionally Microsoft Office 2010. I also run the “don't show tabs when only one tab is open” software, and had run the old (and preferred) SeaMonkey style face, nicer back buttons etc, and that got wiped out on the 29 update and I'm not happy about it. I'll try not clearing history on close and see if that works. Maybe ad/spam folks want us to be forced into their ads by not clearing our history.

Upravil(a) dumbitdown dňa

more options

dumbitdown,

Note this is a Fault or Bug with Firefox and is being worked on. It is not a feature change or design decision. Using Private Browsing instead is a temporary work around not a solution. It is already probably fixed in Firefox 30 beta, which is available now as I have mentioned up thread.

more options

I have been running Beta 30 for several days and have not seen the issue reoccur. The browser has been closed dozens of times. So far, so good.

more options

Yes, so far so good with the beta...

more options

The current fix has only been in beta for a few days not for 30 days.

There was a fix as a workaround for hangs with a different cause and that was included as a point release in the Ordinary Release Fx29.0.1 made on 9th May

more options

@John99 Did someone say they've been using the beta for 30 days?

I see @Scuba said "Beta 30 for several days" several days not 30?

I've been using it for a couple of days now and it seems to be closing fine?

more options

Note I'm one of the devs who fixed the issue.

We believe that the issue has been fixed in Firefox 30 beta 8. If you are affected by the issue, you may download this version here: https://www.mozilla.org/en-US/firefox/channel/ or wait a few weeks until it comes out of beta.

This bug was triggered by cleanup of thumbnails during shutdown. In most runs of Firefox, this cleanup worked nicely. However, a combination of circumstances could cause the cleanup mechanism to start loading its resources during shutdown, after the loading mechanism had already shutdown itself. Firefox waited until that load was complete to proceed with shutdown, but the load could not complete.

Two fixes have been landed. A fix specific to thumbnails landed in time for Firefox Beta 8 and ensures that we never shutdown the loading mechanism before the cleanup has had a chance to complete. A more general fix will has landed shortly after to ensure that the bug does not reappear with other subsystems.

You may find all the technical data on the bug and how it was resolved here.

As a side-note, this issue is not considered a security bug, as it may only be triggered by sitting in front of the computer and changing the settings. We reserve the denomination for security bugs for issues that can be triggered without the consent of the user.

more options

@Yoric appreciate the prompt attention to the issue (and your explanation) as well as all the work the devs put into FF.

It's really too bad FF succumbed to external pressures recently rather than put its true user base first. FF should have stuck to its core beliefs open source/open web. My 2cents...

Thx again for the fix!

Upravil(a) Dr. User dňa

more options

Yoric, Thanks for the comments.

more options

I have the same problem with FF 29. I have found that I can close it by clicking on the menu and then the exit button in the lower right hand corner. This works all the time for me to exit FF and also stop it from running. Thanks.

more options

I reported I had the described problem when running 29.0.1; just upgraded to 30.0 and a quick test seems to indicate that the issue is no longer occurring.

Although I have been a FF user for years and a proponent to the uninitiated, I have not been much of a participant, feeling I lack any relevant skill set to 'aid the team'. However, I now realize I can at least serve as a bug reporter...

I am hopeful the fully dissected 'bug' has indeed been resolved. Regards, Robert

more options

RBeach

If you are interested in trying to help there are possibly a few things you could consider participating in see for example.

more options

OK, that does it.

This has been going on for a long time. As fine as the Mozilla team is, they don't seem to want to fix it.

I've decided to stop waiting for them and do something about it myself. I've built a small executable stub that first kills any stale Firefox instances, and then starts up a clean one.

You can download the program and/or Visual Basic source code here:

Firefox Killer

If you run into any trouble, post a question in the Discussions section. Be patient; I'm pretty busy. I'll try to respond as quickly as I can.

Thanks, Jeff Bowman Fairbanks, Alaska (Spam link Removed by mod)

Upravil(a) user633449 dňa

  1. 1
  2. 2
  3. 3