X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Táto téma bola uzamknutá a archivovaná. Ak potrebujete pomôcť, založte prosím novú otázku.

Youtube videos won't play with Firefox.

Pridané

Youtube is still working with Safari and Chrome but for some reason it stopped working with Firefox. This happened the night before it updated to Firefox 25. I thought the update was the issue but it's not. I've tried everything that I've read about to fix this issue. I've tried playing vids in safe mode, updated to the latest version of flash, disabled hardware acceleration, I've cleared all cookies and cache, I've reset firefox, I've deleted all my add-ons, I've deleted and re-installed firefox. Nothing is working. Anyone got a clue what to do?

OSX 10.6.8 Macbook 2.4 Ghz

Youtube is still working with Safari and Chrome but for some reason it stopped working with Firefox. This happened the night before it updated to Firefox 25. I thought the update was the issue but it's not. I've tried everything that I've read about to fix this issue. I've tried playing vids in safe mode, updated to the latest version of flash, disabled hardware acceleration, I've cleared all cookies and cache, I've reset firefox, I've deleted all my add-ons, I've deleted and re-installed firefox. Nothing is working. Anyone got a clue what to do? OSX 10.6.8 Macbook 2.4 Ghz

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 11.9 r900
  • Version 4.8.2.15856
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Unity Web Player version 4.2.1f4. (c) 2013 Unity Technologies ApS. All rights reserved.
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • 5.1.20125.0
  • Facebook Video Calling by Skype
  • Picasa plugin.
  • iPhoto6

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:25.0) Gecko/20100101 Firefox/25.0

Viac informácií

kobe 441 riešení 5048 odpovedí

Do you get a error, or nothing, does the Flash test page work?

SEE:

Do you get a error, or nothing, does the Flash test page work? SEE: * [[Flash 11.3 doesn't load video in Firefox]] <= Applies to 11.3 and ABOVE * [[Flash Plugin - Keep it up to date and troubleshoot problems]] * http://www.adobe.com/software/flash/about/ <= Flash Test

Autor otázky

Flash is up to date. It works on other sites aside from youtube and works on the flash test page.

Flash is up to date. It works on other sites aside from youtube and works on the flash test page.

Autor otázky

Nothing comes up, screen stays black, just doesn't load. No error message.

Nothing comes up, screen stays black, just doesn't load. No error message.
jscher2000
  • Top 10 Contributor
8792 riešení 71910 odpovedí

Could you check whether you are enrolled in the Youtube "HTML5 trial"? If you are, this might not be a Flash problem, but an HTML5 video problem. You should be able to see/change your status on this page: https://www.youtube.com/html5

Could you check whether you are enrolled in the Youtube "HTML5 trial"? If you are, this might not be a Flash problem, but an HTML5 video problem. You should be able to see/change your status on this page: https://www.youtube.com/html5

Autor otázky

Already tried both ways, HTML5 on or off. Neither is working.

Already tried both ways, HTML5 on or off. Neither is working.
cor-el
  • Top 10 Contributor
  • Moderator
17578 riešení 158993 odpovedí

If Flash works properly on other website including the Adobe welcome test page then someting must be blocking Flash on YouTube.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

If clearing cookies doesn't work then it is possible that the cookies.sqlite file that stores the cookies is corrupted.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookie files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

If Flash works properly on other website including the Adobe welcome test page then someting must be blocking Flash on YouTube. Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes If clearing cookies doesn't work then it is possible that the <i>cookies.sqlite</i> file that stores the cookies is corrupted. Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookie files like <b>cookies.sqlite-journal</b> in the Firefox profile folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies

Upravil(a) cor-el dňa

seedsandsuch 0 riešení 3 odpovedí

Užitočné odpovede

I have the same problem. I followed all of the above suggestions to no avail. Advertisements play fine. But when the skip option pops up, it doesn't count down smoothly from 5 -0 seconds. It will say, 5, 4, 5, 5, 4, and then sometimes you can skip ad. It doesn't matter if you skip ad or not. When the video comes up, it acts like it wants to load and play but will only play for a second, then restarts from beginning and says an error occured. Same thing in Explorer. And this is a brand new, Windows 7 64-bit computer. Is there anything else I can do to get Youtube videos to play?

I have the same problem. I followed all of the above suggestions to no avail. Advertisements play fine. But when the skip option pops up, it doesn't count down smoothly from 5 -0 seconds. It will say, 5, 4, 5, 5, 4, and then sometimes you can skip ad. It doesn't matter if you skip ad or not. When the video comes up, it acts like it wants to load and play but will only play for a second, then restarts from beginning and says an error occured. Same thing in Explorer. And this is a brand new, Windows 7 64-bit computer. Is there anything else I can do to get Youtube videos to play?
lsirisup 0 riešení 1 odpovedí

I had this problem too. After I reactivated the plugins: RealNetworks, RealPlayer, and Shockwave Flash 11.9.900.152, youtube showed video as normal.

I had this problem too. After I reactivated the plugins: RealNetworks, RealPlayer, and Shockwave Flash 11.9.900.152, youtube showed video as normal.
jscher2000
  • Top 10 Contributor
8792 riešení 71910 odpovedí

Hi seedsandsuch, could you:

  • Test in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

    You can restart Firefox in Safe Mode using

    Help > Restart with Add-ons Disabled

    In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hi seedsandsuch, could you: * Disable the protected mode of the Flash Player plugin. See this support article from Adobe under the heading "Last Resort": [http://forums.adobe.com/message/4468493#TemporaryWorkaround Adobe Forums: How do I troubleshoot Flash Player's protected mode for Firefox?] * Test in Firefox's Safe Mode. That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]].<br><br>You can restart Firefox in Safe Mode using<br><br>Help > Restart with Add-ons Disabled<br><br>In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
seedsandsuch 0 riešení 3 odpovedí

Užitočné odpovede

Tried both and there is no change. I did try something that someone else suggested. I installed Google Chrome and the videos play perfectly in that browser. So, this must be something between firefox and flash. However, the same thing happens when I use Explorer as well so that browser must have a problem as well.

I wish I could get this resolved. I'd rather use Firefox than other browsers.

Tried both and there is no change. I did try something that someone else suggested. I installed Google Chrome and the videos play perfectly in that browser. So, this must be something between firefox and flash. However, the same thing happens when I use Explorer as well so that browser must have a problem as well. I wish I could get this resolved. I'd rather use Firefox than other browsers.
seedsandsuch 0 riešení 3 odpovedí

I also tried reactivating Flash. And even downloaded RealPlayer. It makes no difference whether RealPlayer is installed, enabled, or disabled. Same problem.

I also tried reactivating Flash. And even downloaded RealPlayer. It makes no difference whether RealPlayer is installed, enabled, or disabled. Same problem.
Visitor1 0 riešení 1 odpovedí

I had the same problem with video,youtube has been working untill I changed video quality. Messing with plugins and updating didn't help. Only Internet Explorer worked.

A minute ago I saved my all bookmarks and uninstalled Firefox, then install it back and everything works great. Fast and easy

I had the same problem with video,youtube has been working untill I changed video quality. Messing with plugins and updating didn't help. Only Internet Explorer worked. A minute ago I saved my all bookmarks and uninstalled Firefox, then install it back and everything works great. Fast and easy
cbvideo 0 riešení 1 odpovedí

the anchwer on this probl is easy . Chans the date of your comp/lapt to realtyme

the anchwer on this probl is easy . Chans the date of your comp/lapt to realtyme
cyberpope67 0 riešení 2 odpovedí

I'm hacving it, too, just started -- seems to happen when a video gets to a HD part. I clicjked the gear, set to Auto, reloaded, same; clicked gea, set to 240(only choice other than HD or Auto), reloaded, & again -- happens at same point; & "HD" shows up on the gear at that moment -- even though I had it set to 240. . .

I'm using the latest version of Firefox, today, 28-Jan-2014

Message given is: An error occurred, please try again later.

I've had this for 3 days now. . . :( for all youtube videos, whether playing an embedded one on a site(eg facebook) or playing on youtube.com itself

Any ideas?

I'm hacving it, too, just started -- seems to happen when a video gets to a HD part. I clicjked the gear, set to Auto, reloaded, same; clicked gea, set to 240(only choice other than HD or Auto), reloaded, & again -- happens at same point; & "HD" shows up on the gear at that moment -- even though I had it set to 240. . . I'm using the latest version of Firefox, today, 28-Jan-2014 Message given is: An error occurred, please try again later. I've had this for 3 days now. . . :( for all youtube videos, whether playing an embedded one on a site(eg facebook) or playing on youtube.com itself Any ideas?

Upravil(a) cyberpope67 dňa

jscher2000
  • Top 10 Contributor
8792 riešení 71910 odpovedí

Hi cyberpope67, in case you haven't already tried this:

When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Bypass Firefox's Cache

Clear Firefox's cache using:

orange Firefox button (or Tools menu) > Options > Advanced

On the Network mini-tab > Cached Web Content : "Clear Now"

If you have a large hard drive, this might take a few minutes.

(2) Remove all Youtube cookies (save any pending work first). While viewing a page on the site, try either:

  • right-click and choose View Page Info > Security > "View Cookies"
  • Tools menu > Page Info > Security > "View Cookies"

In the dialog that opens, you can remove the site's cookies individually.

Then try reloading the page with the video. Does that help?

Hi cyberpope67, in case you haven't already tried this: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site. (1) Bypass Firefox's Cache Clear Firefox's cache using: orange Firefox button (or Tools menu) > Options > Advanced On the Network mini-tab > Cached Web Content : "Clear Now" If you have a large hard drive, this might take a few minutes. (2) Remove all Youtube cookies (save any pending work first). While viewing a page on the site, try either: * right-click and choose View Page Info > Security > "View Cookies" * Tools menu > Page Info > Security > "View Cookies" In the dialog that opens, you can remove the site's cookies individually. Then try reloading the page with the video. Does that help?
cyberpope67 0 riešení 2 odpovedí

I did exactly as you suggested; cleared cache, killed cookies, reloaded, but video still won't play past aboput the 2 second mark, &, strangest, it insists on switching me to HD mode, eventhough I've specified not.

I did exactly as you suggested; cleared cache, killed cookies, reloaded, but video still won't play past aboput the 2 second mark, &, strangest, it insists on switching me to HD mode, eventhough I've specified not.
jscher2000
  • Top 10 Contributor
8792 riešení 71910 odpovedí

Hi cyberpope67, do you have any add-ons that might be touching the Flash media, whether for purposes of recording or downloading videos? I wonder whether one of those might be affecting the quality?

Also, I don't know whether it will help, but Youtube uses the DASH method of sending videos in small bits. The YouTube Center extension can revert to the older method of sending the whole video as one giant file. Maybe that will prevent mid-video changes from occurring?

https://addons.mozilla.org/en-us/firefox/addon/youtube-center/

Hi cyberpope67, do you have any add-ons that might be touching the Flash media, whether for purposes of recording or downloading videos? I wonder whether one of those might be affecting the quality? Also, I don't know whether it will help, but Youtube uses the DASH method of sending videos in small bits. The YouTube Center extension can revert to the older method of sending the whole video as one giant file. Maybe that will prevent mid-video changes from occurring? https://addons.mozilla.org/en-us/firefox/addon/youtube-center/
Brady 0 riešení 1 odpovedí

Here's what worked for me...

Go to Tools > Add-ons and click the link at the top that says "Check to see if your plugins are up to date".

In my case, Java needed to be updated. In your case, you may have several that need to be updated.

Once I updated Java, everything started loading & playing as it should on YouTube.

Here's what worked for me... Go to Tools > Add-ons and click the link at the top that says "Check to see if your plugins are up to date". In my case, Java needed to be updated. In your case, you may have several that need to be updated. Once I updated Java, everything started loading & playing as it should on YouTube.
cor-el
  • Top 10 Contributor
  • Moderator
17578 riešení 158993 odpovedí

It is possible that the cookies.sqlite file that stores the cookies is corrupted if clearing cookies doesn't work.

Rename (or delete) cookies.sqlite (cookies.sqlite.old) and delete other present cookies files like cookies.sqlite-journal in the Firefox profile folder in case the file cookies.sqlite got corrupted.

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.
It is possible that the <i>cookies.sqlite</i> file that stores the cookies is corrupted if clearing cookies doesn't work. Rename (or delete) <b>cookies.sqlite</b> (cookies.sqlite.old) and delete other present cookies files like <b>cookies.sqlite-journal</b> in the Firefox profile folder in case the file cookies.sqlite got corrupted. *http://kb.mozillazine.org/Cookies *https://support.mozilla.org/kb/Deleting+cookies Start Firefox in <u>[[Safe Mode|Safe Mode]]</u> to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). *Do NOT click the Reset button on the Safe Mode start window. *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
rogerfsp 0 riešení 7 odpovedí

Why only Firefox displays, on Youtube, the "An error ocurred, please try again later" message? How to solve this? Hello, I am developer and always stayed videos from my sites and blogs, YouTube. Now I'm having trouble "only" with Firefox, because only it is showing now famous message: "An error ocurred, please try again later". Ie, the solution to host videos on YouTube to display on websites, no longer "Cross Browser". How to solve this? This story clearing cache does not work, useless to sticking with this type of response. Please help me. Thank you very much.

PS: Other flash sites work perfectly in Firefox. Including the testing of Adobe's Flash. Only YouTube does not work.

Why only Firefox displays, on Youtube, the "An error ocurred, please try again later" message? How to solve this? Hello, I am developer and always stayed videos from my sites and blogs, YouTube. Now I'm having trouble "only" with Firefox, because only it is showing now famous message: "An error ocurred, please try again later". Ie, the solution to host videos on YouTube to display on websites, no longer "Cross Browser". How to solve this? This story clearing cache does not work, useless to sticking with this type of response. Please help me. Thank you very much. PS: Other flash sites work perfectly in Firefox. Including the testing of Adobe's Flash. Only YouTube does not work.

Upravil(a) rogerfsp dňa