X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

I am unable to sign in to Twitter or Pinterest on Firefox but they both work on Safari

Pridané

I can't enter my log in information on the Twitter log in page. My Pinterest page is blank and unable to click on any icon at top I cleared cookies and cache but still doesn't work

I can't enter my log in information on the Twitter log in page. My Pinterest page is blank and unable to click on any icon at top I cleared cookies and cache but still doesn't work

Vybrané riešenie

I figured out which setting was causing the problem, and want to share in case it helps someone else. I was using the EFF's recommended settings to stop online tracking, here: https://www.eff.org/deeplinks/2012/04/4-simple-changes-protect-your-privacy-online

Step number 3 suggests you "turn off referers" by going into the about:config settings and changing the referer setting from 2 to 0. The setting is "network.http.sendRefererHeader". When I changed it back to 2, the problem went away.

Čítať túto odpoveď v kontexte 3

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 11.8 r800
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Displays Java applet content, or a placeholder if Java is not installed.
  • Microsoft Office for Mac SharePoint Browser Plug-in
  • Plugin that detects installed Citrix Online products (visit www.citrixonline.com).
  • The Google Earth Plugin allows you to view 3D imagery and terrain in your web browser.
  • 5.1.10516.0

Aplikácie

  • Firefox 23.0.1
  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:23.0) Gecko/20100101 Firefox/23.0
  • URL adresa podpory: http://support.mozilla.org/1/firefox/23.0.1/Darwin/en-US/

Rozšírenia

  • Add to Amazon Wish List Button 1.10 (amznUWL2@amazon.com)
  • Add to Wishpot initial.rev18 (jid0-rQAKfA8xtr968vDoIiJalXYS0q0@jetpack)
  • Buffer for Firefox 2.2.19 (jid1-zUyU7TGKwejAyA@jetpack)
  • Classic Retweet 1.11.1 (classicretweet@jonpierce.com)
  • Copy As Plain Text 1.0.9 ({1a5dabbd-0e74-41da-b532-a364bb552cab})
  • gTranslate 0.9 ({aff87fa2-a58e-4edd-b852-0a20203c1e17})
  • HootSuite Hootlet 1.0 (hootsuite@hootsuite.com)
  • PrivacyChoice TrackerBlock 2.2 (trackerblock@privacychoice.org)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • WordPress.com Extension 2 (extension@wordpress.com)

JavaScript

  • incrementalGCEnabled: True

Grafika

  • adapterDescription:
  • adapterDeviceID: 0x6740
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x1002
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 3
  • numTotalWindows: 3
  • webglRenderer: ATI Technologies Inc. -- ATI Radeon HD 6770M OpenGL Engine
  • windowLayerManagerType: OpenGL

Upravené nastavenia

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.newtab.url: about:blank
  • browser.places.smartBookmarksVersion: 4
  • browser.startup.homepage: google.com
  • browser.startup.homepage_override.buildID: 20130814063812
  • browser.startup.homepage_override.mstone: 23.0.1
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 23.0.1
  • gfx.blacklist.direct2d: 3
  • gfx.blacklist.layers.direct3d9: 3
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1378306750
  • places.history.enabled: False
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • plugin.importedState: True
  • plugin.state.adobepdfviewernpapi: 0
  • privacy.clearOnShutdown.cookies: False
  • privacy.clearOnShutdown.sessions: False
  • privacy.cpd.downloads: False
  • privacy.cpd.formdata: False
  • privacy.cpd.history: False
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.value: 0
  • privacy.popups.showBrowserMessage: False
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.sanitizeOnShutdown: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1377954960

Ostatné

  • User JS: Nie
  • Prístupnosť: Nie
iamjayakumars 492 riešení 5972 odpovedí

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

To Enable SafeMode

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.
  • Once you get the pop-up, just select "'Start in Safe Mode"

If it works in Safe Mode and in normal mode with all extensions (Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: "Firefox > Quit Firefox"; Linux: "Firefox/File > Quit")

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance). <b> To Enable SafeMode </b> *You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. *''Once you get the pop-up, just select "'Start in Safe Mode"'' If it works in Safe Mode and in normal mode with all extensions (Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears. Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: "Firefox > Quit Firefox"; Linux: "Firefox/File > Quit") * https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode *https://support.mozilla.org/kb/Safe+Mode *https://support.mozilla.org/kb/Troubleshooting+extensions+and+themes
kobe 441 riešení 5048 odpovedí

Hello,

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

Did this fix your problems? Please report back to us!

Thank you.

Hello, Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache. Note: ''This will temporarily log you out of all sites you're logged in to.'' To clear cache and cookies do the following: #Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history. #Under "Time range to clear", select "Everything". #Now, click the arrow next to Details to toggle the Details list active. #From the details list, check ''Cache'' and ''Cookies'' and uncheck everything else. #Now click the ''Clear now'' button. Further information can be found in the [[Clear your cache, history and other personal information in Firefox]] article. Did this fix your problems? Please report back to us! Thank you.
neviller 0 riešení 1 odpovedí

I had this problem but did not want to clear all my existing cookies, as many of them are useful.

I realised that in the past I had blocked cookies from twitter.com. Now that I have registered for Twitter, I need to allow them.

In Firefox preferences / options, click the Privacy tab, then alongside "Accept cookies from sites" click the Exceptions button. Type in twitter.com and click Allow.

This doesn't address the detailed question reported by Pat928, who had already cleared all cookies. However, I hope it helps other people who come here because of the headline.

I had this problem but did not want to clear all my existing cookies, as many of them are useful. I realised that in the past I had blocked cookies from twitter.com. Now that I have registered for Twitter, I need to allow them. In Firefox preferences / options, click the Privacy tab, then alongside "Accept cookies from sites" click the Exceptions button. Type in twitter.com and click Allow. This doesn't address the detailed question reported by Pat928, who had already cleared all cookies. However, I hope it helps other people who come here because of the headline.
sugarcookie 1 riešení 12 odpovedí

I'm having the same problem, and I've tried everything. I made sure firefox and all it's plugins were up to date. I cleared the cookies and cache, disabled all of the extensions, and I still can't log in. I tried starting in safe mode. I also tried disabling plugins, but that didn't work. Then I tried setting cookies and pop-ups to "allow all". Still won't work.

This is happening on my home and work computers, which are two different internet connections and operating systems (win xp and win 7). I'm at a complete loss! If I can't resolve this, I will have to switch to a different browser, but I really want to stick with firefox. Any suggestions?

I'm having the same problem, and I've tried everything. I made sure firefox and all it's plugins were up to date. I cleared the cookies and cache, disabled all of the extensions, and I still can't log in. I tried starting in safe mode. I also tried disabling plugins, but that didn't work. Then I tried setting cookies and pop-ups to "allow all". Still won't work. This is happening on my home and work computers, which are two different internet connections and operating systems (win xp and win 7). I'm at a complete loss! If I can't resolve this, I will have to switch to a different browser, but I really want to stick with firefox. Any suggestions?
jscher2000
  • Top 10 Contributor
8773 riešení 71719 odpovedí

Hi sugarcookie, could you describe the behavior you're seeing in more detail?

For example, on https://twitter.com/ does the login form display? If you try to click into the username box, does the blinking text cursor appear, along with a blue outline around the box?

I noticed that if I block the scripts from a related site (twimg.com) then when I click the username box nothing happens; it's completely unusable. If you have that same symptom, I wonder whether you might be blocking scripts from that site, or "third party" cookies normally sent to that site.

Firefox usually allows all sites to run scripts. However, there are Firefox add-ons as well as external security software that might block them.

Have you tried the site in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hi sugarcookie, could you describe the behavior you're seeing in more detail? For example, on https://twitter.com/ does the login form display? If you try to click into the username box, does the blinking text cursor appear, along with a blue outline around the box? I noticed that if I block the scripts from a related site (twimg.com) then when I click the username box nothing happens; it's completely unusable. If you have that same symptom, I wonder whether you might be blocking scripts from that site, or "third party" cookies normally sent to that site. Firefox usually allows all sites to run scripts. However, there are Firefox add-ons as well as external security software that might block them. Have you tried the site in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?
sugarcookie 1 riešení 12 odpovedí

Hi jscher2000,

What happens on pinterest is that I enter my login information and the login page just refreshes, and I'm still not logged in. I can log in from other browsers, so it's just on firefox.

I've already tried all of your suggestions. I turned disabled all extensions and turned off all security options in the firefox options. Also, firefox and all the plugins have been updated. Is there still some way I might be blocking a script, even with all my extensions disabled?

Thanks

Hi jscher2000, What happens on pinterest is that I enter my login information and the login page just refreshes, and I'm still not logged in. I can log in from other browsers, so it's just on firefox. I've already tried all of your suggestions. I turned disabled all extensions and turned off all security options in the firefox options. Also, firefox and all the plugins have been updated. Is there still some way I might be blocking a script, even with all my extensions disabled? Thanks
jscher2000
  • Top 10 Contributor
8773 riešení 71719 odpovedí

Hi sugarcookie, I can't get that to happen, simply reloading the same page. If I disable scripts from pinterest.com or pinimg.com, when I try the login form, I get to an error page with various suggestions for solving the problem.

(By the way, I use an email login, I don't login using my Facebook or Twitter account. Those buttons pop up a new window to take your credentials.)

Do you have any external security software that filters your web traffic? McAfee software and parent control software, for example, could filter some scripts. Many security suites could block cookies, separately from Firefox's own cookie management.

Have you tried accessing Pinterest in Internet Explorer on the same computers? Just noticed you said that works.

Hi sugarcookie, I can't get that to happen, simply reloading the same page. If I disable scripts from pinterest.com or pinimg.com, when I try the login form, I get to an error page with various suggestions for solving the problem. (By the way, I use an email login, I don't login using my Facebook or Twitter account. Those buttons pop up a new window to take your credentials.) Do you have any external security software that filters your web traffic? McAfee software and parent control software, for example, could filter some scripts. Many security suites could block cookies, separately from Firefox's own cookie management. <s>Have you tried accessing Pinterest in Internet Explorer on the same computers?</s> ''Just noticed you said that works.''

Upravil(a) jscher2000 dňa

sugarcookie 1 riešení 12 odpovedí

I have comodo firewall and microsoft security essentials. I tried disabling both of them, clearing my cache again, and re-starting firefox. Still isn't working. I've also tried emailing pinterest. They said they couldn't reproduce the problem and couldn't help me :(

I have comodo firewall and microsoft security essentials. I tried disabling both of them, clearing my cache again, and re-starting firefox. Still isn't working. I've also tried emailing pinterest. They said they couldn't reproduce the problem and couldn't help me :(
jscher2000
  • Top 10 Contributor
8773 riešení 71719 odpovedí

Hi sugarcookie, since there are so many potential variables, to narrow it down to something in your settings, could you do a two-minute experiment?

Create a new Firefox profile

It will have your system-installed plugins (e.g., Flash), but no themes, extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder.

Exit Firefox and start up in the Profile Manager using Start > search box (or Run):

firefox.exe -P

Any time you want to switch profiles, exit Firefox and return to this dialog.

When creating a new profile, I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Before deleting unneeded profiles, I suggest making a backup first in case something were to go wrong.

Does Pinterest login work in the new profile? If so, then we can be reasonably certain there's a problem in your regular profile... the hard part is identifying it.

Hi sugarcookie, since there are so many potential variables, to narrow it down to something in your settings, could you do a two-minute experiment? '''Create a new Firefox profile''' It will have your system-installed plugins (e.g., Flash), but no themes, extensions, or other customizations. It also should have completely fresh settings databases and a fresh cache folder. Exit Firefox and start up in the Profile Manager using Start > search box (or Run): firefox.exe -P Any time you want to switch profiles, exit Firefox and return to this dialog. When creating a new profile, I recommend using the default location suggested, and to avoid data loss, not re-using any existing folder. Before deleting unneeded profiles, I suggest making a backup first in case something were to go wrong. Does Pinterest login work in the new profile? If so, then we can be reasonably certain there's a problem in your regular profile... the hard part is identifying it.
sugarcookie 1 riešení 12 odpovedí

That worked! I guess I will just start fresh with a new profile. Thanks for your help!

That worked! I guess I will just start fresh with a new profile. Thanks for your help!
jscher2000
  • Top 10 Contributor
8773 riešení 71719 odpovedí

Užitočné odpovede

Hi sugarcookie, as an intermediate step, you could return to your regular profile and use the Reset feature. That will at least copy over your bookmarks and some other data. Check out this article for more information: Refresh Firefox - reset add-ons and settings.

Hi sugarcookie, as an intermediate step, you could return to your regular profile and use the Reset feature. That will at least copy over your bookmarks and some other data. Check out this article for more information: [[Reset Firefox – easily fix most problems]].
sugarcookie 1 riešení 12 odpovedí

Vybrané riešenie

I figured out which setting was causing the problem, and want to share in case it helps someone else. I was using the EFF's recommended settings to stop online tracking, here: https://www.eff.org/deeplinks/2012/04/4-simple-changes-protect-your-privacy-online

Step number 3 suggests you "turn off referers" by going into the about:config settings and changing the referer setting from 2 to 0. The setting is "network.http.sendRefererHeader". When I changed it back to 2, the problem went away.

I figured out which setting was causing the problem, and want to share in case it helps someone else. I was using the EFF's recommended settings to stop online tracking, here: https://www.eff.org/deeplinks/2012/04/4-simple-changes-protect-your-privacy-online Step number 3 suggests you "turn off referers" by going into the about:config settings and changing the referer setting from 2 to 0. The setting is "network.http.sendRefererHeader". When I changed it back to 2, the problem went away.
jscher2000
  • Top 10 Contributor
8773 riešení 71719 odpovedí

Hi sugarcookie, thank you for posting that back. Sorry we didn't think to ask about that. The automated tool that scans for "important modified settings" and adds them to your post apparently doesn't check that. Hopefully it will be updated to do so.

Hi sugarcookie, thank you for posting that back. Sorry we didn't think to ask about that. The automated tool that scans for "important modified settings" and adds them to your post apparently doesn't check that. Hopefully it will be updated to do so.
wehrd1 0 riešení 1 odpovedí

I checked my referer setting and it's always been 2. so this isn't my problem.

I can sign in just fine using IE, but not FF. I've cleared all my cookies, history, and all the other suggestions in this thread.

what next?

windows8 - pinterest will not load. my login page is just a white screen with text and a login box for user name and password. and when i 'log in' i get nothing.

there was another site that had no graphics and just looked like text. honda-tech.com

I checked my referer setting and it's always been 2. so this isn't my problem. I can sign in just fine using IE, but not FF. I've cleared all my cookies, history, and all the other suggestions in this thread. what next? windows8 - pinterest will not load. my login page is just a white screen with text and a login box for user name and password. and when i 'log in' i get nothing. there was another site that had no graphics and just looked like text. honda-tech.com
jscher2000
  • Top 10 Contributor
8773 riešení 71719 odpovedí

Hi wehrd1, could you start a new question including your Windows version and add-on information? You can use this link:

https://support.mozilla.org/en-US/questions/new/desktop/fix-problems

Scroll down past the suggestions to continue the form (last time I checked, it is spread over 3 pages).

Hi wehrd1, could you start a new question including your Windows version and add-on information? You can use this link: https://support.mozilla.org/en-US/questions/new/desktop/fix-problems Scroll down past the suggestions to continue the form (last time I checked, it is spread over 3 pages).