Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The javascript option is gone, but so, apparently, is javascript

  • 3 odpovede
  • 84 má tento problém
  • 3162 zobrazení
  • Posledná odpoveď od cor-el

more options

According to what I have read thus far the decision to remove the 'enable javascript' option was for our own good, and in fact javascript is enabled by default.... except when it isn't. I have been unable to access the review links on allrecipes.com to read what other cooks say about the recipes. Minor issue, maybe, but the little message that comes up is "javascript; void(0)". When I asked the site managers for help they told me javascript must be enabled to see these ... so... clearly it isn't enabled. I tried adding the "quickjava" addon, but it doesn't help. I can get to these comments instantly via Chrome, but not Firefox at all. This is just one of a series of 'improvements' which have been making my web browsing increasingly troublesome recently. I don't particularly like Chrome, but it is rapidly becoming the better option in terms of basic usability. Please tell me there is a way to simply re-enable javascript - thank you!

Všetky odpovede (3)

more options

You do have some addons that can ruin webpages.

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

Please report back.

more options

The enable/disable JavaScript setting is global, so if it is off, you would be told about it by lots of sites. Probably the issue is something more site specific, such as the site's script being incompatible with one of your extensions.

I experimented with allowing/blocking scripts on the site, and it appears that if you block scorecardresearch, then the links for "More Reviews" and "See full review", and the previous and next buttons in the overlay, do not work. Instead, there is an error in the Error Console (Ctrl+Shift+j) that reads:

ReferenceError: COMSCORE is not defined
Source File: http://js01.media-allrecipes.com/js/bundles/v-2013.0821/main-site.compressed.min.js

If one of your extensions has an anti-tracking feature that blocks COMSCORE, then that probably is the culprit.

If blocking is more important than a nice user interface, you could use the less fancy separate reviews page by clicking the "Read Reviews" link to the right of the stars, then the "See all reviews" link that appears at the bottom of the first review to come up in the overlay.

more options

If you use extensions (Firefox/Tools > Add-ons > Extensions) that can block content (e.g. Adblock Plus, NoScript, Flash Block, Ghostery) then make sure that such extensions aren't blocking content.