Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Search By Name function is NOT WORKING.

more options

Before reading further, PLEASE take note of this: I have ALREADY installed the "Search By Name" add-on, and it DOES NOT WORK. As such, PLEASE do not suggest that add-on as a fix to my issue, since that add-on IS my issue.

I was using Firefox ESR 10.0.11 and was forced to upgrade to 17.0.7 yesterday, even though my cfg file is set to not allow updates. Since the upgrade, the Search by Name function has stopped working, i.e.: I used to be able to type "yahoo" into the address bar and go straight to yahoo; now, when I type anything that is not a complete URL into the address bar, it goes to allied.com. I have already gone into about:config and changed keyword:URL to http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= and have also installed the Search By Name add-on. Neither of these work. Please help me.

Before reading further, PLEASE take note of this: I have ALREADY installed the "Search By Name" add-on, and it DOES NOT WORK. As such, PLEASE do not suggest that add-on as a fix to my issue, since that add-on IS my issue. I was using Firefox ESR 10.0.11 and was forced to upgrade to 17.0.7 yesterday, even though my cfg file is set to not allow updates. Since the upgrade, the Search by Name function has stopped working, i.e.: I used to be able to type "yahoo" into the address bar and go straight to yahoo; now, when I type anything that is not a complete URL into the address bar, it goes to allied.com. I have already gone into about:config and changed keyword:URL to http://www.google.com/search?ie=UTF-8&oe=UTF-8&sourceid=navclient&gfns=1&q= and have also installed the Search By Name add-on. Neither of these work. Please help me.

Vybrané riešenie

Does that setting of the keyword.URL pref stay?

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (3)

more options

Vybrané riešenie

Does that setting of the keyword.URL pref stay?

If you do not keep changes after a restart or otherwise have problems with preferences, see:

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window or otherwise make changes.

Do a malware check with some malware scanning programs on the Windows computer.
Please scan with all programs because each program detects different malware.

Make sure that you update each program to get the latest version of their databases before doing a scan.

You can also do a check for a rootkit infection with TDSSKiller.

See also:

more options

Does this problem only affect one word searches?

Because Firefox checks DNS for one word queries (e.g., the type of domain you might have on an intranet), the DNS provider can hijack your search by returning their own site as a matching server. It's to "help" you by giving you more logical results than a bare 404 error, or so they say...

Upravil(a) jscher2000 - Support Volunteer dňa

more options

I ended up running MalwareBytes and Spybot S&D, and those didn't work. What ended up solving the issue was actually *removing* the Search By Name add-on, clearing out the keyword:URL field, and re-adding the keyword:URL entry. I hadn't thought of checking to make sure the keyword:URL actually stuck. Thanks for that.