X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

Táto téma bola uzamknutá a archivovaná. Ak potrebujete pomôcť, založte prosím novú otázku.

Conflict between Adobe Acrobat and Adobe Reader and how I fixed it

Pridané

For the past 5 years, I have owned Adobe Acrobat version 9, and recently installed Adobe Reader as well (version 10.7). I was previously able to set up Firefox to use Acrobat to display PDF files in the browser without downloading them, but I recently noticed that this was no longer the case. Instead, every PDF file I tried to view was being downloaded instead. I came here to find a solution, and discovered that many other people are having similar problems. I followed the instructions given here (https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them), but found that they were actually UNhelpful. They tell you to turn off the Firefox PDF viewer by editing about:config to disable the file pdfs.js, which is the native Firefox PDF viewer-- but that will cause the PDF file type to disappear from the Tools/Options dialog, so you can't assign it to another program (whether Adobe or anything else). This makes it impossible to assign the Adobe plugin to open PDF files. I did figure out a solution on my own, and wanted to post it here to help other users with the same problem.

I ultimately learned, through trial and error and a lot of research both here and on Adobe's website, that the root cause of my problem was a conflict in Firefox between Acrobat and Reader. I was able to solve it by upgrading Acrobat, getting rid of Reader and enabling the Firefox PDF viewer so that I could assign the PDF file type to the Acrobat plugin within Firefox. Here are the details of my problem and how I solved it:

1. Acrobat and Reader conflict with each other in Firefox, but this isn't totally Firefox's fault. It's mostly Adobe's fault, and they pretty much admit it. Specifically, they say that Acrobat and Reader can't coexist on the same machine unless both are version 10 or higher. They tell you to upgrade to solve the problem--but I can't afford to pay for a new version of Acrobat. If you have to keep Acrobat 9.x, Adobe says the lowest version of Reader that will work with it is Reader 11. I couldn't upgrade to this because I have Vista, and Adobe hasn't issued Reader 11 for Vista (and doesn't plan to). I did cheat and download the Win 7 version of Reader 11, but it didn't help.

2. If you have both Acrobat and Reader, you can choose a setting in Reader to make it the default PDF handler--but Firefox ignores this information and defaults to Acrobat no matter what. (This is the part we can blame Firefox for.) If you have a version of Acrobat which is below 9.5.5, Firefox actually blocks it as a security risk, so the plugin won't work at all, regardless of version number. That's why PDFs are being downloaded through your standalone program instead of being displayed in the browser. If you want to view PDFs in Firefox and keep Acrobat on your computer, you MUST upgrade Acrobat to version 9.5.5 or above.

3. Unless you can upgrade Acrobat to at least 10.x, GET RID OF READER. As long as you can access Acrobat 9.5.5, it will work fine in Firefox and there's no need for Reader. I never used to have Reader myself, only Acrobat, but it must have been downloaded automatically when Acrobat was blocked by Firefox (which I didn't even realize).

4. IF YOU NEED TO UPGRADE ACROBAT 9.X TO 9.5.5, YOUR LAST CHANCE IS TODAY--6/26/13. Adobe has announced that today is the "end of life" for the Acrobat 9.x platform, and all support and upgrades will cease after today.

When I searched for updates by going to Adobe's website, it told me there were none available--but when I checked for them FROM THE ACROBAT PROGRAM ITSELF (Help/Check for updates), I was offered a 300 MB upgrade that took me all the way from version 9.0 to 9.5.5 in one step. (It did take a very long time to download and install.)

5. Once you have Acrobat 9.5.5, this is how to enable it in Firefox:

a. INSIDE ACROBAT, set your preference for "Internet" to "view PDF files in browser." Close Acrobat. Close Firefox if it's already open.

b. Reopen Firefox. Check Tools/Add-Ons/Plugins to make sure the Acrobat plugin is there. Enable it if disabled. Close Firefox.

If the plugin isn't there at all, repair your Acrobat installation through Control Panel. Then return to Firefox and enable it. Close Firefox.

c. Reopen Firefox again. Go to Tools/Options and check the list of file types. For the names that contain "Adobe" and "Acrobat," Acrobat should be set as the default program to open them. Select it from the drop-down list if it's not. Continue to scroll through the alphabetical list--you should see another entry called Portable Document Format. If it's there, the default will be "preview in Firefox." You should be able to change this to "Acrobat (in Firefox)" using the drop-down menu. Do NOT pick the option that says "Acrobat"--this is the standalone program and will cause your PDFs to be downloaded.

If you don't see "Acrobat (in Firefox)" as an option, this means your plugin is not working. Go back and fix it using the instructions above (including repair of Acrobat if necessary).

d. If you don't see a file type for "Portable Document Format" at all, that means the Firefox PDF viewer is disabled. You must enable it by editing the about:config file. To see it, type about:config in the Firefox address bar. You will get a warning message--just click OK and keep going.

This file is a long list of statements in alphabetical order. LOOK FOR A STATEMENT THAT SAYS "pdfjs.disabled" with a Boolean value of "true." Select this statement and right-click. A context menu will offer you choices including "Toggle." Select that one, which will change the Boolean value to "false." Exit about:config. Close Firefox.

e. Now return to Tools/Options, scroll through the list of file types, and you should see "Portable Document Format." Select "Acrobat (in Firefox)" as in the instructions above. Close Firefox.

f. The first time you try to open a PDF file in Firefox, you may get a dialog box which offers you choices of how to open the file. The first will be Acrobat, but DON'T CHOOSE THAT--it will cause your PDF to download. Instead, go to the choice that says "Open as application/pdf." You don't need to change the program that opens this file type, because your settings are already correct. Your PDF should open in the browser, with the full-featured Acrobat menu (including the option of editing or saving the file).

I hope other users can benefit from the truly painful experience I had figuring all of this out. Good luck.

For the past 5 years, I have owned Adobe Acrobat version 9, and recently installed Adobe Reader as well (version 10.7). I was previously able to set up Firefox to use Acrobat to display PDF files in the browser without downloading them, but I recently noticed that this was no longer the case. Instead, every PDF file I tried to view was being downloaded instead. I came here to find a solution, and discovered that many other people are having similar problems. I followed the instructions given here (https://support.mozilla.org/en-US/kb/view-pdf-files-firefox-without-downloading-them), but found that they were actually UNhelpful. They tell you to turn off the Firefox PDF viewer by editing about:config to disable the file pdfs.js, which is the native Firefox PDF viewer-- but that will cause the PDF file type to disappear from the Tools/Options dialog, so you can't assign it to another program (whether Adobe or anything else). This makes it impossible to assign the Adobe plugin to open PDF files. I did figure out a solution on my own, and wanted to post it here to help other users with the same problem. I ultimately learned, through trial and error and a lot of research both here and on Adobe's website, that the root cause of my problem was a conflict in Firefox between Acrobat and Reader. I was able to solve it by upgrading Acrobat, getting rid of Reader and enabling the Firefox PDF viewer so that I could assign the PDF file type to the Acrobat plugin within Firefox. Here are the details of my problem and how I solved it: 1. Acrobat and Reader conflict with each other in Firefox, but this isn't totally Firefox's fault. It's mostly Adobe's fault, and they pretty much admit it. Specifically, they say that Acrobat and Reader can't coexist on the same machine unless both are version 10 or higher. They tell you to upgrade to solve the problem--but I can't afford to pay for a new version of Acrobat. If you have to keep Acrobat 9.x, Adobe says the lowest version of Reader that will work with it is Reader 11. I couldn't upgrade to this because I have Vista, and Adobe hasn't issued Reader 11 for Vista (and doesn't plan to). I did cheat and download the Win 7 version of Reader 11, but it didn't help. 2. If you have both Acrobat and Reader, you can choose a setting in Reader to make it the default PDF handler--but Firefox ignores this information and defaults to Acrobat no matter what. (This is the part we can blame Firefox for.) If you have a version of Acrobat which is below 9.5.5, Firefox actually blocks it as a security risk, so the plugin won't work at all, regardless of version number. That's why PDFs are being downloaded through your standalone program instead of being displayed in the browser. If you want to view PDFs in Firefox and keep Acrobat on your computer, you MUST upgrade Acrobat to version 9.5.5 or above. 3. Unless you can upgrade Acrobat to at least 10.x, GET RID OF READER. As long as you can access Acrobat 9.5.5, it will work fine in Firefox and there's no need for Reader. I never used to have Reader myself, only Acrobat, but it must have been downloaded automatically when Acrobat was blocked by Firefox (which I didn't even realize). 4. IF YOU NEED TO UPGRADE ACROBAT 9.X TO 9.5.5, YOUR LAST CHANCE IS TODAY--6/26/13. Adobe has announced that today is the "end of life" for the Acrobat 9.x platform, and all support and upgrades will cease after today. When I searched for updates by going to Adobe's website, it told me there were none available--but when I checked for them FROM THE ACROBAT PROGRAM ITSELF (Help/Check for updates), I was offered a 300 MB upgrade that took me all the way from version 9.0 to 9.5.5 in one step. (It did take a very long time to download and install.) 5. Once you have Acrobat 9.5.5, this is how to enable it in Firefox: a. INSIDE ACROBAT, set your preference for "Internet" to "view PDF files in browser." Close Acrobat. Close Firefox if it's already open. b. Reopen Firefox. Check Tools/Add-Ons/Plugins to make sure the Acrobat plugin is there. Enable it if disabled. Close Firefox. If the plugin isn't there at all, repair your Acrobat installation through Control Panel. Then return to Firefox and enable it. Close Firefox. c. Reopen Firefox again. Go to Tools/Options and check the list of file types. For the names that contain "Adobe" and "Acrobat," Acrobat should be set as the default program to open them. Select it from the drop-down list if it's not. Continue to scroll through the alphabetical list--you should see another entry called Portable Document Format. If it's there, the default will be "preview in Firefox." You should be able to change this to "Acrobat (in Firefox)" using the drop-down menu. Do NOT pick the option that says "Acrobat"--this is the standalone program and will cause your PDFs to be downloaded. If you don't see "Acrobat (in Firefox)" as an option, this means your plugin is not working. Go back and fix it using the instructions above (including repair of Acrobat if necessary). d. If you don't see a file type for "Portable Document Format" at all, that means the Firefox PDF viewer is disabled. You must enable it by editing the about:config file. To see it, type about:config in the Firefox address bar. You will get a warning message--just click OK and keep going. This file is a long list of statements in alphabetical order. LOOK FOR A STATEMENT THAT SAYS "pdfjs.disabled" with a Boolean value of "true." Select this statement and right-click. A context menu will offer you choices including "Toggle." Select that one, which will change the Boolean value to "false." Exit about:config. Close Firefox. e. Now return to Tools/Options, scroll through the list of file types, and you should see "Portable Document Format." Select "Acrobat (in Firefox)" as in the instructions above. Close Firefox. f. The first time you try to open a PDF file in Firefox, you may get a dialog box which offers you choices of how to open the file. The first will be Acrobat, but DON'T CHOOSE THAT--it will cause your PDF to download. Instead, go to the choice that says "Open as application/pdf." You don't need to change the program that opens this file type, because your settings are already correct. Your PDF should open in the browser, with the full-featured Acrobat menu (including the option of editing or saving the file). I hope other users can benefit from the truly painful experience I had figuring all of this out. Good luck.

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 11.7 r700
  • Next Generation Java Plug-in 10.25.2 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Google Talk Plugin Video Accelerator version:0.1.44.29
  • Version 4.0.3.13724
  • Google Update
  • Adobe PDF Plug-In For Firefox and Netscape "9.5.5"
  • iTunes Detector Plug-in
  • Adobe Shockwave for Director Netscape plug-in, version 12.0.2.122
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.
  • Amazon MP3 Downloader Plugin 1.0.17
  • LightshotPlugin
  • BlackBerry WebSL Browser Plug-In
  • RealPlayer Enterprise(tm) LiveConnect-Enabled Plug-In
  • Windows Presentation Foundation (WPF) plug-in for Mozilla browsers

Aplikácie

  • Firefox 22.0
  • Identifikácia prehliadača: Mozilla/5.0 (Windows NT 6.0; rv:22.0) Gecko/20100101 Firefox/22.0
  • URL adresa podpory: http://support.mozilla.org/1/firefox/22.0/WINNT/en-US/

Rozšírenia

  • Adblock Plus 2.1.1 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d})
  • Add Google Search To New Tab Page 1.0.2 (newtabgoogle@graememcc.co.uk)
  • DoNotTrackPlus 2.2.1.611 (donottrackplus@abine.com)
  • Googlebar Lite 4.9.1 ({79c50f9a-2ffe-4ee0-8a37-fae4f5dacd4f})
  • IE View 1.5.1 ({6e84150a-d526-41f1-a480-a67d3fed910d})
  • Image Zoom 0.4.6 ({1A2D0EC4-75F5-4c91-89C4-3656F6E44B68})
  • ImTranslator 5.5 ({9AA46F4F-4DC7-4c06-97AF-5035170634FE})
  • Lightshot (screenshot tool) 2.8.2 ({394DCBA4-1F92-4f8e-8EC9-8D2CB90CB69B})
  • Multirow Bookmarks Toolbar Plus 1.2 ({4c7097f7-08f2-4ef2-9b9f-f95fa4cbb064})
  • NoSquint 2.1.5 (nosquint@urandom.ca)
  • Open in Browser 1.11 (openinbrowser@www.spasche.net)
  • Places’ Tooltips 3.0.20110409 ({46136bce-f897-43d4-b3df-5e51562f4923})
  • Saved Password Editor 2.6.3 (savedpasswordeditor@daniel.dawson)
  • TinyURL Generator 2.6.1 (tinyurl.addon@fast-chat.co.uk)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • Microsoft .NET Framework Assistant 1.2.1 ({20a82645-c095-46ed-80e3-08825760534b}) (Neaktívny)
  • Multirow Bookmarks Toolbar 5.0.1 ({FBF6D7FB-F305-4445-BB3D-FEF66579A033}) (Neaktívny)
  • Tooltip Plus 0.2.0 ({f2e5baa8-0711-4113-830c-1b3debd6f2a5}) (Neaktívny)

JavaScript

  • incrementalGCEnabled: True

Grafika

  • adapterDescription: Mobile Intel(R) 4 Series Express Chipset Family
  • adapterDescription2:
  • adapterDeviceID: 0x2a42
  • adapterDeviceID2:
  • adapterDrivers: igdumdx32 igd10umd32
  • adapterDrivers2:
  • adapterRAM: Unknown
  • adapterRAM2:
  • adapterVendorID: 0x8086
  • adapterVendorID2:
  • direct2DEnabled: False
  • direct2DEnabledMessage: [u'']
  • directWriteEnabled: False
  • directWriteVersion: 7.0.6002.18592
  • driverDate: 2-11-2011
  • driverDate2:
  • driverVersion: 8.15.10.2302
  • driverVersion2:
  • info: {u'AzureCanvasBackend': u'skia', u'AzureFallbackCanvasBackend': u'cairo', u'AzureContentBackend': u'none'}
  • isGPU2Active: False
  • numAcceleratedWindows: 0
  • numAcceleratedWindowsMessage: [u'']
  • numTotalWindows: 2
  • webglRenderer: Google Inc. -- ANGLE (Mobile Intel(R) 4 Series Express Chipset Family)
  • windowLayerManagerType: Basic

Upravené nastavenia

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.capacity: 358400
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.display.background_color: #C0C0C0
  • browser.display.use_system_colors: True
  • browser.fixup.alternate.enabled: False
  • browser.history_expire_days.mirror: 20
  • browser.places.smartBookmarksVersion: 4
  • browser.search.update: False
  • browser.startup.homepage: www.yahoo.com
  • browser.startup.homepage_override.buildID: 20130618035212
  • browser.startup.homepage_override.mstone: 22.0
  • browser.tabs.warnOnClose: False
  • browser.zoom.siteSpecific: False
  • dom.max_script_run_time: 1800
  • dom.mozApps.used: True
  • extensions.lastAppVersion: 22.0
  • font.internaluseonly.changed: False
  • general.useragent.extra.microsoftdotnet: ( .NET CLR 3.5.30729; .NET4.0C)
  • gfx.direct2d.disabled: True
  • layers.acceleration.disabled: True
  • network.cookie.cookieBehavior: 1
  • network.cookie.lifetimePolicy: 2
  • network.cookie.prefsMigrated: True
  • places.database.lastMaintenance: 1372258054
  • places.history.expiration.transient_current_max_pages: 79251
  • places.last_vacuum: 1342407016
  • plugin.disable_full_page_plugin_for_types: application/vnd.fdf,application/vnd.adobe.xdp+xml,application/vnd.adobe.xfdf
  • plugin.importedState: True
  • plugin.state.npnitromozilla: 0
  • plugin.state.nppdf: 2
  • plugin.state.nppdfviewer: 0
  • privacy.donottrackheader.enabled: True
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 2
  • security.warn_viewing_mixed: False
  • storage.vacuum.last.index: 1
  • storage.vacuum.last.places.sqlite: 1371167054

Ostatné

  • User JS: Nie
  • Prístupnosť: Áno
Tyler Downer
  • Top 25 Contributor
  • Moderator
1538 riešení 10733 odpovedí

Since it doesn't seem like you are looking for support, locking this thread.

Since it doesn't seem like you are looking for support, locking this thread.