Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

browser freezes after resuming from sleep

  • 96 odpovedí
  • 153 má tento problém
  • 23656 zobrazení
  • Posledná odpoveď od tuckfoot

more options

Hello,

FF 21.0 Browser freezes after resuming from sleep. What would cause FF 21.0 Browser to freezes after resuming from sleep?

Thanks,

Vybrané riešenie

Hello John99,

I have been following since I started thread. For me, the browser would freeze if I left it open when the computer went to sleep. So I would minimize the browser before putting computer to sleep. But if the computer was in sleep for along time (2 to 4 hours) minimizing didn't prevent the browser from freezing.

I just now Updated 8-14-13 to Firefox 23 I will see if the problem still exist.

If Firefox 23 fixes the problem I will Mark thread as solved.

Thank You,

jorb

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (20)

more options

I quite like the idea of more users trying the Beta channel.

I think it is pretty stable and suitable for day-to-day use. It has the big advantage of always having a tried tested and secure downgrade option.

Pity they do not reintroduce the UI channel switcher that they experimented with a while ago.

more options

July 19, 2013

I finally fixed the Firefox freeze problem today. Had FF 22, Windows 7. So damn tired of the damn Firefox freeze because if I had tabs open I'd have to X out and lose them. The checkbox for hardware acceleration makes no difference.

The fix was very simple. Uninstall Java. Uninstall FF. Restart computer. Find and download Firefox20 Beta 4. Go to java dot com and re-install Java and the problem is fixed.

Done. Tired of screwing around with this and having to set my computer never to sleep, because I'm a busy guy and glad I fixed it.

more options

P.S. - When you uninstall Firefox, make sure you don't check the box that erases your personal data. It'll be obvious during the wizard so it's foolproof.

more options

Hi bayouboogie, rolling back to a vulnerable version of Firefox is only a short-term wokraround. You might want to try the beta of Firefox 23, which others have confirmed to work for them earlier in this thread.

http://www.mozilla.org/en-US/firefox/all-beta.html

more options

I advocated the FF 20 Beta 4 because it worked perfectly the first time I invented the fix and tried it. I remembered specifically that the problem started with FF21 and so I decided at last to go back to the last version that I KNEW worked. I was 100% on the mark, in my case at least.

I tried everything, and I am quite methodical about what I do. The FF 20 Beta 4 fix works perfectly for me. The hardware acceleration checkbox does nothing for the problem.

I put up with this major pain in the butt for too long and finally solved it for myself. I am a happy camper now with my fix.

That said, are you telling me that FF 23 has fixed the bug? That would be great!

I am very busy right now, but when I get a chance, I will try it and post back my results.

Anyone else trying the beta 23, please report back.

As to your Java question, I'm not sure there is a connection at all. I just decided that if I was going to do a clean FF 20 b4 install, I wanted Java stripped out and reinstalled too. Let me say that I stripped out Java several times in the last couple months to address the freeze, but it didn't help.

IMO, Firefox itself was the problem

FF20b4 - no problem, and I'm happy as a clam now.

more options

Yes, it was mentioned two posts above yours (and others before) that FF23 fixes it. :)

For me, disabling the protected mode has worked so far, but I'm still testing.

more options

Thanks!

For now, as the FF20 Beta 4 fix is working perfectly with my Windows 7, the work is done. I will hang fire and monitor this thread until the regular FF 23 release on Aug. 6, if I read correctly above. On principle, I'm not going to fool with Flash or whatever; Firefox either works or it doesn't.

In the meantime, if anyone has problems with the FF23 Beta, please holler!

more options

The problem so far as I can tell is with power management settings. I'm not sure what the technical breakdown is or what's going on internally, but changing the PM settings fixes the issue for me.

To recap:

The issue - Firefox visually freezes after the computer resumes from standby mode. Manually activating standby doesn't seem to cause the bug as consistently as the computer being left idle and to its own whim. When affected, users can click on the browser window as if everything was normal; tabs will update, pages will load, but the main GUI remains "frozen". The GUI is redrawn when the user changes focus to a non-Firefox window.

The cause - Windows Power Management settings adjusts the power provided to various hardware depending on whether the computer (which is generally a laptop) is on A/C or battery power and active or in standby mode. A combination of battery power supply and standby mode cuts the activity of some undetermined hardware. Firefox either attempts to catch-up, or waits for this hardware to resume, resulting in a similar behaviour to a hanging script.

The solution - Go to your control panel, into Power Options, and click on the Power Schemes tab. Change the power scheme drop-down to the "Minimal Power Management" option. You can manually adjust the times, but if the scheme is left on laptop, you will have issues with wifi adapters and Firefox.

Please post back and report if this does or doesn't work for you.

Cheers

more options

I just figured out that the Flash protected mode setting didn't make any difference on mine.

Also mine freezes when on AC power as well.

more options

It might not be FF problem. I have the same problem, but for me also IE and Chrome freeze. I have win7 (64bit) dell xps computer. The steps are the same 1. close lid (AC power) 2. take out AC power 3. put AC power back on and open lid 4. all browsers are frozen. The browser in general is not frozen. I mean I can open new browser windows (not tabs) and they work fine. But previously opened browser windows are all frozen. Would be nice if one browser wouldn't do that. Also my friend has the same laptop and he has the same problem. He has win8

Upravil(a) vuhuuu dňa

more options

This problem started for me as soon as I upgraded to ff 22. It does not happen to any other program...so i am using chrome to type this, which does not have the problem.

only thing i can do to fix it is go to task manager, end the ff process, reboot ff and restore windows. hope it gets fixed soon in a non-beta release. i'd hate to have to use chrome as my default browser, but this is a major annoyance.

more options

Hi did you read the rest of the thread? This has been fixed in Firefox 23 released next month.

Update: August 6, 2013

Upravil(a) kobe dňa

more options

oops missed the release date above. glad to hear its fixed and sorry for the extra noise

more options

I have the same problem with the freeze after sleep running FF22 is there a fix that can be installed rather than wait for FF23. Its a huge time consumer and just generally a pain. Have to close FF and restart. I refuse to use explorer and prefer not going to Chrome. Thanks.

more options

you can try firefox beta? which is version 23

more options

Adding more fuel to the fire... I hope that FF 23 fixes all the problems. Just in case it does not, here is yet another possible solution. Are you users of iGoogle? I have noticed the when IGoogle is not active, the "sleep" problem seems to disappear. I do not know if it is iGoogle itself or some gadget inside it, but the absences of iGoogle seems to makes a difference.

more options

it has not been fixed, i still have this freezing issue in latest update version 23 too.

more options

This is along thread and some of the questions may not relate to the original title. The main problem has been solved for most users in Firefox 23. Anyone still having a problem please start a new thread.

If you have already posted in this thread and start a new question you may wish to mention it here so that others may follow progress on any other issue.

N.B.

  • open bug UNCONFIRMED: Bug 904958 - [Mac] UI stops painting after resuming from sleep

Upravil(a) John99 dňa

more options

jorb,

Are you still following this. Is it now fixed in Firefox 23 for you ?

more options

Vybrané riešenie

Hello John99,

I have been following since I started thread. For me, the browser would freeze if I left it open when the computer went to sleep. So I would minimize the browser before putting computer to sleep. But if the computer was in sleep for along time (2 to 4 hours) minimizing didn't prevent the browser from freezing.

I just now Updated 8-14-13 to Firefox 23 I will see if the problem still exist.

If Firefox 23 fixes the problem I will Mark thread as solved.

Thank You,

jorb

  1. 1
  2. 2
  3. 3
  4. 4
  5. 5