Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

how to force firefox to use unicode utf character encoding

  • 10 odpovedí
  • 34 má tento problém
  • 18 zobrazení
  • Posledná odpoveď od cor-el

more options

i post on a multi lingual site so i need firefox to use unicode character encoding. firefox displays the forum in the wrong character encoding. im forced to manually select unicode utf-8 character encoding for every page.

how do i force firefox to POST and GET in utf-8?

i post on a multi lingual site so i need firefox to use unicode character encoding. firefox displays the forum in the wrong character encoding. im forced to manually select unicode utf-8 character encoding for every page. how do i force firefox to POST and GET in utf-8?

Všetky odpovede (10)

more options

If Firefox uses the wrong encoding then this usually means that the server sends an encoding via the HTTP response header, but the website may be specifying another encoding in the file.
You can check this via Tools > Page Info > General
You will have to change the encoding manually in this case via the Web Developer menu.

Alternatively you can set the browser.menu.showCharacterEncoding pref to true for easier access via the Firefox menu button or View menu.

more options

how do you change the character encoding in "Web Developer"?

browser.menu.showCharacterEncoding in about:config set to true. dont know what it did, if anything.

in a forum viewing hundreds of messages, setting character encoding manually for each message??? firefox reverts from utf-8 with every page/message.

firefox should do what i want it to. i want firefox to ignore the character encoding in the http headers. i want firefox to display the page in utf-8 (at the very least). i want firefox to post in utf-8 (at the most).

linux firefox displays the forum in utf-8. windows-xp firefox doesnt. so, how do i force firefox to use utf-8 (and ignore character encoding in http headers from server).

more options

What I meant is the Web Developer sub menu in the Firefox menu button list or the Tools menu if the menu bar is visible.
Then you see a Character Encoding entry in the Web Developer sub menu.

more options

im using firefox esr 17

browser.menu.showCharacterEncoding set true

there is NO "Character Encoding" menu under "Tools > Web Developer" menu. there IS "Character Encoding" menu under "View > Character Encoding".

from "View > Character Encoding" i can see that firefox keeps reverting from "unicode (utf-8)" to "western (iso-8859-1)". from "Tools > Page Info > General" i can see that Encoding: ISO-8859-1 Content-Type: text/html; charset=ISO-8859-1

linux firefox displays the forum in utf-8. windows-xp firefox does not. its set to utf-8 then reverts to iso-8859-1 for every referesh or click.

i have changed the user agent to linux, it hasnt helped. Mozilla/5.0 (X11; Linux i686; rv:17.0) Gecko/20100101 Firefox/17.0

i want to force firefox to use utf-8 only! how do i do that.

Upravil(a) youteeff8 dňa

more options

Sorry for the confusion.

If you enable the pref then you only get this item directly under the orange Firefox menu button in addition to the Web Developer menu.
If the menu bar is visible then you have it in the View menu.


  • Firefox > Web Developer > Character Encoding
  • View > Character Encoding
more options

Firefox will always use the encoding as set via the HTTP response headers.

See:

more options

is it possible to move past the discussion on the menu. ive set the encoding to "unicode utf-8" using

  • View > Character Encoding

but it keeps reverting to "western iso-8859-1"

Upravil(a) youteeff8 dňa

more options

Content Preferences addon has not helped.

so firefox will override user settings, making the forum unreadable. i thought firefox was software customisable to user requirements.

if anyone has similar problems, in about:config replacing all western iso-8859-1 references with unicode utf-8 does not help.

more options

What should be the character encoding? Mine shows unicode, and I didn't change a thing, but I am having massive problems with FF when the plug in loaded, it interferes with the loading of ordinary pages not requiring a flash plugin, and sometimes the error message appears several times before the page is loaded.

This happens on each and every loading of a window, but when I uninstall the plugin, the pages load properly and normally but I cannot run any game or video, or u-tube..

more options

Hi snoekie1

Could you please start a new thread instead of posting in an existing thread?

Then you can provide more information like your operating system and installed extensions and installed plugins.


What kind of error message do you see?

Can you attach a screenshot?

Use a compressed image type like PNG or JPG to save the screenshot.

Note that you can't attach a screenshot to the first post that starts a thread, but you can do that in subsequent replies.