X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

As of today, Firefox windows no longer resizeable! OSX 10.6.8, Firefox 20.0

Pridané

As title suggests, the resize control on lower right corner of all Firefox windows is gone!

As title suggests, the resize control on lower right corner of all Firefox windows is gone!

Vybrané riešenie

Hardware Acceleration is no longer present as a user-settable option on Firefox 20 under OSX - Accessibility is the first sub-heading under Advanced.

Is the screen shot here out of date?

https://support.mozilla.org/en-US/kb/advanced-settings-browsing-network-updates-encryption#os=mac&browser=fx20

Čítať túto odpoveď v kontexte 1

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • Shockwave Flash 11.7 r700
  • Displays Java applet content, or a placeholder if Java is not installed.
  • DivX VOD Helper Plug-in
  • DivX Plus Web Player version 2.2.2.14
  • Version 3.3.3.8675
  • Google Talk Plugin Video Accelerator version:0.1.44.16
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in web pages. For more information, visit the QuickTime Web site.
  • Picasa plugin.
  • Microsoft Office for Mac SharePoint Browser Plug-in

Aplikácie

  • Firefox 20.0
  • Identifikácia prehliadača: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:20.0) Gecko/20100101 Firefox/20.0
  • URL adresa podpory: http://support.mozilla.org/1/firefox/20.0/Darwin/en-US/

Rozšírenia

  • Adblock Plus Pop-up Addon 0.7 (adblockpopups@jessehakanen.net)
  • Cookies Export/import 1.0 (CookiesIE@yahoo.com)
  • Delicious Bookmarks 2.3.4 ({2fa4ed95-0317-4c6a-a74c-5f3e3912c1f9})
  • Diccionario de Español/España 1.5 (es-es@dictionaries.addons.mozilla.org)
  • DivX Plus Web Player HTML5 <video> 2.1.2.172 ({23fcfd51-4958-4f00-80a3-ae97e717ed8b})
  • DoNotTrackMe 2.2.8.307 (donottrackplus@abine.com)
  • DownloadHelper 4.9.14 ({b9db16a4-6edc-47ec-a1f4-b86292ed211d})
  • Fasterfox 3.9.81 ({c36177c0-224a-11da-8cd6-0800200c9a91})
  • Firebug 1.11.2 (firebug@software.joehewitt.com)
  • FoxyProxy Basic 3.2 (foxyproxy-basic@eric.h.jung)
  • Greasemonkey 1.8 ({e4a8a97b-f2ed-450b-b12d-ee082ba24781})
  • History Export 0.4 (histexp@cycledlm.gmail.com)
  • HTTPS-Everywhere 3.1.4 (https-everywhere@eff.org)
  • iMacros for Firefox 8.3.0 ({81BF1D23-5F17-408D-AC6B-BD6DF7CAF670})
  • TinyURL Generator 2.6.1 (tinyurl.addon@fast-chat.co.uk)
  • Troubleshooter 1.1a (troubleshooter@mozilla.org)
  • YSlow 3.1.4 (yslow@yahoo-inc.com)
  • Adblock Plus 2.2.3 ({d10d0bf8-f5b5-c8b4-a8b2-2b9879e08c5d}) (Neaktívny)

JavaScript

  • incrementalGCEnabled: True

Grafika

  • adapterDescription:
  • adapterDeviceID: 0x 126
  • adapterDrivers:
  • adapterRAM:
  • adapterVendorID: 0x8086
  • driverDate:
  • driverVersion:
  • info: {u'AzureCanvasBackend': u'quartz', u'AzureFallbackCanvasBackend': u'none', u'AzureContentBackend': u'none'}
  • numAcceleratedWindows: 1
  • numTotalWindows: 1
  • webglRenderer: Intel Inc. -- Intel HD Graphics 3000 OpenGL Engine
  • windowLayerManagerType: OpenGL

Upravené nastavenia

  • accessibility.typeaheadfind.flashBar: 0
  • browser.cache.disk.smart_size.first_run: False
  • browser.cache.disk.smart_size.use_old_max: False
  • browser.cache.disk.smart_size_cached_value: 358400
  • browser.cache.memory.capacity: 1048576
  • browser.places.smartBookmarksVersion: 4
  • browser.privatebrowsing.dont_prompt_on_enter: True
  • browser.search.update: False
  • browser.search.useDBForOrder: True
  • browser.startup.homepage: https://duckduckgo.com/
  • browser.startup.homepage_override.buildID: 20130326150557
  • browser.startup.homepage_override.mstone: 20.0
  • browser.tabs.warnOnClose: False
  • browser.urlbar.default.behavior: 1
  • browser.urlbar.maxRichResults: 8
  • dom.mozApps.used: True
  • dom.w3c_touch_events.expose: False
  • extensions.lastAppVersion: 20.0
  • font.internaluseonly.changed: True
  • font.language.group: x-western
  • gfx.blacklist.webgl.msaa: 4
  • network.cookie.prefsMigrated: True
  • network.http.max-connections-per-server: 16
  • network.http.max-persistent-connections-per-server: 4
  • network.http.pipelining.firstrequest: False
  • network.http.pipelining.ssl: True
  • places.database.lastMaintenance: 1366649891
  • places.history.expiration.transient_current_max_pages: 104858
  • plugin.disable_full_page_plugin_for_types: application/pdf
  • privacy.cpd.cookies: False
  • privacy.cpd.formdata: False
  • privacy.cpd.offlineApps: True
  • privacy.cpd.sessions: False
  • privacy.donottrackheader.enabled: True
  • privacy.popups.disable_from_plugins: 0
  • privacy.sanitize.migrateFx3Prefs: True
  • privacy.sanitize.timeSpan: 0
  • security.warn_viewing_mixed: False

Ostatné

  • User JS: Nie
  • Prístupnosť: Nie
iamjayakumars 489 riešení 5951 odpovedí

Make sure that your Not using Full Screen Mode, Hit F11 key to get back to normal mode.

See also

Hello,

Try Firefox Safe Mode to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons.

(If you're not using it, switch to the Default theme.)

  • You can open Firefox 4.0+ in Safe Mode by holding the Shift key when you open the Firefox desktop or Start menu shortcut.
  • Or open the Help menu and click on the Restart with Add-ons Disabled... menu item while Firefox is running.

Once you get the pop-up, just select "'Start in Safe Mode"

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, and you need to figure out which one. Please follow the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article for that.

To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.

When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.

Thank you.

Make sure that your Not using Full Screen Mode, Hit F11 key to get back to normal mode. See also *http://kb.mozillazine.org/Resizing_oversize_window Hello, '''Try Firefox Safe Mode''' to see if the problem goes away. Safe Mode is a troubleshooting mode, which disables most add-ons. ''(If you're not using it, switch to the Default theme.)'' * You can open Firefox 4.0+ in Safe Mode by holding the '''Shift''' key when you open the Firefox desktop or Start menu shortcut. * Or open the Help menu and click on the '''Restart with Add-ons Disabled...''' menu item while Firefox is running. ''Once you get the pop-up, just select "'Start in Safe Mode"'' '''''If the issue is not present in Firefox Safe Mode''''', your problem is probably caused by an extension, and you need to figure out which one. Please follow the [[Troubleshooting extensions and themes]] article for that. ''To exit the Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.'' ''When you figure out what's causing your issues, please let us know. It might help other users who have the same problem.'' Thank you.
cor-el
  • Top 10 Contributor
  • Moderator
17519 riešení 158412 odpovedí

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: command+Shift+F).

Make sure that you do not run Firefox in full screen mode (press F11 or Fn + F11 to toggle; Mac: command+Shift+F). *https://support.mozilla.org/kb/how-to-use-full-screen

Autor otázky

Thanks - the problem is not the mode - the problem is that Firefox & Firefox alone, with no add-on updates or anything - magically started deleting the resize control from its window-frame this afternoon.

Thanks - the problem is not the mode - the problem is that Firefox & Firefox alone, with no add-on updates or anything - magically started deleting the resize control from its window-frame this afternoon.

Autor otázky

Thanks - it's not in full-screeen mode - the window is supressing the resize control and there is no adequate exposed firefox configuration parameter in about:config, apparently.

Thanks - it's not in full-screeen mode - the window is supressing the resize control and there is no adequate exposed firefox configuration parameter in about:config, apparently.
jscher2000
  • Top 10 Contributor
8758 riešení 71655 odpovedí

If you create a new window from the menu or by pressing Command+n, is that one resizable? Does it matter whether the window is maximized?

Edit: That was a dumb question: maximized windows are never resizable. Never mind.

If you create a new window from the menu or by pressing Command+n, is that one resizable? <s>Does it matter whether the window is maximized?</s> ''Edit: That was a dumb question: maximized windows are never resizable. Never mind.''

Upravil(a) jscher2000 dňa

jscher2000
  • Top 10 Contributor
8758 riešení 71655 odpovedí

By the way, on Windows, the window is resizable even if no "grippy" is displayed in the corner. Are you able to get the double-headed arrow by mousing over the corner or is your mouse pointer ignored?

By the way, on Windows, the window is resizable even if no "grippy" is displayed in the corner. Are you able to get the double-headed arrow by mousing over the corner or is your mouse pointer ignored?

Autor otázky

Actually, Firefox's 'maximized' windows are not correctly maximized on OSX, so they still have an active resize border - but that is gone in this case regardless of whether the window is 'maxed' or not, and no matter how created - i.e. w. Apple-N, a new window request from the window menu, or first launching the app.

Actually, Firefox's 'maximized' windows are not correctly maximized on OSX, so they still have an active resize border - but that is gone in this case regardless of whether the window is 'maxed' or not, and no matter how created - i.e. w. Apple-N, a new window request from the window menu, or first launching the app.

Autor otázky

I should mention that despite this, 'full-screen' (or kiosk mode as it used to be known in Windows) is not realizable at all on OSX...

I should mention that despite this, 'full-screen' (or kiosk mode as it used to be known in Windows) is not realizable at all on OSX...

Autor otázky

..and to clarify (yup - I've been coding since this stuff was all codified by IBM in the CUA) the sizing border is altogether gone - i.e. to me it looks like a somewhat hidden setting that some annoying extension set, or a broken item on a silent respin, or something...

..and to clarify (yup - I've been coding since this stuff was all codified by IBM in the CUA) the sizing border is altogether gone - i.e. to me it looks like a somewhat hidden setting that some annoying extension set, or a broken item on a silent respin, or something...
jscher2000
  • Top 10 Contributor
8758 riešení 71655 odpovedí

Sometimes the file that stores toolbar customizations and window sizes becomes corrupted and causes inexplicable UI issues. You can rename the file and customize from scratch.

Open your current Firefox settings (AKA Firefox profile) folder using

Help > Troubleshooting Information > "Show in Finder" button

Switch back to Firefox and Exit

Pause while Firefox finishes its cleanup, then rename localstore.rdf to something like localstore.old.

Restart Firefox. Do windows appear normal? If not, and you miss your customizations, you could reverse the process and restore your localstore.old file.

If you can't help wanting to open the file, look for this and see whether sizemode="normal" and the dimensions make sense:

"chrome://browser/content/browser.xul#main-window"
Sometimes the file that stores toolbar customizations and window sizes becomes corrupted and causes inexplicable UI issues. You can rename the file and customize from scratch. Open your current Firefox settings (AKA Firefox profile) folder using Help > Troubleshooting Information > "Show in Finder" button Switch back to Firefox and Exit Pause while Firefox finishes its cleanup, then rename '''localstore.rdf''' to something like localstore.old. Restart Firefox. Do windows appear normal? If not, and you miss your customizations, you could reverse the process and restore your localstore.old file. If you can't help wanting to open the file, look for this and see whether sizemode="normal" and the dimensions make sense: "chrome://browser/content/browser.xul#main-window"

Autor otázky

Interesting... - I tried it, but no sizing control still. OTOH, I started it in safe mode, and voila! - So it must be one of my add-ons doing something unwanted under the covers... Oh joy.

Thanks for all the help, jscher. I guess I'll kill another hour or so restarting with batches of add-ons disabled until I see which one.

Interesting... - I tried it, but no sizing control still. OTOH, I started it in safe mode, and voila! - So it must be one of my add-ons doing something unwanted under the covers... Oh joy. Thanks for all the help, jscher. I guess I'll kill another hour or so restarting with batches of add-ons disabled until I see which one.

Autor otázky

OK - Now it's decidedly a coding issue: So when I restart in safe-mode from the help menu, I get my beloved sizing border back. However, when I restart in normal mode again, it's gone again. So, naturally, I went ahead & disabled every add-on and every plug-in, and restarted (in normal mode with every plug-in and every add-on disabled) and the sizing control is gone, yet when I restart in 'safe mode' it's back. So what does safe-mode do beyond disabling add-ons and plugins? I'm restarting now to see if I can find the difference...

OK - Now it's decidedly a coding issue: So when I restart in safe-mode from the help menu, I get my beloved sizing border back. However, when I restart in normal mode again, it's gone again. So, naturally, I went ahead & disabled every add-on and every plug-in, and restarted (in normal mode with every plug-in and every add-on disabled) and the sizing control is gone, yet when I restart in 'safe mode' it's back. So what does safe-mode do beyond disabling add-ons and plugins? I'm restarting now to see if I can find the difference...

Autor otázky

So it's an OpenGL problem - safe-mode does not 'just' disable all add-ons, it also turns off OpenGL - actually, switches GPU Accelerated Windows setting from '1/1 OpenGL' to '0/1 Basic', and that fixes the problem. Only trouble is figuring out whether there are user-accessible setting to control that. This post looks the business, but unfortunately there is no gfx.font_rendering.directwrite.enabled parameter in my config, so...

So it's an OpenGL problem - safe-mode does not 'just' disable all add-ons, it also turns off OpenGL - actually, switches GPU Accelerated Windows setting from '1/1 OpenGL' to '0/1 Basic', and that fixes the problem. Only trouble is figuring out whether there are user-accessible setting to control that. [http://www.addictivetips.com/internet-tips/enable-firefox-hardware-accelerated-graphics/ This post] looks the business, but unfortunately there is no gfx.font_rendering.directwrite.enabled parameter in my config, so...
jscher2000
  • Top 10 Contributor
8758 riešení 71655 odpovedí

Užitočné odpovede

Does the hardware acceleration checkbox reach that setting?

Firefox menu > Preferences > Advanced > General

Uncheck "Use hardware acceleration when available"

A restart usually is necessary for that to take effect.

Does the hardware acceleration checkbox reach that setting? Firefox menu > Preferences > Advanced > General Uncheck "Use hardware acceleration when available" A restart usually is necessary for that to take effect.

Autor otázky

Hardware Acceleration is no longer present as a user-settable option on Firefox 20 under OSX - Accessibility is the first sub-heading under Advanced.

Hardware Acceleration is no longer present as a user-settable option on Firefox 20 under OSX - Accessibility is the first sub-heading under Advanced.
jscher2000
  • Top 10 Contributor
8758 riešení 71655 odpovedí

Vybrané riešenie

Hardware Acceleration is no longer present as a user-settable option on Firefox 20 under OSX - Accessibility is the first sub-heading under Advanced.

Is the screen shot here out of date?

https://support.mozilla.org/en-US/kb/advanced-settings-browsing-network-updates-encryption#os=mac&browser=fx20

''Hardware Acceleration is no longer present as a user-settable option on Firefox 20 under OSX - Accessibility is the first sub-heading under Advanced.'' Is the screen shot here out of date? https://support.mozilla.org/en-US/kb/advanced-settings-browsing-network-updates-encryption#os=mac&browser=fx20

Autor otázky

Wow! - No - I had completely missed it under the Browsing header because I saw screenshots that showed it up top under its own heading, such as here. Beautiful - that brought back my sizing control AND sped up my display slightly (from 19 to 21fps - Chrome does 60fps... lol) as tested here

Wow! - No - I had completely missed it under the Browsing header because I saw screenshots that showed it up top under its own heading, such as [http://www.techlivez.com/2011/03/how-to-enabledisable-gpu-acceleration-in-ie-chrome-firefox/ here]. Beautiful - that brought back my sizing control AND sped up my display slightly (from 19 to 21fps - Chrome does 60fps... lol) as tested [http://www.techlivez.com/2011/03/how-to-enabledisable-gpu-acceleration-in-ie-chrome-firefox/ here]

Autor otázky

So I guess this is another Firefox bug. I tested it on OSX 10.7 and it does not happen there, but Firefox 20 on OSX 10.6 is a little unusable. It's unfortunate that show-stopping bugs slip through the cracks so frequently. Were it not for the great delicious plugin, I think I would have abandoned Firefox a while ago due to this sort of thing being pretty common with new releases. Now, after recovering the ability to size Firefox windows, youtube videos don't play... Sigh

So I guess this is another Firefox bug. I tested it on OSX 10.7 and it does not happen there, but Firefox 20 on OSX 10.6 is a little unusable. It's unfortunate that show-stopping bugs slip through the cracks so frequently. Were it not for the great delicious plugin, I think I would have abandoned Firefox a while ago due to this sort of thing being pretty common with new releases. Now, after recovering the ability to size Firefox windows, youtube videos don't play... Sigh
jscher2000
  • Top 10 Contributor
8758 riešení 71655 odpovedí

Hi xilantro, turning off Firefox's use of hardware graphics acceleration shouldn't have any (negative) effect on the Flash player.

Is the problem only on the YouTube site itself, or does it extend to embedded YouTube videos on other sites (e.g., this page: Where to find and manage downloaded files in Firefox).


You might try YouTube in Firefox's Safe Mode, a diagnostic tool to bypass interference by extensions (and some custom settings). More info: Troubleshoot Firefox issues using Safe Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

Hi xilantro, turning off Firefox's use of hardware graphics acceleration shouldn't have any (negative) effect on the Flash player. Is the problem only on the YouTube site itself, or does it extend to embedded YouTube videos on other sites (e.g., this page: [[Find and manage downloaded files]]). ---- You might try YouTube in Firefox's Safe Mode, a diagnostic tool to bypass interference by extensions (and some custom settings). More info: [[Troubleshoot Firefox issues using Safe Mode]]. You can restart Firefox in Safe Mode using Help > Restart with Add-ons Disabled In the dialog, click "Start in Safe Mode" (''not'' Reset) Any difference?

Autor otázky

Hi again, jscher2000. Flash player is working fine, as are other video sites such as vimeo. Having just come out of the previous 'turn off all extensions' round trip only to find that Firefox 20 does not work on OSX 10.6 with graphics acceleration turned on, I had neglected this step. You were right. Disabling all add-ons gets youtube running again. Now to narrow it down.

What verbiage would you use to search bugzilla for the OSX 10.6 w. Firefox 20.0 bug I found? I want to report it, and have not seen a dupe there, but better to be sure.

Hi again, jscher2000. Flash player is working fine, as are other video sites such as vimeo. Having just come out of the previous 'turn off all extensions' round trip only to find that Firefox 20 does not work on OSX 10.6 with graphics acceleration turned on, I had neglected this step. You were right. Disabling all add-ons gets youtube running again. Now to narrow it down. What verbiage would you use to search bugzilla for the OSX 10.6 w. Firefox 20.0 bug I found? I want to report it, and have not seen a dupe there, but better to be sure.