Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I correct this? Error: TypeError: netscape.security.PrivilegeManager is undefined

  • 16 odpovedí
  • 128 má tento problém
  • 72121 zobrazení
  • Posledná odpoveď od sankeepan

more options

Every time I log on to the internet this come up: Error: TypeError: netscape.security.PrivilegeManager is undefined. How can I get rid of it? Thanks

Vybrané riešenie

I Finally fixed this Babylon thing, ok so what I did was I installed the entire program (yes, you read right), then I uninstalled it using Revo uninstaller. I figured, it couldn't be worse than what it already was, and going and reading up on the same solutions, didn't really help me much it just frustrated me more, because babylon stayed on as my search engin. Now it is off, YAY, the entire thing, with hidden cookies ect... Revo uninstaller saved my sanity...

Čítať túto odpoveď v kontexte 👍 8

Všetky odpovede (16)

more options

hello larry806, this error is most likely caused by an outdated extension - to check that, please launch firefox in safe mode once & see if you can replicate this error message then? if not, please try disabling your addons until you find the right one & keep it disabled in case there is no update available for it...

Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

more options

Disabling the add-ons or extensions did not affect it. Fyi, in the upper left corner of the box that the Error was in said [JavaScript Application] with the brackets. Hope this helps. Thanks, Larry

more options

Note that this error is the consequence of removing support in current Firefox versions for this feature, so websites may no longer use this to get special XPCOM permissions.

  • Bug 546848 - Remove support for enablePrivilege

Are you opening a specific web page on startup that can cause this?

more options

When I log on to the internet, Google web page comes up, which is what I want. Also when I reply or forward any mail, this error message popes up when I click to go to my addresses. Those are the only 2 times I have noticed it popping up. Don't know how to "Remove support for enable Privilege". Thanks, Larry

more options

I had this identical problem. I went through my extensions one by one and disabled them. The problem extension was my AVG Security Toolbar. When I disabled this add on I stopped getting this irritating message. The problem was fixed simply by disabling an extension.

Upravil(a) gphilli4 dňa

more options

I get this error message from a raw basic copy of firefox 17. No add ons!!!!!

Someone please advise!

Upravil(a) klozter dňa

more options

I registered here, just to thank you for the solution, you saved my sanity :) . I usually never have my AVG toolbar on, so for some other reason it slipped by and that was the problem. I'm having problems with the babylon thing, it has been deleted on my computer, but every time I open my google page or press home, a babylon page opens as well? how can I get it off my computer? I did put google as my home page

more options

hello Crystal-Rose, please make sure that you don't have any babylon related extensions or other suspicious entries like 3rd-party-toolbars presently installed under firefox > addons > extensions (babylon also might install some unwanted stuff that comes under the names "Browser Manager", "Browser Protector", "Bprotector", "Object Installer", etc.) or in the windows control panel > programs section.

afterwards install the search reset addon - it will revert the most common customziations those adware programs do in firefox back to the default: https://addons.mozilla.org/firefox/addon/searchreset/

How to remove the Babylon toolbar, home page and search engine

Remove a toolbar that has taken over your Firefox search or home page

more options

solved, thanks

more options

I never did really realize or remember how i got that AVG to begin with but by removing it the problem was solved. Microsoft directed me to one of their partners to buy a software program to solve a problem they allowed to happen in the first place. I use forums all the time now to solve and help others which saves everyone money.

more options

I had this problem after having sanp.do installed wihout my knowledge and deactivating the toolbar. The I just deactivated the AVG toolbar and the problem disappeared (Just using Tools Options button «manage extensions» (or something like this - I use a French version)

more options

Got it solved, thanks all.

more options

Vybrané riešenie

I Finally fixed this Babylon thing, ok so what I did was I installed the entire program (yes, you read right), then I uninstalled it using Revo uninstaller. I figured, it couldn't be worse than what it already was, and going and reading up on the same solutions, didn't really help me much it just frustrated me more, because babylon stayed on as my search engin. Now it is off, YAY, the entire thing, with hidden cookies ect... Revo uninstaller saved my sanity...

more options

Problem solved, thanks.

more options

That solved my problem too. Thanks so much for sharing.

After I disabled the AVG Security Toolbar and restarted Firefox, I was successful in re-enabling the AVG Toolbar and no longer am receiving the error message.

Upravil(a) Poppoger dňa

more options

I jest remove AVG tool bar from browser