Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't open links in Firefox by clicking URL in Thunderbird

  • 49 odpovedí
  • 39 má tento problém
  • 64 zobrazení
  • Posledná odpoveď od maccool

more options

This has started happening since the last Firefox upgrade (to 14.0.1). It affects two machines - one running Windows 7, the other XP. The symptoms are identical.

Firefox is the default browser on both machines. I'm using only a default profile on each machine. I've checked that there are no stray "no-remote" switches in the command line or environment variables and I've tried deleting "parent.lock". The fact that it has happened to two separate installations, as a result of the upgrade, and the fact that all other functions of Firefox work as expected, makes me doubt that it's a profile corruption. I have also tried opening Firefox in Safe Mode but the behaviour is the same.

Here's what happened/happens:

Previously, if I had opened Firefox in the normal way from the start menu and then clicked on a link in an email in Thunderbird, the link would open in a new tab in the running copy of Firefox. I could do this with multiple links, each opening a new tab.

Now, if I do this I get the "Firefox is already running" error box.

If I close Firefox the click on a link in an email in Thunderbird, it will start Firefox as expected, and open the link. But if I then click on a second link, I get the error message.

If I click on URLs in other applications (for instance Pidgin instant messenger), the links open in new tabs in the running Firefox in the usual way, so the problem seems to be specific to links opened in Thunderbird.

As an experiment, I rolled my FF installation back to 13.0.1 on the XP machines. Everything then worked as before, and as expected, so this is clearly to do with the upgrade.

Všetky odpovede (20)

more options

It could be a problem with DDE settings in the registry. Sometimes Firefox can fix that if you do a two-step default browser change: first change to IE as your default browser, then change back to Firefox as your default browser.

more options

@jscher2000: Thanks for the suggestion, but unfortunately it made no difference. Here's what I did:

1. Upgraded the Firefox version to 14.0.1 again.

2. Opened IE and set it to be default browser.

3. Clicked on a link in an email in TB - it opened a tab in IE without problems.

4. Closed IE, opened FF and set it to be default browser again.

5. Clicked on a link in an email in TB - same error as before.

So there's clearly some issue with the way TB tries to open links in FF that has only shown up in this latest version.

Upravil(a) ratcatcher dňa

more options

I have the same problem except that it is irregular in that occasionally clicking the link in TB will get an open page in FF. I've not figured out what sequence allows it to work as it's very intermittent.

I tried the suggested fix, no joy.

more options

In addition to the various techniques to try to get your default browser settings to be complete and to stick, which you should try first, could you check your Connection settings here:

(WIN) orange Firefox button or classic Tools menu > Options > Advanced
(MAC) Firefox > Preferences > Advanced

On the "Network" mini-tab, click the Settings button. The two settings that seem to involve the least problems are:

  • No proxy
  • Use system proxy settings

Does it make any difference?

more options

Hi ratcatcher, do you have any add-ons in Thunderbird that could affect how links open? I'm just not very familiar with Thunderbird.

more options

Firefox on both machines is set to use system proxy settings (which are no proxy). It has always been this way through several versions of FF so no change there.

No, there are no addons in TB which affect the way links are handled.

more options

Mine has been "Use system proxy settings" in both TB and FF for more than a decade. It's only with the more recent versions of TB/FF that this problem of links not being able to open a browser from TB to FF (maybe version 8?).

Upravil(a) maccool dňa

more options

My machine is doing the same thing. I have Thunderbird set up for two separate email accounts using the " -no-remote " command line argument. This worked quite nicely if I open FF first, then click links from within Thunderbird. As soon as I upgraded to FF 14.0.1 this behavior is *BROKEN*! I can open one and one link only from TB then have to completely shut down FF and let it start as a child of TB. Went back to FF 13.0.1 and everything works just fine! This misguided headlong rush to keep up with the Joneses (Google) is breaking more things than it fixes. The developers have become so enamored of their bazillions of lines of code that they no longer listen to the USERS.

WinXP SP-3 W/All MS Patches

more options

Tip: If you feel adventurous, try downloading FireFox 13.0.1 from:


This site is an official Mozilla Mirror, and has the GpG signature file in the folder with the executable.

I had to revert to 13.0.1 to get my links to open correctly.

more options

When this happened in the past it was a default browser problem, but I don't believe the steps above worked. You had to go into the windows default settings and change it there. You have to use the instructions here to use Windows to change the default. You need to change it to IE there and then back to Firefox.

Hopefully it's the same issue and this will do the trick! If not I'd look at security software.

Upravil(a) Kensie dňa

more options

changing the default browser (however one does it) does not help. Just tried it, no joy.

more options

I went to the official Mozilla release download ( ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/ ) an installed FF 13.0 1.

No Joy

I've put up with this for far longer than that (FF version 7? 8?), but I finally got disgusted with the error. However, I tried FF version 13 in case there was some quirk that would fix my problem.

Upravil(a) maccool dňa

more options

I've got the same problem since FF 14. Clicking on links in TB will start up FF but if FF is already running then get error saying FF isn't responding and must be closed down.

Other apps can happily open links (in a new tab) in FF and TB can open links in other browsers. They just won't work with each other - sigh :( I'm fed up of having to copy/paste links from TB to FF that I've now installed Opera and made it my default browser.

It needs fixing!

more options

I get emails from Domino's pizza and all looks good in TB. But when I click on their order offer FF opens a tab but in the tab it has this info in it ( there is more to the link . I didn't include all of it) ... http://link.p0.comu.d?Q4............................................................................

I can't open the Domino's page from TB . I can open the site from FF .. and can open other sites from TB emails no problem... Contacted Domino's ..no joy..
more options

Hi tlaclair, there should have been a / after p0.com and before u.d? in that link. If that is a personal coupon you can't redeem any other way, I'd try adding the slash to the URL in the address bar and press Enter or click the Go button. Any luck?

(By the way, it's a tracking link so infoGROUP can report back to Domino's on which offers were clicked by which recipients.)

Upravil(a) jscher2000 dňa

more options

Whoops.. The / was there..I messed up the copy/paste... I have 'do not track plus' installed on FF.. maybe that is the problem.. I'll disable it and try later..

more options

I added url that showed up in my FF tab when I clicked on the order button for Domino's to my white list..still no joy

more options

Hi tlaclair, when you enter that URL, the browser just sits there and never redirects?

Does the same URL work in other browsers on your system?

more options

url works with IE .. when I click on url that is in TB email FF opens a tab and the url is the name in the tab ..the url also shows up in the address bar of FF..but nothing happens ..browsers shows a tab but a blank page

url is very long this is part of it : http://link.p0.com/u.d?Q4GtnP7P6XSqxbcsgbRP=111&s=http%3a%2f%2forder.dominos.com

more options

Hi tlaclair, when I click that link, here is what I see (observed using the Fiddler2 program, which intercepts web traffic between your browser and websites):

(1) The server at link.p0.com sets 1 cookie and redirects to http://t.mookie1.com/t/v1/event?migClientId=181&migAction=email-click&migSource=mig&migDest=http%3a%2f%2forder.dominos.com

(2) Firefox follows the redirect and the server at t.mookie1.com sets 3 cookies and redirects to http://order.dominos.com

(3) Firefox follows the redirect and the server at order.dominos.com redirects to a secure session (https://order.dominos.com/)

These kinds of redirects are completely standard; if you set Firefox to warn you about redirects, then a bar usually appear below the address where you can click an Allow button to continue. You can check whether you have this feature turned on here:

orange Firefox button or classic Tools menu > Options > Advanced > General

If Firefox isn't blocking the redirect, it's possible that one of your add-ons is doing it. A standard diagnostic for interference by add-ons is to try Firefox's Safe Mode.

First, I recommend backing up your Firefox settings in case something goes wrong. See Back up and restore information in Firefox profiles. (You can copy your entire Firefox profile folder somewhere outside of the Mozilla folder.)

Next, restart Firefox in Firefox's Safe Mode (Diagnose Firefox issues using Troubleshoot Mode) using

Help > Restart with Add-ons Disabled

In the Safe Mode dialog, do not check any boxes, just click "Continue in Safe Mode."

If the link works correctly, this points to one of your add-ons or custom settings as the problem.

Any change?

  1. 1
  2. 2
  3. 3