Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google search links stopped working

  • 10 odpovedí
  • 49 má tento problém
  • 1627 zobrazení
  • Posledná odpoveď od mouseonline98

more options

What the hell happened? Today I noticed that the links provided by Google search no longer work. If I click a link offered by google search, nothing happens! The same screen is presented. I tested it with both Firefox 10 and Firefox 6. Same result. Only the google previews are available, but the links to the actual source are not clickable.

I also tried the exact same search with IE, and I'm sad to say that the problem is not with Google.

Deactivating Adblock did not change this anomaly.

Vybrané riešenie

Not sure but this seems to be happening on and off when cookies are blocked. It could be that this change hasn't rolled over completely to my region. This add-on seems to help for now and also with cookies off.

Čítať túto odpoveď v kontexte 👍 7

Všetky odpovede (10)

more options
more options

Hi,

Thanks for the suggestion. I just tried it. Didn't help.

Regards,

Jyrki

more options

I tried another thing. I have disallowed "google.fi" from setting cookies (I am just generically opposed to cookies, in particular to those that may collect statistics from my browsing habits). This has not affected my ability to click the links coming our google search in the past. Today that has changed, because grudgingly removing "google.fi" from that list of sites seems to have cured the problem. Anyone with inside information about changes at Google's end?

more options

This most likely has to do with Google's new privacy ToS. I got the same problem starting yesterday. It seems to be Google's way of dealing with merging all your accounts. I have cookies disabled for google.com and google.(insert country here) and I can do google searches and get results. When I hover my cursor over them I get the right link address, when I click the link it turns to gibberish. Using the translate page does however work. Allowing cookies from google fixes the problem. If there is a workaround for this I'd be interested as I don't want to be logged in to google while searching , but do want to be able to use my youtube account and some other services related to google.

more options

Vybrané riešenie

Not sure but this seems to be happening on and off when cookies are blocked. It could be that this change hasn't rolled over completely to my region. This add-on seems to help for now and also with cookies off.

Upravil(a) Vivek dňa

more options

Thank you Vivek.Wilfred! Problem solved! I apologize to originally suspecting that the problem might be with FF.

more options

This works. Thanks.

more options

You are welcome :)

more options

With this add on and with Google cookies blocked everything is working. Thank you so much.

Upravil(a) RonHK dňa

more options

Thanks for a very interesting web site. Where else may I get that kind of information written in such a perfect approach? I’ve a venture that I am simply now running on, and I have been on the look out for such info.

Upravil(a) cor-el dňa