Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The "Clear Recent History" option is not available in my version of FF (7.0.1). How can I restore that?

  • 10 odpovedí
  • 7 má tento problém
  • 2487 zobrazení
  • Posledná odpoveď od cor-el

more options

The Firefox Help section describes how to clear history, cache, etc. by using the "Clear Recent History" option, but my version of Firefox (7.0.1) does not have that available.

Is there a way to restore this option to my version?

Vybrané riešenie

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (10)

more options

upgrade your browser to Firefox 8 and check

more options

Thanks, Swarnava. I upgraded (to 8.0.1) and still the option does not appear (under Tools, History, or any other menu).

Is there a setting or registry change that needs to be made to enable this?

more options

The link to "Clear Recent History" is available by any of the following:


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Hi, SafeBrowser.

Thanks for the reply. Unfortunately, this solution does not work for me for two reasons:

1. I am running Win XP, so I don't have a "Firefox Button."

2. My Tools menu (now FF 8.0.1) does not have the "Clear Recent History" option (see attached screen shot).

I visited the Mozilla support pages before posting the question, but I think something else may be needed.

I found an add-on that adds a "Meta-Alt-C," but I believe there should be a native option in the Tools menu. I just can't make it appear.

Any other thoughts?

more options

angelucci:

Are you in an office environment?

Some enterprises, when installing Firefox, restrict/remove options that they do not want employees to use for security and other reasons. Two options are missing from your image that are included in the standard Firefox installation: "Start/Stop Private Browsing" and "Clear Recent History".

It is also possible to find options missing in a home environment, when the administrator of a system "knows" how to do so.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

Upravil(a) SafeBrowser dňa

more options

Vybrané riešenie

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Hi, SafeBrowser.

I *am* in an office environment, and have installed my company's version of FF - it's the only one approved for use.

Since I need to test different web sites, I need to be able to clear cookies, cache, etc. Do you know of a way to restore this functionality?

more options

You will need to contact your company's IT department. If they have disabled that function, they have done so for security reasons and only they can undo the change.


If this reply solves your problem, please click "Solved It" next to this reply when signed-in to the forum.

more options

Okay, I have a work-around.

Starting FireFox in Safe Mode allows the "Clear History" option to appear. From there, I can clear the history, cache, cookies, etc. Unfortunately, I have to restart each time, but hey, at least it's do-able.

Thanks, all! Great help!

more options

If it does work in Safe-mode then disable all extensions and then try to find which is causing it by enabling one at a time until the problem reappears.

  • Use "Disable all add-ons" on the Troubleshoot Firefox issues using Safe Mode start window to disable all extensions.
  • Close and restart Firefox after each change via "File > Exit" (Mac: "Firefox > Quit"; Linux: "File > Quit")