Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

FireFox keyboard shortcuts - how to use old, traditional scheme?

  • 11 odpovedí
  • 8 má tento problém
  • 350 zobrazení
  • Posledná odpoveď od thespace

more options

I still have no idea why did FF team decided to touch keyboard patterns: - It is not design/features/etc. Eyes can adapt to anything, indeed, no problem but - This is in the essence how your fingers use software, that's a physical world. Hands definitely are MUCH more sensitive.

I would like to note that I have all three (IE, Chrome, FF) browsers installed, I used FF last few years, but a few months (or half a year?) ago they made that radical update which touched not eyes/brains, but hands. And that's a mess: - Home and End keys simply are not used now in FF :-/ (and earlier it was used for scrolling page in current tab) - PgDw and PgUp keys are used for going forward/back (!) in your tab - to switch tabs to the right you have to use Ctrl+Tab, and for back Ctrl+Shift+Tab

etc. etc.

To say that I was disappointed is to say nothing. I tried, week or so, to adapt to new tradition of keyboard use in FF, but I miserably failed. Then, ** for some other reason ** I ran Chrome. And since then I am Chrommed.... - PageUp and PageDown keys do work in Chrome for scrolling page - Home and End keys do work in Chrome for scrolling page - Ctrl+PgUp/PgDn - you switch tabs

People like me do NOT switch to Mac because (I work mostly in MS Office) there a bit different (really minor) keyboard shortcuts etc. etc.

I am stuck. Or they are some kind of Linux or whatever guys... And I even don't know how to give them feedback, and how to show them that there MANY people like me - we love FF but your change of keyboard shortcuts touched not brain/eyes, but our hands.

Vybrané riešenie

See also

  • Bug 640587 – Page up/down behaviour changes to "page back/forward"
Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (11)

more options

That is Firefox's interpretation of "caret browsing" press "F7" to turn it off. It is a toggle and the toggle may or may not provide a warning message when turning it on, it never provides a message when turning it off. If you see the message, reply "No" to turning on caret browsing.

Keyboard shortcuts and certainly not for dedicated keys have not been changed.

more options

thanks for your time, surely, but problem not solved yet. 1) i used config settings as in your link 2) i do press F7 and then 'no' 3) scrolling up and down via cursor keys works, end/home works but scrollling via pgup/pgdn keys doesn't work, it simply equivalent to Back/Forward for current tab.

btw in your link for FF shortcuts info is out of date, for FF there is simply no combination mentioned such as ctrl+pgup/pgdn at all. this is simply not true - see what this combination do in your FF.

huhuh too sophisticated FF and again - how do developers decide if to change keyboard shortcuts or not? do you have any insights? or thisi is in essence the problem - no dedicated and genius product manager with veto right? =)(

more options

ctrl+pgup/pgdn doesnt switch tabs as well, simply no any reaction

more options

sorry, i didn't formulate clearly:

in a table there are combinations Ctrl+pgdn and pgup, but actually they dont work in my FF. and I made changes in about:config as you suggested in your link and I press F7 then choose No etc.

Combination: Ctrl+PgDn; Claimed function: Tab Next (on Right); Real action at my PC: nothing (if this is last page opened).

Combination: Ctrl+PgUp; Claimed function: Tab Next (on Left); Real action at my PC: go to previous page.

more options

That part of that Keyboard Shortcuts table is a bit out of date.

{Ctrl + PageUp} and Ctrl + PagedDown} last worked for navigating thru opened Tabs in the Firefox 3.6 versions. Those keyboard commands quit working in Firefox 4 (and subsequent versions) when the tab strip was changed.

I believe that there is another way to indirectly navigate tabs on the 4+ versions, but at this time I don't recall what it is.

more options

Make sure that you do not have NumLock turned on (Bios setting may reverse what is on or off, but with the light off for me it should not enter numbers on dual purpose keys)

The alternative is the only one I use Ctrl+TAB and Ctrl+Shift+TAB, but I have no problem with either.

If it is tied into to Tab Scrolling for that, as Ed mentioned, I do not allow tabs to scroll so that would not affect me.


I see now that switching tabs with Ctrl+PageUp and Ctrl+PageDn not only is what the original poster was talking about but that he knew about use of the Ctrl+Tab alternative. I really would suggest getting used to using the Ctrl+Tab and Ctrl+Shift+Tab as the other is affected by the NumLock key.

Also turn on toggle keys so that you do get an audible warning when Caps Lock or Num Lock is invoked. see item #9 on

http://dmcritchie.mvps.org/windows-7/win7.htm

Upravil(a) David McRitchie dňa

more options

well, guys, sorry for delayed answer!

i do really appreciate your advice and i tried everything you said but it is tooocomplicated for me, so last few days i returned back to Chrome which has absolutely no problem. i guess large google may have some product management best practice developed from hundreds of product management exercises, and for FF team it is in some way one of more importance and hidden agendas/preferences, so FF team doesnt really understand that keyboard changes are not the same with any kind of design/menu changes. so - unfortunately - i need to save precious time and use chrome. i will check future FF versions and hope for the best.

by the way how does FF team conduct feedback on such things as i raised in this thread?

more options

You may have switched on caret browsing.

You can press press F7 (on Mac: fn + F7) to toggle caret browsing on/off.

  • Tools > Options > Advanced : General: Accessibility: [ ] "Always use the cursor keys to navigate within pages"

Start Firefox in Troubleshoot Firefox issues using Safe Mode to check if one of the extensions or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox (Tools) > Add-ons > Appearance/Themes).

more options

Hi,

thanks for help, but I already played all games with this caret browsing etc.

Really - FF simply decided to leave some keyboard shortcuts (with no rational reason or optionality to return back old keyboard shortcuts), while Chrome allows to use ctrl+tab and older ctrl+pgup/pgdn.

I will hope that someday I will have an opportunity to return back to FF from Chrome.

And, again - nobody answered me how those decisions are done among FF developers. Because, again, at google there is a function of product manager, who cares about user experience (doing A/B check for example etc.). =)

Again, thanks for your support!

more options

Vybrané riešenie

See also

  • Bug 640587 – Page up/down behaviour changes to "page back/forward"
more options

Cor-el, thanks for your mail! huhuh - i have asus ul30vt which is mentioned in this bug thread... :-/// i changed elantech preference in config and as for now it works. thanks man!