Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Apply Update button appears when Firefox is up to date

  • 6 odpovedí
  • 59 má tento problém
  • 47 zobrazení
  • Posledná odpoveď od ataraxy

more options

There seems to be a problem with the updater in Firefox 5. I am running Windows 7 Home Premium SP1 64 bit.

I was running Firefox 5.0 and I noticed that Firefox 5.0.1 had been released so went to Help - About Firefox.

Running under my user account the Apply Update button appeared but when I clicked it Firefox restarted but didn't update. Running under my administrator account, Firefox said that it was up to date.

Therefore, I downloaded the 5.0.1 file and installed it manually. When I checked Help - About Firefox:

- in my user account, the Apply Update button still appears, even though the version shows as 5.0.1; and - in my administrator account, Firefox says it is up to date.

So there seems to be a bug in the up date process. Under Firefox 3 and 4 the updates worked okay.

Vybrané riešenie

See:

Remove the files in the updates and updates\0 folder.
You may need to delete active-update.xml and updates.xml as well if present.

C:\Users\<user>\AppData\Local\Mozilla\Firefox\Mozilla Firefox\updates
(%LOCALAPPDATA%\Mozilla\Firefox\Mozilla Firefox)
Čítať túto odpoveď v kontexte 👍 10

Všetky odpovede (6)

more options

Here is a screenshot of the Help - About Firefox window running Firefox under my user account.

more options

Vybrané riešenie

See:

Remove the files in the updates and updates\0 folder.
You may need to delete active-update.xml and updates.xml as well if present.

C:\Users\<user>\AppData\Local\Mozilla\Firefox\Mozilla Firefox\updates
(%LOCALAPPDATA%\Mozilla\Firefox\Mozilla Firefox)
more options

Thanks cor-el!

That's solved the problem in my user account. It's not possible to check my administrator account as that was showing Firefox as up to date, but hopefully will fix that too if there continue to be problems.

more options

You're welcome.

more options

This still seems to be happening. On my machines, (Windows 7 Enterprise and Windows 7 Home, 64-bit), the fix works but still has to be re-applied after every update, e.g. 6.0 -> 6.0.1

more options

@tt1234567: I haven't had any problems since applying the fix above. You may be better off starting a new question. As this one has a "solution", your question above probably won't be noticed.