Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I can't find Firefox 5 for Solaris on sparc

  • 1 odpoveď
  • 12 má tento problém
  • 88 zobrazení
  • Posledná odpoveď od nbalcolm

more options

I went to the downloads page, found 5.0.7b (or something like that) downloaded and ran it, but it turned out to be some form of version3. It even redirected me to the download site I had just come from.

HUH?

Všetky odpovede (1)

more options

I had a similar problem under Solaris 11 Express on x64.

Because of the way the script works that starts firefox, you'll end up launching the firefox that came installed with Solaris... the script gives priority to the firefox installation that is in the conventional place on the filesystem.

What I did was to move the older installation to /usr/lib/firefox-3.6 place the 5.0 installation in /usr/lib/firefox-5.0 and create a link to /usr/lib/firefox-5.0 at the conventional installation point /usr/lib/firefox

I also copied the new /usr/lib/firefox/firefox script to /usr/bin/ , overwriting the previous one.

Now firefox 5.0 is completely taking the place of the pre-packaged 3.6, as far as I can tell.

If you are going to attempt what I did, remember to snapshot your rpool so you can revert to the previous state if things go awry.

Also, please don't ask me to list the commands to do this line by line; if you can't easily figure them out yourself, you shouldn't be trying to do this. It wouldn't be so bad to tolerate firefox 3.6 until a new Solaris release includes the newest version.