Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox not storing passwords for a couple of websites even when they are not listed in the "exceptions" under security option

  • 4 odpovede
  • 2 majú tento problém
  • 21 zobrazení
  • Posledná odpoveď od dinkar

more options

I used to login to a web site where FF stored my username and password which used to get populated automatically.

Recently my friend wanted to use the site, so he logged into the site using my computer and used his credentials to log in which got saved too.

After that, I tried to remove his details from the options and since then, FF doesnt populate the username/password fields automatically.

I tried removing my details again from the options hoping that when i login to the site again, it will ask me to save the same but now FF doesnt ask me to save the password.

Please help

Všetky odpovede (4)

more options

Make sure that you not run Firefox in permanent Private Browsing mode.

  • https://support.mozilla.com/kb/Private+Browsing
  • You enter Private Browsing mode if you select: Tools > Options > Privacy > History: Firefox will: "Never Remember History"
  • To see all History and Cookie settings, choose: Tools > Options > Privacy, choose the setting Firefox will: Use custom settings for history
  • Deselect: [ ] "Permanent Private Browsing mode"

more options

Checked! Its not in private browsing mode.

The current settings are:

Tools>Options>Privacy>Firefox will Remember history

more options

Did you check for the possibility that those websites use autocomplete=off to prevent Firefox from saving the password?

more options

Yes, you are right. I checked the source and found that the autocomplete=off has been set for the form as well as the username/password fields.

What is bothering me is the fact that this site was storing my credentials until this issue happened and now that I deleted the same, it is not asking me to store the same possibly due to autocomplete=off.

Is there a way I can get FF to remember the same? I tried the "remember password" bookmarklet as given in the page Bookmarklets page .

I read that it will work ONLY if the form uses autocomplete=off to avoid saving passwords. Since I have verified that the site indeed uses autocomplete=off for the same, I was expecting this approach to work but unfortunately it didnt.

If you want to have a try, you can take a look at this site:

IRCTC Site