X
Kliknite sem pre prechod na mobilnú verziu webu.

Fórum podpory

On Firefox beta startup I get a javascript error before the browser opens: what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined. The browser pane then remains empty until manual refresh.

Pridané

Every time starting Firefox beta (4.0b1) I get a javascript application popup error saying "what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined" before the browser opens. Clicking OK closes popup, browser opens to empty page (incorrect). Browser refresh reveals expected content.

This happened

Every time Firefox opened

== I installed beta firefox on Windows Vista system.

Every time starting Firefox beta (4.0b1) I get a javascript application popup error saying "what happened:TypeError: Components.classes['@mozilla.org/extensions/manager;1'] is undefined" before the browser opens. Clicking OK closes popup, browser opens to empty page (incorrect). Browser refresh reveals expected content. == This happened == Every time Firefox opened == I installed beta firefox on Windows Vista system.

Vybrané riešenie

Carl,

The first message is due to an extension that is not compatible with Firefox 4.0 beta 1.

Did you turn compatibility checking off or use the add-on compatibility reporter? Try disabling extensions that are indicating incompatibility in Tools -> Add-ons.

It may be the Ask Toolbar (AskTbTRL/3.8.0.12304 in user agent), try disabling that.

Otherwise you will have to disable all add-ons and re-enable one by one until the problem appears, and you identify the problematic extension. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Your second issue may be covered by this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=575281 or it may be due to the incompatible extension(s).

Čítať túto odpoveď v kontexte 3

Ďalšie informácie o systéme

Nainštalované zásuvné moduly

  • -npmnqmp 989898989877
  • Google Update
  • Shockwave Flash 10.1 r53
  • Adobe Shockwave for Director Netscape plug-in, version 11.5
  • iTunes Detector Plug-in
  • DivX Web Player version 2.0.2.40
  • Picasa plugin
  • Yahoo Application State Plugin version 1.0.0.7
  • 4.0.50524.0
  • NPWLPG
  • 6.0.12.732
  • RealPlayer(tm) LiveConnect-Enabled Plug-In
  • RealJukebox Netscape Plugin
  • RealPlayer(tm) HTML5VideoShim Plug-In
  • Next Generation Java Plug-in 1.6.0_20 for Mozilla browsers
  • NPRuntime Script Plug-in Library for Java(TM) Deploy
  • Adobe PDF Plug-In For Firefox and Netscape "9.3.3"
  • The QuickTime Plugin allows you to view a wide variety of multimedia content in Web pages. For more information, visit the QuickTime Web site.

Aplikácie

  • Identifikácia prehliadača: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:2.0b1) Gecko/20100630 AskTbTRL/3.8.0.12304 Firefox/4.0b1 ( .NET CLR 3.5.30729; .NET4.0C)

Viac informácií

rjohnson19 39 riešení 240 odpovedí

Vybrané riešenie

Carl,

The first message is due to an extension that is not compatible with Firefox 4.0 beta 1.

Did you turn compatibility checking off or use the add-on compatibility reporter? Try disabling extensions that are indicating incompatibility in Tools -> Add-ons.

It may be the Ask Toolbar (AskTbTRL/3.8.0.12304 in user agent), try disabling that.

Otherwise you will have to disable all add-ons and re-enable one by one until the problem appears, and you identify the problematic extension. See Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems

Your second issue may be covered by this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=575281 or it may be due to the incompatible extension(s).

Carl, The first message is due to an extension that is not compatible with Firefox 4.0 beta 1. Did you turn compatibility checking off or use the add-on compatibility reporter? Try disabling extensions that are indicating incompatibility in Tools -> Add-ons. It may be the Ask Toolbar (AskTbTRL/3.8.0.12304 in user agent), try disabling that. Otherwise you will have to disable all add-ons and re-enable one by one until the problem appears, and you identify the problematic extension. See [[Troubleshooting extensions and themes]] Your second issue may be covered by this bug: https://bugzilla.mozilla.org/show_bug.cgi?id=575281 or it may be due to the incompatible extension(s).