Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to make Firefox wait more before thinking that there is no connection?

  • 2 odpovede
  • 2 majú tento problém
  • 24 zobrazení
  • Posledná odpoveď od Morbus

more options

I am using F-Secure Antivirus. It also includes a firewall. This firewall is a bit slow to understand exactly when a program is launched and so when I launch Firefox it blocks the Internet connection from Firefox for a second, before allowing the access to Internet. This is enough for Firefox to think that there is no connection at all, since it failed to connect to the homepage server.

This means every time I launch Firefox, I have to click the refresh button to load my homepage.

For some reason, when I lauch Firefox the first time after logging in to Windows, Firefox manages to load my home page. But every time after that Firefox fails.

Please make Firefox wait for a few seconds if it does not manage to connect to Internet right after starting Firefox so it won't show this stupid error page.

This problem does not occur in Internet Explorer and SRWare Iron.

Computer: - 2GB RAM - Intel Pentium Dual CPU (2 x 1,60 GHz)

This happened

Every time Firefox opened

== F-Secure firewall is enabled.

Všetky odpovede (2)

more options

Hello Reikko.

I believe there is no way around this, because this is not a matter of timeout. In my experience, in situations like this, Firefox can clearly see that its connection to the internet is non-existent or is being deliberately blocked, so it reports it as non-existent.

There was, a long while ago, an extension called "Try again" or something like that, that would force a reload every 10 seconds on pages that had timed out or were showing the "no connection" error. You may want to search for it in addons.mozilla.org.

more options

This problem also occurs when connecting to wireless networks that require some sort of login or click (aka a "captive portal"). In addition to the homepage, it also impacts how extensions load (causing problems like certificate errors). Some sort of verification that the connection is fully live before loading pages and extensions might solve this problem.