Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

OAuth2 option not showing for Outgoing Server

  • 11 odpovedí
  • 2 majú tento problém
  • 1 zobrazenie
  • Posledná odpoveď od gorbage

more options

From the article "Microsoft OAuth Authentication and Thunderbird in 2024" there is a screenshot showing a OAuth2 option for the SMTP server setting with STARTTLS connection security. It does not appear for me. There are only the five options, as shown in the screenshot. How do enable the option to be available in the drop-down list or set it?

The available options are:

No Authentication Normal Password Encrypted Password Kerberos / GSSAPI NTLM

I am on Thunderbird version 115.12.1 (64-bit), Windows 11, version 23H2, build 22631.3737

From the article "Microsoft OAuth Authentication and Thunderbird in 2024" there is a screenshot showing a OAuth2 option for the SMTP server setting with STARTTLS connection security. It does not appear for me. There are only the five options, as shown in the screenshot. How do enable the option to be available in the drop-down list or set it? The available options are: No Authentication Normal Password Encrypted Password Kerberos / GSSAPI NTLM I am on Thunderbird version 115.12.1 (64-bit), Windows 11, version 23H2, build 22631.3737
Priložené obrázky

Vybrané riešenie

I made a mistake on my previous post. I meant to write that my reply to sfhowes was "bad", instead of "not bad".

So...I tested the smtp.office365.com server and the OAuth2 option finally appeared but not until after saving the server name and going back to edit it. The original post from sfhowes was correct and the Microsoft article I had found, is not. Just to reiterate and summarize for anyone that happens upon this thread, the OAuth2 authentication method for outgoing mail server settings, and probably incoming, only appears in the drop-down list of choices based on the server name entered.

My guess is that Thunderbird has some sort of handshake with the server to determine whether it uses OAuth2 or not. It might be done when saving the server name. When the save is made, Thunderbird could be communicating with the server and updating the authentication method options. This would force you to edit the settings after just saving them so you can now choose the updated list option of OAuth2.

Maybe someone could confirm this and add to this thread but for now, I consider it resolved.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (11)

more options
How do enable the option to be available in the drop-down list or set it?

You need to set a Server Name first.

Pomohla vám táto odpoveď?

more options

The screenshot was just an example. I have all the fields filled out. I happen to be using outlook so the server is smtp-mail.outlook.com. Still no OAuth2 option.

Pomohla vám táto odpoveď?

more options

Pomohla vám táto odpoveď?

more options

I am using POP3 by choice and the server I stated in my previous email came from here:

https://support.microsoft.com/en-us/office/pop-imap-and-smtp-settings-for-outlook-com-d088b986-291d-42b8-9564-9c414e2aa040

I am also not using Microsoft 365. Just an outlook.com account.

Pomohla vám táto odpoveď?

more options

I do not use oauth for my SMTP settings in outlook.com only for incoming. Is it even a thing for outlook/hotmail/MSN ie free accounts?

Looking at the setup database, that is configured to use the office365 servers for hotmail accounts. Given how careful those folk in development are about what gets into that database, I would use those settings until they were proved to not work as they emphasize security over provider recommendations. https://autoconfig.thunderbird.net/v1.1/hotmail.com

Pomohla vám táto odpoveď?

more options

I apologize. I am not entirely clear what settings you are referring to, Mozilla or Microsoft? Mozilla has a screenshot in the https://support.mozilla.org/en-US/questions/1417298#answer-1588949 article which shows there is an OAuth2 option in Thunderbird that I am not seeing. Microsoft requires your email address and account password to send outgoing mail but because I have OAuth2 enabled and I have not chosen that setting for SMTP because I am not seeing in Thunderbird, Thunderbird cannot send mail with those credentials. The only other option I have is to create and use an application password for my outlook.com account and punch it into Thunderbird; but that defeats the purpose of OAuth2. Even Microsoft has an article on using OAuth2 for SMTP:

https://learn.microsoft.com/en-us/exchange/client-developer/legacy-protocols/how-to-authenticate-an-imap-pop-smtp-application-by-using-oauth

Pomohla vám táto odpoveď?

more options

gorbage said

I am using POP3 by choice and the server I stated in my previous email came from here: https://support.microsoft.com/en-us/office/pop-imap-and-smtp-settings-for-outlook-com-d088b986-291d-42b8-9564-9c414e2aa040 I am also not using Microsoft 365. Just an outlook.com account.

POP uses the same settings as IMAP, except on port 995.

The settings in the link in my first reply are for free, consumer hotmail/outlook.com accounts (although they are the same as for MS 365), and have been working for at least a year.

Pomohla vám táto odpoveď?

more options

POP3 and IMAP may have the same or similar settings but are definitively not the same. Do your research.

Pomohla vám táto odpoveď?

more options

gorbage said

I apologize. I am not entirely clear what settings you are referring to, Mozilla or Microsoft? Mozilla has a screenshot in the https://support.mozilla.org/en-US/questions/1417298#answer-1588949 article which shows there is an OAuth2 option in Thunderbird that I am not seeing.

As you have been repeatedly told oauth is only available for select server names. Take not of the server name in the image to which you refer, which I have linked to below.

Microsoft requires your email address and account password to send outgoing mail but because I have OAuth2 enabled and I have not chosen that setting for SMTP because I am not seeing in Thunderbird, Thunderbird cannot send mail with those credentials. The only other option I have is to create and use an application password for my outlook.com account and punch it into Thunderbird; but that defeats the purpose of OAuth2. Even Microsoft has an article on using OAuth2 for SMTP: https://learn.microsoft.com/en-us/exchange/client-developer/legacy-protocols/how-to-authenticate-an-imap-pop-smtp-application-by-using-oauth

gorbage said

POP3 and IMAP may have the same or similar settings but are definitively not the same. Do your research.

Quit arguing and do what you are told will fix your issue. You use the server names you are told (office365) and you can use oauth. Choose not to and you can not. It is that simple.

There is nothing else to discuss here in support.

If you wish the development team to enable oauth for further Microsoft server names you are welcome to file a bug requesting same. It will probably take months if they choose to make the change. There are open bugs in bugzilla that have achieved their majority (21 years). Change is not fast.

You can have use of oauth today, but instead you have continued to insist that the server which does not have access to oauth in Thunderbird is correct and look for some other solution to enable it.

Pomohla vám táto odpoveď?

more options

Matt,

Thank you for clarifying a little more but you didn't have to berate me about it. I am not arguing anything, just trying to understand the short & non-descriptive answers that generated more questions for me than answer. No one stated that the OAuth2 option only displays for certain server entries prior to your post and I had no idea I could use their 365 servers for an outlook.com address. I do not know which address domains are compatible with what servers. Your first response stated to use "those" settings. I did not know if you were referring to the 365 servers from the previous post or something to do with the hotmail link you included in your response. Then you never responded to my reply asking for clarification. When sfhowes wrote POP uses the same settings as IMAP, I thought they were stating that IMAP and POP are interchangeable. For me, they are not, since I prefer to download my mail to my local device. Granted, my reply to sfhowes was not bad and I apologize to sfhowes for that. I will try the settings tomorrow and either close this thread or report further.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

I made a mistake on my previous post. I meant to write that my reply to sfhowes was "bad", instead of "not bad".

So...I tested the smtp.office365.com server and the OAuth2 option finally appeared but not until after saving the server name and going back to edit it. The original post from sfhowes was correct and the Microsoft article I had found, is not. Just to reiterate and summarize for anyone that happens upon this thread, the OAuth2 authentication method for outgoing mail server settings, and probably incoming, only appears in the drop-down list of choices based on the server name entered.

My guess is that Thunderbird has some sort of handshake with the server to determine whether it uses OAuth2 or not. It might be done when saving the server name. When the save is made, Thunderbird could be communicating with the server and updating the authentication method options. This would force you to edit the settings after just saving them so you can now choose the updated list option of OAuth2.

Maybe someone could confirm this and add to this thread but for now, I consider it resolved.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.