Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Search defaults to UK. How undo? Using Duck Duck Go for search.

  • 8 odpovedí
  • 3 majú tento problém
  • 1 zobrazenie
  • Posledná odpoveď od ezameht

more options

My default search engine is Duck Duck Go. I frequently use a VPN.

I am usually in North America and want to search sites in North America. When I run a search by typing a search term in Firefox, I get results beginning in UK, and I see that a blue toggle switch has been set to UK. (See image.)

This started 2-3 weeks ago.

How do I set things so that my searches begin in North America?

I have checked "about:config" preferences and do not see anywhere that UK is specified. I don't see a region preference setting, either.

Thank you.

My default search engine is Duck Duck Go. I frequently use a VPN. I am usually in North America and want to search sites in North America. When I run a search by typing a search term in Firefox, I get results beginning in UK, and I see that a blue toggle switch has been set to UK. (See image.) This started 2-3 weeks ago. How do I set things so that my searches begin in North America? I have checked "about:config" preferences and do not see anywhere that UK is specified. I don't see a region preference setting, either. Thank you.
Priložené obrázky

Všetky odpovede (8)

more options

I wonder whether this got saved in a cookie. While you are on the results page, press Shift+F9 to open the Storage Inspector panel. Perhaps you will be able to recognize a cookie that specifies U.K. results. If not, you could just try deleting all of them and see whether that cleans it out. That might also flush other DDG preferences such as light/dark theme and where results open (same tab/new tab).

Pomohla vám táto odpoveď?

more options

Cookies are deleted daily, so that's not a solution.

One of the preferences in about:config had the region set for "RO". I don't know where that came from, but I changed it to US. Now when I search, the results simply say "All regions", and US results come first.

Pomohla vám táto odpoveď?

more options

This also happens on my Android - it defaults to UK for searches. Firefox is synched between the PC and Android.

HELP ==> Firefox is LOSING ITS USEFULNESS because of this problem.

What is the solution?

Pomohla vám táto odpoveď?

more options

Any improvement if you update your Region in https://duckduckgo.com/settings ?

Pomohla vám táto odpoveď?

more options

Thanks for the suggestion. That was already set to All Regions, but searches are still UK.

So no, that didn't help.

Upravil(a) ezameht dňa

Pomohla vám táto odpoveď?

more options

Is there anything in the results page URL that seems to specify the region that might override that setting?

Pomohla vám táto odpoveď?

more options

What is the value of browser.search.region in about:config?

Pomohla vám táto odpoveď?

more options

It says browser.search.region US

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.