Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Blocked from extracting canvas data because no user input was detected.

  • 2 odpovede
  • 0 má tento problém
  • 18 zobrazení
  • Posledná odpoveď od ooioo1

more options

Hi, I'm using 0penlayers and with this online example : https://openlayers.org/en/latest/examples/export-map.html when clicking "Download PNG" button I get the following message in Firefox console : "Blocked https://openlayers.org/en/latest/examples/export-map.html from extracting canvas data because no user input was detected." And the image downloaded is incorrect. I have no Firefox user message asking for permission to canvas access. I'm using Firefox 107.0.1 (64 bits) Mozilla Firefox Snap for Ubuntu canonical-002-1.0

With Firefox on windows or android the example is working fine. On the example web page there is the javascript code using the canvas.

Bye !

Pierre.

Hi, I'm using 0penlayers and with this online example : https://openlayers.org/en/latest/examples/export-map.html when clicking "Download PNG" button I get the following message in Firefox console : "Blocked https://openlayers.org/en/latest/examples/export-map.html from extracting canvas data because no user input was detected." And the image downloaded is incorrect. I have no Firefox user message asking for permission to canvas access. I'm using Firefox 107.0.1 (64 bits) Mozilla Firefox Snap for Ubuntu canonical-002-1.0 With Firefox on windows or android the example is working fine. On the example web page there is the javascript code using the canvas. Bye ! Pierre.

Vybrané riešenie

Do you have "privacy.resistFingerprinting" enabled in about:config?

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (2)

more options

Vybrané riešenie

Do you have "privacy.resistFingerprinting" enabled in about:config?

Pomohla vám táto odpoveď?

more options

Yes indeed ! And resetting it to false solved the problem !

Thanks a lot !

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete odpovedať na príspevky, musíte sa prihlásiť do svojho účtu. Ak ešte nemáte účet, položte novú otázku.