Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Websites not displaying all elements

more options

I have a couple of client websites that sometimes has trouble displaying page elements. I think it's related to some Javascript that's controlling elements animating in as user scrolls down the page. The page will sometimes load fine, but other times elements don't display resulting in large blank areas and the hero video doesn't load.

It's behaving as if Javascript is disabled in browser settings, but it is enabled. Only happens in Firefox, no issues in Chrome. My developers can't figure out what's happening.

https://kmsc.ca/ and https://carbertwaite.com/

I have a couple of client websites that sometimes has trouble displaying page elements. I think it's related to some Javascript that's controlling elements animating in as user scrolls down the page. The page will sometimes load fine, but other times elements don't display resulting in large blank areas and the hero video doesn't load. It's behaving as if Javascript is disabled in browser settings, but it is enabled. Only happens in Firefox, no issues in Chrome. My developers can't figure out what's happening. [https://kmsc.ca/ https://kmsc.ca/] and [https://carbertwaite.com/ https://carbertwaite.com/]
Priložené obrázky

Všetky odpovede (5)

more options

Did you check the Web Console for relevant-looking messages ?

Pomohla vám táto odpoveď?

more options

Console doesn't look too different between when the issue occurs and when the page displays properly.

Pomohla vám táto odpoveď?

more options

I notice a "reached loc slider resize" message in the second screenshot.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Pomohla vám táto odpoveď?

more options

The "reached loc slider resize" line as part of the scripts-min.js might indicate that something preventing the Javascript file from loading and causing the issue? Looking at the Network tab, all JS files are transferring.

Still occurs in Troubleshoot Mode. Clearing cache sometimes works, but when the page is refreshed again the issue comes back. Even when reloading and bypassing cache. I can refresh the page over and over again in Chrome without issue.

Pomohla vám táto odpoveď?

more options

White text on a white background... not a good look. The scripts are minified, so I can't really tell for sure what's going on, but I have a theory.

This probably results from assigning the background images in an "onload" handler. When Firefox loads pages fresh, it fires the load event, but when it loads from cache, especially the "fast back-forward" cache, it does not fire the load event, only the pageshow event.

As a minimal workaround while you sort out the script, consider applying a default background color to areas affected by this problem so the text is readable.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.