Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Some websites don't display fonts properly...all |??????|

  • 5 odpovedí
  • 0 má tento problém
  • 2 zobrazenia
  • Posledná odpoveď od cor-el

more options

Even though I have the "allow websites to choose their own fonts" box checked, some websites (Google and others) display fonts as all question marks. This doesn't happen all the time...just sometimes. And sometimes restarting the computer helps. I prefer using Firefox but I noticed it doesn't happen in Safari. I have OS 12.4 and am using Firefox 103.0.2. Thanks for any advice!

Even though I have the "allow websites to choose their own fonts" box checked, some websites (Google and others) display fonts as all question marks. This doesn't happen all the time...just sometimes. And sometimes restarting the computer helps. I prefer using Firefox but I noticed it doesn't happen in Safari. I have OS 12.4 and am using Firefox 103.0.2. Thanks for any advice!

Všetky odpovede (5)

more options

Hi

Do you have an example of some those websites?

more options

barbara61 said

I have OS 12.4

As you have macOS 12.4, moving thread to (desktop) Firefox section.

iOS 12.4 (for iPad/iPhone) is old and does not support current Firefox versions that require iOS 13.0 at minimum.

more options

It is possible that Firefox isn't able to access the requested font and falls back to a 'last resort' font that shows all glyphs as a '?' or an 'A'.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.

more options

Well I found the font as you suggested but that didn't solve the problem. When I unchecked the box that let the webpage choose it's own fonts, that seemed to work. Thanks for your response.

more options

Which font has been replaced by the last resort font?

Note that these days a lot of websites use an iconic font to display (small) special images. If you disable website font via "Allow pages to choose their own fonts, instead of my selections above" then such fonts are disabled and you may see little boxes with the hex code of the character or text labels instead.