Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

wide spacing between words as well as odd-looking numbers in Firefox

more options

Since a recent update the spacing of words in Firefox's UI as well as on some websites seems to be wider than normal (instead of a singular space it seems as if each space is now a tab wide). Additionally the numbers have also suffered and are now not presented in a normal font anymore but instead seem bigger and grey instead of white or black. Both of these issues occurred at the same time and appear on the normal User Interface of Firefox (e.g. in the bookmarks or in Firefox's settings and preferences) as well as on some websites/search engines. However when copying the text and numbers from Firefox into a regular text editor everything seems normal and no appearance issues can be noticed. What I've already tried: I've restarted my system multiple times since the issue first occurred. I've removed all contents from /home/user/.mozilla/firefox. I've reinstalled Firefox. I've deleted my cache. I've changed my font preferences in Firefox back to Default(Roboto) after having used Inter before. None of my actions above have changed anything. However, when I log into a different user on my computer and open Firefox there everything seems to be normal, so it seems as if this is a user-specific problem.

Thanks in advance, Emma.

OS: opensuseTumbleweed 20220507 Firefox version: 100.0 (issue has occurred since version 98.0)

Since a recent update the spacing of words in Firefox's UI as well as on some websites seems to be wider than normal (instead of a singular space it seems as if each space is now a tab wide). Additionally the numbers have also suffered and are now not presented in a normal font anymore but instead seem bigger and grey instead of white or black. Both of these issues occurred at the same time and appear on the normal User Interface of Firefox (e.g. in the bookmarks or in Firefox's settings and preferences) as well as on some websites/search engines. However when copying the text and numbers from Firefox into a regular text editor everything seems normal and no appearance issues can be noticed. What I've already tried: I've restarted my system multiple times since the issue first occurred. I've removed all contents from /home/user/.mozilla/firefox. I've reinstalled Firefox. I've deleted my cache. I've changed my font preferences in Firefox back to Default(Roboto) after having used Inter before. None of my actions above have changed anything. However, when I log into a different user on my computer and open Firefox there everything seems to be normal, so it seems as if this is a user-specific problem. Thanks in advance, Emma. OS: opensuseTumbleweed 20220507 Firefox version: 100.0 (issue has occurred since version 98.0)
Priložené obrázky

Vybrané riešenie

This might be a problem with an emoji font that causes spaces to get larger.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


  • /questions/1373348 The number and space fonts render much bigger and wider than other letters?
Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (3)

more options

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?

more options

Vybrané riešenie

This might be a problem with an emoji font that causes spaces to get larger.

You can right-click and select "Inspect" to open the built-in Inspector with this element selected.

You can check in the Rules tab in the right panel in the Inspector what font-family is used for selected text. You can check in the Fonts tab in the right panel in the Inspector what font is actually used because Firefox might be using a different font than specified by the website.


  • /questions/1373348 The number and space fonts render much bigger and wider than other letters?
more options

Thank you both for your fast replies! The third link posted by cor-el (this one ) was actually the solution to this problem. I just changed the fontconfig file (in ~/.config/fontconfig) for the Noto Color Emojis as suggested and the weird font behavior is gone! Thanks to both of you for your fast replies again!