Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

how to avoid the graying of most of the url in the location bar?

  • 7 odpovedí
  • 2 majú tento problém
  • 17 zobrazení
  • Posledná odpoveď od cor-el

more options

In the location bar (aka url bar aka address bar), the base domain name ("example.com") is displayed as normal text, whereas everything else in the url is displayed in gray. For example, if the displayed url is https://foo.example.com/bar, the "https://foo." and "/bar" are in gray.

Is it possible to get the whole url displayed as normal text, i.e., black, and avoid this "graying out" of some of it?

In my searches so far, I've found various other customizations for the location bar via userChrome.css, but not this one. Any help appreciated.

I'm using firefox 91.8.0esr (64-bit) as currently packaged for centos7 (x86_64), though presumably this is not system-dependent.

In the location bar (aka url bar aka address bar), the base domain name ("example.com") is displayed as normal text, whereas everything else in the url is displayed in gray. For example, if the displayed url is https://foo.example.com/bar, the "https://foo." and "/bar" are in gray. Is it possible to get the whole url displayed as normal text, i.e., black, and avoid this "graying out" of some of it? In my searches so far, I've found various other customizations for the location bar via userChrome.css, but not this one. Any help appreciated. I'm using firefox 91.8.0esr (64-bit) as currently packaged for centos7 (x86_64), though presumably this is not system-dependent.

Vybrané riešenie

Yeah, put browser.urlbar.formatting.enabled in the search field of about:config, make sure boolean is selected below and click the + button on the right side to add it. Then make sure it's set to false.

Looks like they might have removed that preference but you can still add it and it will work. I just now tried toggling it.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (7)

more options

Start Firefox using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Hello,

In order to better assist you with your issue please provide us with a screenshot. If you need help to create a screenshot, please see How do I create a screenshot of my problem?

Once you've done this, attach the saved screenshot file to your forum post by clicking the Browse... button below the Post your reply box. This will help us to visualize the problem.

Note: If you have problems when uploading the image to this forum, you can use imgur. com or a similar image host if the image appears to hang on upload, then add a link to the image. However, this may delay a response if the external link needs review by a moderator.

Thank you!

Pomohla vám táto odpoveď?

more options

1) Certainly it still happens in safe mode. The graying-out of the url except for the base domain name is intended behavior of firefox (from what I can gather from the bugzilla and forums), not a "problem" per se.

2) Screenshot attached of my safe mode startup. (I chopped off some of the page content due to this forum's size limit.) The "centos.org" appears at the regular text weight, while "https://www." is in light gray.

Thanks, Karl

Pomohla vám táto odpoveď?

more options

Trying going to about:config and set browser.urlbar.formatting.enabled to false. It should be solid black text. Still working in FF 100.

Pomohla vám táto odpoveď?

more options

Thanks for replying, but browser.urlbar.formatting.enabled does not show up in my about:config. No match (for any browser.urlbar.f*). Thus I assumed it had been disappeared. Do I need to somehow set the preference manually? Thanks again.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

Yeah, put browser.urlbar.formatting.enabled in the search field of about:config, make sure boolean is selected below and click the + button on the right side to add it. Then make sure it's set to false.

Looks like they might have removed that preference but you can still add it and it will work. I just now tried toggling it.

Pomohla vám táto odpoveď?

more options

It works! Thank you so much!

Pomohla vám táto odpoveď?

more options

The browser.urlbar.formatting.enabled.formatting.enabled preference is still supported if I check the source code (got removed from about:config as part of bug 1643639). Some docs that describe various browser.urlbar prefs.


You can paste browser.urlbar.formatting.enabled in the search bar and select the Boolean radio button and click the '+' icon to this pref as a new Boolean pref and set its value to false.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.