Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Firefox downoading files instead of printing

  • 6 odpovedí
  • 1 má tento problém
  • 30 zobrazení
  • Posledná odpoveď od Mithrandirx2

more options

I hope this is the right category. I recently switched to Firefox, and while I love both the customization aspect and how privacy-centered it is, I have 1 small thing that is bugging me a lot: printing. I'm on an M1 Macbook Air, and when I do Command+P (which is the default printing command for OSX), it downloads the file I'm attempting to print instead of sending it to preview instead of printing. I have changed the "Applications" setting so it says "Open in Preview" where I can print it from. However, it still downloads the file along with printing it. I have tried doing "Open in Firefox", and it has the same affect where it both prints the document but also downloads this. What can I do to change this, if anything? Thank you!

I hope this is the right category. I recently switched to Firefox, and while I love both the customization aspect and how privacy-centered it is, I have 1 small thing that is bugging me a lot: printing. I'm on an M1 Macbook Air, and when I do Command+P (which is the default printing command for OSX), it downloads the file I'm attempting to print instead of sending it to preview instead of printing. I have changed the "Applications" setting so it says "Open in Preview" where I can print it from. However, it still downloads the file along with printing it. I have tried doing "Open in Firefox", and it has the same affect where it both prints the document but also downloads this. What can I do to change this, if anything? Thank you!

Všetky odpovede (6)

more options

Hi, You posted in the correct forum. ☺️

Would you be able to provide an example website we can test?

Pomohla vám táto odpoveď?

more options

Thanks for the replay! Sorry for the late response. I did a bit more testing, and apparently it only happens on Google Suite applications such as Google Docs and Drive. Does that help at all?

Pomohla vám táto odpoveď?

more options

It is normal for Google Docs to generate a PDF when you use the Print command on its menu. I guess they also intercept Command+P. I think you may be able to bypass that using Firefox's main menu button > Print, but the results may not be as good.

If you do not want PDFs to download automatically, you can change the action for opening PDFs on the Settings/Preferences page: View PDF files in Firefox or choose another viewer.

Pomohla vám táto odpoveď?

more options

Google Docs does not generate a PDF file on Google Chrome at least. I am able to bypass it using the Print button, but I'd much prefer to be able to just do Command+P. As for "If you do not want PDFs to download automatically, you can change the action for opening PDFs on the Settings/Preferences page: View PDF files in Firefox or choose another viewer." comment, that does not change anything with Google Docs. Thank you for your help though!

Pomohla vám táto odpoveď?

more options

You can disable Google from capturing and repurposing built-in keyboard shortcuts, but this could be a problem for some that you prefer Google to intercept and repurpose. Here's how to try it and see what you think.

While viewing a page on Google docs, call up the Page Info dialog using either Command+i (if not intercepted) or on the menu bar, Tools > Page Info.

When the dialog comes up, click the Permission icon at the top to show that panel.

Scroll down to "Override Keyboard Shortcuts" and uncheck the "Use default" box. Then select "Block" on the right side of that row.

This is saved immediately, so you can close Page Info now. I don't know whether it will start working right away or after you reload the document.

Pomohla vám táto odpoveď?

more options

Oh, thanks! I had no clue that existed. I will definitely check that out. Thank you for the help!

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.