Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Secure Connection Failed on Firefox 98 (SEC_ERROR_LIBRARY_FAILURE)

  • 8 odpovedí
  • 2 majú tento problém
  • 578 zobrazení
  • Posledná odpoveď od Michael

more options

Greetings. I can't open most sites I usually visit (even google.com) via my Firefox 98.0a1. This happens since today. All error codes are SEC_ERROR_LIBRARY_FAILURE.

Tried to:

  • Disable DNS-over-HTTPS.
  • Disable HTTP/3.
  • Disable proxy (never had it enabled anyway).
  • Disable sending info to Firefox developers.
  • Change settings of DNS-over-HTTPS.
  • Restart the browser (after each action).

Nothing helps me... But I still can visit some websites, but most common resources are not working for me. Please help me because I can't use Microsoft Edge without getting mentally ill. :/

Greetings. I can't open most sites I usually visit (even google.com) via my Firefox 98.0a1. This happens since today. All error codes are SEC_ERROR_LIBRARY_FAILURE. Tried to: * Disable DNS-over-HTTPS. * Disable HTTP/3. * Disable proxy (never had it enabled anyway). * Disable sending info to Firefox developers. * Change settings of DNS-over-HTTPS. * Restart the browser (after each action). Nothing helps me... But I still can visit some websites, but most common resources are not working for me. Please help me because I can't use Microsoft Edge without getting mentally ill. :/

Vybrané riešenie

Kahuna said

Same here. I did (much to my detriment) the "Refresh Nightly" from the help menu and that helped me get back into sites for about an hour or two and then they all stopped working again. Help ASAP!

Heyyyy! I came here with the solution.

  1. Open about:config (just like a regular URL) in your browser
  2. Search for security.pki.crlite_mode
  3. Set it to 0 and save changes.

And now... I can open sites! :D

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (8)

more options

Same here. I did (much to my detriment) the "Refresh Nightly" from the help menu and that helped me get back into sites for about an hour or two and then they all stopped working again. Help ASAP!

Upravil(a) Kahuna dňa

more options

Vybrané riešenie

Kahuna said

Same here. I did (much to my detriment) the "Refresh Nightly" from the help menu and that helped me get back into sites for about an hour or two and then they all stopped working again. Help ASAP!

Heyyyy! I came here with the solution.

  1. Open about:config (just like a regular URL) in your browser
  2. Search for security.pki.crlite_mode
  3. Set it to 0 and save changes.

And now... I can open sites! :D

more options

Wonderful! Thank you!!

more options

Web search: https://www.bing.com/search?q=SEC_ERROR_LIBRARY_FAILURE it's possible that the NOD32 service is not running

I called for more help.

more options

Николай said

Kahuna said

Same here. I did (much to my detriment) the "Refresh Nightly" from the help menu and that helped me get back into sites for about an hour or two and then they all stopped working again. Help ASAP!

Heyyyy! I came here with the solution.

  1. Open about:config (just like a regular URL) in your browser
  2. Search for security.pki.crlite_mode
  3. Set it to 0 and save changes.

And now... I can open sites! :D

Unfortunately, I can't say that this has resolved issues for me (instead I now get a never-ending "page loading" indicator, like with the http3 woes a couple days back)

more options

strangeglyph сказал(а)

Unfortunately, I can't say that this has resolved issues for me (instead I now get a never-ending "page loading" indicator, like with the http3 woes a couple days back)

I've also disabled http3 support, but I did that in before. In about:config I set network.http.http3.enabled to false.

Upravil(a) Николай dňa

more options
more options

My cause is perhaps different - but the 'complaint' from FF (100.0.1) is:

SEC_ERROR_LIBRARY_FAILURE

1) None of the help pages I came across have this 'label' in the help text - which makes it extremely difficult to diagnose. 2) On a laptop I installed 97.0.2 (EME-free, whatever that is) I can open the page. FF consider the co9nnection - not secure, but exception applied. Via page-Info I can see that the certificate is not expired, encryption: TLS_ECDHE_RSA_WITH_AES256_GCM_SHA384, 256 bit keys, TLS 1.2 (edit2: This does not seem to be the reason. I have an area with a self-signed cert I can connect to, same TLS... information, but 128-bit key).

  • I am guessing the key is the 256-bit keys (as 'too' weak).

I am forced to rollback all my FF to version 97 - as this is a piece of firmware that is not getting firmware updates (anymore). Too much security (in one area) can bring bigger problems in other areas.

So, I am hoping there is a setting to allow the 'library' to accept the encryption method above - and it would be much better if there was more information offerred re: SEC_ERROR_LIBRARY_FAILURE - what has actually failed (as it is not the dlopen of the library, etc..).

(The bug id=1750188 was an interesting read. I'll try an update to 100.0.2 (edit: I saw that number being offered for my laptop, but this installation says 'at latest') before I rollback this system to 97.0.2. And let me add - forcing a new profile is a real pain in the ass. Please add an option to save the current profile so it can easily be restored. I am praying 'sync' is going to help me with my bookmarks, etc..)

Upravil(a) Michael dňa