Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Fonts broken

  • 6 odpovedí
  • 1 má tento problém
  • 2 zobrazenia
  • Posledná odpoveď od FredMcD

more options

Hi all, due to the sometimes quite rude tone in the german forum, I dare to ask my question here: Since the last update to FF 95.x a few weeks ago, I have this strange behaviour with some fonts, as e.g. Manrope, Lato and others (mostly from Google). Parts of the types are white (refer to the screenshot). I'm using Mac OS 10.15.17. Is this a known issue - and is there a remedy? Thanks so much, Martin

Priložené obrázky

Všetky odpovede (6)

more options

[v56+] Type about:preferences#general<enter> in the address box. Under fonts and colors, press the Advanced button. Scroll to the bottom, turn on Allow Web Sites To Choose Their Own.

Make sure you haven't enabled a High Contrast theme in the OS settings.

  • We have seen reports that this can be caused by a problem with fonts like Roboto or Helvetica that

you have installed locally and that might be corrupted or are missing some variants. Also, make sure you allow pages to choose their own fonts and that you do not block remote (downloadable) fonts.

  • If you use uBlock Origin make sure not to "block remote fonts".

Pomohla vám táto odpoveď?

more options

Hi Fred, thanks for caring! The requested settings are already as you proposed. The thing is, that this phenomen exists only since the latest version. Before, the fonts were no issue. I would have noticed, as I'm a web designer myself and use Google fonts frequently ;-) Of course, system cleanup, cache clearing ... everything done several times.

Any other ideas?

Cheers Martin

Pomohla vám táto odpoveď?

more options

I called for more help.

Make sure you are not blocking content.

https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop also see https://blog.mozilla.org/security/2021/03/23/introducing-smartblock/

https://support.mozilla.org/en-US/kb/smartblock-enhanced-tracking-protection


Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Pomohla vám táto odpoveď?

more options

Hi Fred,

thanks so far. I tried that. But: there is nothing blocked, no cookies are concerned. It is simply a corrupt font display. If you compare the two attached screen shots, then you see: - The original displays the font Manrope in the defectuous mode - When I simply change the font-family into helvetica (which is of course activated in my system), then there ain't no issue with the display. The thing is, that the construction of Google fonts is - depending on the font - sometimes more than questionable. The horizontal bars are separate parts, simply overlayed. This is by far not best practice to construct a font. But: as mentioned, the issue is not present on FF on WIN, just on FF on Mac. And on no other browser...

Cheers Martin

Pomohla vám táto odpoveď?

more options

Ok then: Checking with several other browsers on Mac OS 10.15.17, the issue is present on all of them. Seems like the OS update was around the same time as the FF update which led me to the supposition that this is a FF specific problem. It is not. It obviously is an OS related issue. Therefore I move to an Apple forum.

Pomohla vám táto odpoveď?

more options

Please keep us posted.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.