Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Tab history constantly overwritten when following a link on page

  • 4 odpovede
  • 1 má tento problém
  • 11 zobrazení
  • Posledná odpoveď od FredMcD

more options

Whenever I search something and follow a link, or if I'm on a page and click a link to another site or page, the history in the tab gets overwritten.

I've only noticed it this month and if I'm looking for something quickly its extremely frustrating having to re search with the same parameters over and over or remember to open every search in its own tab.

I've had a hard time searching this issue, I don't know if my terminology is right or if it's just a very niche issue I'm having.

Any help would be EXTREMELY appreciated.

Whenever I search something and follow a link, or if I'm on a page and click a link to another site or page, the history in the tab gets overwritten. I've only noticed it this month and if I'm looking for something quickly its extremely frustrating having to re search with the same parameters over and over or remember to open every search in its own tab. I've had a hard time searching this issue, I don't know if my terminology is right or if it's just a very niche issue I'm having. Any help would be EXTREMELY appreciated.

Vybrané riešenie

Managed to figure it out.

browser.navigation.requireUserInteraction default is set to false in the about:config page.

I had it set to true. Reverting it solved the problem.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (4)

more options

I get around this by; When I find a link I want to check out, I open it in a new tab/window. Then when I am done, I close it and am back where I started. ++++++++++++++++++ Note: Sometimes the 'back' button has issues when redirects and other issues show up. Try right-clicking the 'back' button for better control.

more options

Thank you for the suggestion but I am not looking to work around the problem but rather, to fix it.

I have narrowed it down to how DuckDuckGo behaves differently in Firefox compared to a few other browsers I've tested.

If someone has any settings suggestions I could try changing?

more options

Vybrané riešenie

Managed to figure it out.

browser.navigation.requireUserInteraction default is set to false in the about:config page.

I had it set to true. Reverting it solved the problem.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator.]

Upravil(a) Chris Ilias dňa

more options

That was very good work. Well Done.