Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Background turned black after 95.0 update

  • 34 odpovedí
  • 9 má tento problém
  • 2379 zobrazení
  • Posledná odpoveď od ps-firefox

more options

I just updated to 95.0. I use default Firefox home page with the Search bar. The background turned to black with this update. The background has also turned to black for some of my bookmarks or sites I go to. Settings, Language and Appearance, Colors, Text is Black and Background is White. I have never changed that. How do I get the background back to White?

Vybrané riešenie

You can change this pref on the about:config page from 3 to 2.

*layout.css.prefers-color-scheme.content-override
Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Čítať túto odpoveď v kontexte 👍 2

Všetky odpovede (20)

more options

Hi, I had this problem. I have gone back to version. 94.02 no probs, back to normal..MAKE SURE you back up bookmarks, passwords etc, as they're not transferred... I just hope Mozilla Firefox realize WE DON'T LIKE THE BLACK BACKGROUND WITH WHITE TXT !! Please change back.. Jon....

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

You can change this pref on the about:config page from 3 to 2.

*layout.css.prefers-color-scheme.content-override
Dark (0), light (1), system (2) or browser (3)

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Upravil(a) cor-el dňa

Pomohla vám táto odpoveď?

more options

Thank you cor-el! This worked fine. Thank you. Now maybe I won't get any headaches. Seriously. This won't effect future updates will it? What if Mozilla Firefox changes this back with an update? Hopefully they will. Have a great day.

Pomohla vám táto odpoveď?

more options

THX- changing it from 3 to 2 definitely fixed that one page. i'll have to visit a few other things like bookmarks and hope they are back to legible black type on white page. no more of this in the future i hope.

Pomohla vám táto odpoveď?

more options

NOPE! bookmarks is STILL BLACK BACKGROUND!? any fix for this?

Pomohla vám táto odpoveď?

more options

See also ui.systemUsesDarkTheme [0:light; 1:dark; 2:no-preference]

Pomohla vám táto odpoveď?

more options

JACKI Q. said

NOPE! bookmarks is STILL BLACK BACKGROUND!? any fix for this?

I am with the same problem, my bookmark bar with the last update in now black.  :/

Changing theme can help, but I prefer a possible solution.

Pomohla vám táto odpoveď?

more options

changed layout.css.prefers-color-scheme.content-override to 2 and 1, but it still messes with the color of other websites. Not right. Can I undo the update?

Pomohla vám táto odpoveď?

more options

This is what I see for a Dark theme (light text on the inactive/background tabs) vs. a Light theme (dark text on the inactive/background tabs) and that about:config change. Are you all seeing similar -- dark sidebar, dark toolbar panels with a dark theme? This is the new normal in Firefox 96 as far as I can tell.

Pomohla vám táto odpoveď?

more options

I have the same problem, Have changed background to white ( thanks cor-el) but as Jacki Q says the bookmarks have a black background. This does my head in. why fix something that wasnt broken. Lets put it back the way it was? any ideas?

Pomohla vám táto odpoveď?

more options

Hi bovril602, Firefox 96 is trying to harmonize the color scheme of all the parts of the browser with your toolbar theme. The only "quick fix" is to select a theme that has dark text on the tabs instead of light text. Until someone comes up with a better approach.

Pomohla vám táto odpoveď?

more options

I did the about:config change but still had some black backgrounds. It seems this kind of problem was introduced when Mozilla started using Proton. I am installing version 88 which was just before they started using it until they make it much easier to get rid of black backgrounds.

Pomohla vám táto odpoveď?

more options

baysailor1 said

I did the about:config change but still had some black backgrounds.

Firefox 96 now harmonizes more parts of Firefox with your toolbar theme. When the text color on your background tabs is light/white, it triggers Firefox to use a dark background on menus, the sidebar, the Library window, and various built-in pages. It also signals sites that you have a dark theme preference.

What to do about this

The safer workaround is to change your theme to one that uses dark text. By dark text I mean, for example, the built-in Light theme, or an add-on theme with black or dark text on the tabs such as:

https://addons.mozilla.org/firefox/addon/firefox-b/

Pomohla vám táto odpoveď?

more options

@ baysailor1

I noticed you posted about this in six threads and got replies in a few cases. If you still have issues then best is to create a new thread instead of reusing existing threads or at least stay in one thread.

Pomohla vám táto odpoveď?

more options

cor-el said

@ baysailor1 I noticed you posted about this in six threads and got replies in a few cases. If you still have issues then best is to create a new thread instead of reusing existing threads or at least stay in one thread.

I would personally like to do this, but either I am very stupid, or it's an unnecessarily complex process. Because I do not see any option to do so.

Pomohla vám táto odpoveď?

more options

Hi fopibab368, you can use the link I provided in the other thread:

https://support.mozilla.org/questions/new/desktop/form

Pomohla vám táto odpoveď?

more options

jscher2000 said

Hi fopibab368, you can use the link I provided in the other thread: https://support.mozilla.org/questions/new/desktop/form

Thank you.

Pomohla vám táto odpoveď?

more options

These are what i did to revert the color back to light.

1. about:config ---> layout.css.prefers-color-scheme.content-override ---> 3 to 2

2. Mozilla settings icon ---> SETTINGS ---> LANGUAGE AND APPEARANCE section ---> COLORS and i set it like in figure 1.

But, the changes i made above still can not counteract (i don't know what it's called) things like what's highlighted in red in figure 2

What is shown in figure 2 had light background before.

3. I had installed a custom theme from the mozilla addons page before this problem occurred. (This might help with those whose still experiencing color problem on the bookmark section)

Upravil(a) Samurai dňa

Pomohla vám táto odpoveď?

more options

I found a fix for the black bookmarks on another site

First about:config in a blank page. Click away the warning and add browser.theme.toolbar-theme set it to 1 and voila, the bookmarks is now white with black text without needing to change the theme.

This takes out a lot of my annoyance with the new update. But it really shouldnt be needed because mozilla keeps messing with settings and forcing things on the users.

Oops. You have to make sure to check use system colors to ensure it works.

Upravil(a) LucianDK dňa

Pomohla vám táto odpoveď?

more options

Thanks so much, this was driving me crazy!

Pomohla vám táto odpoveď?

  1. 1
  2. 2
Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.