Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Disable Address Bar Search in Firefox 91

  • 2 odpovede
  • 2 majú tento problém
  • 75 zobrazení
  • Posledná odpoveď od AndalayBay

more options

I want to disable the searching in the address bar. I have already changed the configuration settings in about:config.

I have Google search set up as my home page and I want to continue using that for searches. In Firefox 91, as soon as I start typing in the search box on the home page, it jumps to the damned address bar. After changing the configuration settings, now it wants to visit whatever I typed in! I also changed browser.fixup.alternate.enabled to false per another suggestion.

I suspect I'm screwed and I'm going to have to ditch Firefox for another browser, but if someone has some magic settings, I'm all ears.

To repeat, I have already changed: keyword.enabled to false browser.fixup.alternate.enabled to false

I do not want to disable the search suggestions. I want Firefox to stop moving my cursor from the Google search box in the middle of my home page to anything in the address bar.

I want to disable the searching in the address bar. I have already changed the configuration settings in about:config. I have Google search set up as my home page and I want to continue using that for searches. In Firefox 91, as soon as I start typing in the search box on the home page, it jumps to the damned address bar. After changing the configuration settings, now it wants to visit whatever I typed in! I also changed browser.fixup.alternate.enabled to false per another suggestion. I suspect I'm screwed and I'm going to have to ditch Firefox for another browser, but if someone has some magic settings, I'm all ears. '''To repeat, I have already changed:''' keyword.enabled to false browser.fixup.alternate.enabled to false I do not want to disable the search suggestions. I want Firefox to stop moving my cursor from the Google search box in the middle of my home page to anything in the address bar.

Vybrané riešenie

AndalayBay said

I want Firefox to stop moving my cursor from the Google search box in the middle of my home page to anything in the address bar.

You can set keyword.enabled back to true. This is the oddly named preference you're looking for:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since I use this one myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

Čítať túto odpoveď v kontexte 👍 2

Všetky odpovede (2)

more options

Vybrané riešenie

AndalayBay said

I want Firefox to stop moving my cursor from the Google search box in the middle of my home page to anything in the address bar.

You can set keyword.enabled back to true. This is the oddly named preference you're looking for:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since I use this one myself, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste handoff and pause while the list is filtered

(3) Double-click the browser.newtabpage.activity-stream.improvesearch.handoffToAwesomebar preference to switch the value from true to false

Success?

more options

Yes! Thank you thank you thank you!

I'm glad they kept a setting to fix it. I really didn't want to switch browsers.