Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 90 Fonts

  • 3 odpovede
  • 1 má tento problém
  • 64 zobrazení
  • Posledná odpoveď od jscher2000

more options

I changed my Windows 10 default font to something other than Segoe UI because I very much dislike Segoe UI. My doing so also changed the default font in Firefox 88, which is what I wanted. When I updated to Firefox 89, the browser no longer used my Windows 10 default font. That disappointed me a great deal because I did not like the font that Firefox 89 used. When Firefox 89.01 was released, that fixed the problem, and the browser used my Windows 10 default font, which again, is what I wanted.

I have now updated to Firefox 90, and it is not using my Windows 10 default font. Instead, it is using the ugly font that Firefox 89 used. In the Firefox 89.01 Release Notes, it says one of the issues that got fixed was "Fix various font related regressions (bug 1694174)" I am not sure if that is the "fix" that allowed Firefox 89.01 to use my Windows 10 default font, but I do know that after that fix, Firefox used my preferred font.

At bottom, Firefox 90 is not using my preferred font, which is the same problem Firefox 89 had and that Firefox 89.01 corrected. Please fix Firefox 90 so I am not stuck with the ugly font that it uses.

Vybrané riešenie

Firefox 89.0 changed how Firefox shares fonts across processes. Due to crashes, this was disabled in 89.0.1. However, it wasn't disabled in Firefox 90.0 presumably because those emergency issues were resolved for today's release. So the shared font list is back with various potential odd side effects that we all get to learn about in real time.

Windows Font Substitutions

Firefox 89 also changed how Firefox uses the system's font substitutions table. Previously, the substitutions were used to override requested fonts, but starting in Firefox 89, they are used if the requested font isn't available. Try changing the following preference to revert to the old behavior and see whether this resolves the interface font issue with your Firefox:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.windows-font-substitutes.always and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true -- you might need to do a regular exit/restart of Firefox for that to take effect, I don't have a way to test this

Did that make any difference?

More info on about:config: Configuration Editor for Firefox.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (3)

more options

Vybrané riešenie

Firefox 89.0 changed how Firefox shares fonts across processes. Due to crashes, this was disabled in 89.0.1. However, it wasn't disabled in Firefox 90.0 presumably because those emergency issues were resolved for today's release. So the shared font list is back with various potential odd side effects that we all get to learn about in real time.

Windows Font Substitutions

Firefox 89 also changed how Firefox uses the system's font substitutions table. Previously, the substitutions were used to override requested fonts, but starting in Firefox 89, they are used if the requested font isn't available. Try changing the following preference to revert to the old behavior and see whether this resolves the interface font issue with your Firefox:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste gfx.windows-font-substitutes.always and pause while the list is filtered

(3) Double-click the preference to switch the value from false to true -- you might need to do a regular exit/restart of Firefox for that to take effect, I don't have a way to test this

Did that make any difference?

More info on about:config: Configuration Editor for Firefox.

Pomohla vám táto odpoveď?

more options

What you recommended worked. Thank you so much not only for providing a solution that solved my precise issue, but also for how promptly you responded.

Pomohla vám táto odpoveď?

more options

Thank you for reporting back. I wouldn't be surprised if others come here with the same question in coming weeks so it's good to have something for them to find, if the search works, which, well... we can hope.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.