Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Upgraded from Firefox 88 to 89.0.2 on Mac OS 11.4 and found some websites displaying blank pages

  • 12 odpovedí
  • 1 má tento problém
  • 23 zobrazení
  • Posledná odpoveď od FredMcD

more options

Upgraded from Firefox 88 to 89.0.2 on Mac OS and found some websites displaying blank pages.

https://docs.github.com/en/get-started/getting-started-with-git/caching-your-github-credentials-in-git Displays a white page. Other Github pages are fine.

https://app.pluralsight.com/player?name=f83ca95c-74e2-4a1d-8742-62b34ec47906&mode=live&clip=0&course=code-school-git-real&author=gregg-pollack Displays a dark grey page.

Both these websites were working fine in Firefox 88.

Any help much appreciated.

Priložené obrázky

Vybrané riešenie

I ended up doing a fresh install of Firefox 89.0.2 and the problem is no longer present.

The only reason I can think of for this original problem to happen is that some Firefox files got damaged when I downloaded Firefox 89.0.2 and went to install it without closing Firefox 88. I got a dialog box pop up and tell me to close Firefox, so I did, but perhaps the damage was already done. That is the only explanation I can come up with for this original problem to arise.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (12)

more options

I disabled some addons but problem persisted.

Pomohla vám táto odpoveď?

more options

Make sure you are not blocking content.

Diagnose Firefox issues using Troubleshoot(Safe) Mode {web link}

A small dialog should appear. Click Start In Troubleshoot(Safe) Mode (not Refresh). Is the problem still there?


https://support.mozilla.org/en-US/kb/enhanced-tracking-protection-firefox-desktop


Many site issues can be caused by corrupt cookies or cache.

Warning ! ! This will log you out of sites you're logged in to. You may also lose any settings for that website.

Pomohla vám táto odpoveď?

more options

Do you use a bookmark or are you starting with the main (home) page of this website?

If you use a bookmark to access a specific page then instead navigate to this page starting with the main page or with the sign in page in case there is a problem with this bookmark.


You can remove all data stored in Firefox for a specific domain via "Forget About This Site" in the right-click context menu of an history entry ("History -> Show All History" or "View -> Sidebar -> History").

Using "Forget About This Site" will remove all data stored in Firefox for this domain like history and cookies and passwords and exceptions and cache, so be cautious. If you have a password or other data for that domain that you do not want to lose then make sure to backup this data or make a note.

You can't recover from this 'forget' unless you have a backup of involved files.

If you revisit a 'forgotten' website then data for that website will be saved once again.

Pomohla vám táto odpoveď?

more options

Hi, thanks for your replies. I tried all those things but the problem is still there.

I deleted the history, cache, cookies etc and problem still there. I tried running Firefox in safe mode but problem still there. I changed browser privacy from custom to standard, but problem still there. I try home pages or subpages, and problem still there.

A funny thing happens when I refresh or load the page on the Github pages website: the content of the page splashes up on to the screen for a split second and then goes back to blank.

I am wondering if some files became corrupted when I installed the new version of Firefox, and that I need to do a fresh install of Firefox?

Pomohla vám táto odpoveď?

more options

Pomohla vám táto odpoveď?

more options

If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content. You can click shield icon for more detail and possibly disable the protection. You can check the Web Console for messages about blocked content.

Pomohla vám táto odpoveď?

more options

@ cor-el But I had Firefox running in safe mode with addons disabled, so it can't be the addons, right?

And Enhanced Tracking Protection is off for these sites.

And I had the same settings with Firefox 88 and they were all working.

Pomohla vám táto odpoveď?

more options

You can create a new profile as a quick test to see if your current profile is causing the problem.

See "Creating a profile":

If the new profile works then you can transfer files from a previously used profile to the new profile, but be cautious not to copy corrupted files to avoid carrying over problems.

Pomohla vám táto odpoveď?

more options

@cor-el

Yes, thanks, I will try that.

Pomohla vám táto odpoveď?

more options

The two pages you posted above work for me on Linux although I need to enable auto-play to make the gregg-pollack video work in the second link.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

I ended up doing a fresh install of Firefox 89.0.2 and the problem is no longer present.

The only reason I can think of for this original problem to happen is that some Firefox files got damaged when I downloaded Firefox 89.0.2 and went to install it without closing Firefox 88. I got a dialog box pop up and tell me to close Firefox, so I did, but perhaps the damage was already done. That is the only explanation I can come up with for this original problem to arise.

Pomohla vám táto odpoveď?

more options

That was very good work. Well Done. Please flag your last post as Solved Problem as this can help others with similar problems.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.