Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Theme keeps reverting to light theme

  • 5 odpovedí
  • 1 má tento problém
  • 37 zobrazení
  • Posledná odpoveď od jscher2000

more options

So I was on a theme spree trying to find something that fit my tastes better before deciding I would opt for the custom CSS Firefox route, however, I added Dolan's Dynamic theme (https://addons.mozilla.org/en-US/firefox/addon/dolans-dynamic-theme/) and when I tried testing it on other sites I came to realize it was not actually dynamic and decided to use a different theme. However, even after a complete browser refresh/clean-up, as well as a fresh installation of Firefox, my browser still reverts to the light / dynamic theme when I click out of the Add-Ons page. I will disable and remove all added themes and select the default and it will take effect on my browser, however when I ctrl+t or click new tab my browser reverts back to the light / dynamic theme.

Really upsetting seeing as I can't stand light themes and I prefer using Firefox for my web development work however now Firefox is sidelined for Chrome (which I cannot stand using). Any and all help or input will be appreciated and if I can provide anything else to help I will gladly do so.

Priložené obrázky

Vybrané riešenie

Kyle Parker said

I will definitely go ahead and give the Developer Edition a go as I wish I had heard about it prior so thank you for bringing that option to my attention.

Hi Kyle, I got your message that once you enabled Sync in developer edition you lost your dark theme.

I think this came up in another thread, but I can't remember whether it worked. There is a specific preference to control whether the active theme -- this is the theme for the toolbar area -- sync. You could try disabling it and see whether that lets you theme different Firefoxes differently:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste services.sync.prefs.sync.extensions.activeThemeID and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (5)

more options

Kyle Parker said

I will disable and remove all added themes and select the default and it will take effect on my browser, however when I ctrl+t or click new tab my browser reverts back to the light / dynamic theme.

The "default" theme should adapt to your system theme, but I think normally the top bar is blue, so that's a little strange.

Did you try the Dark theme? You also can make internal Firefox pages dark using the following setting:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box, type or paste ui.systemUsesDarkTheme

(3) Firefox should display a bar with some radio buttons to choose a new preference type, followed by a + button. Choose Number and click the + button:

(D) Edit the value from 0 (Light) to 1 (Dark) and then click the blue check mark button or press Enter/Return to save the change.

Success?

Pomohla vám táto odpoveď?

more options

By the way, the Developer Edition, which is a flavor of Firefox Beta, has a dark theme by default:

https://www.mozilla.org/firefox/developer/

Pomohla vám táto odpoveď?

more options

@ jscher2000,

Unfortunately that did not work, when I went from 0 to 1 it would take effect in configuration tab however when I would go to any previously open tabs or open a new tab it would revert back. I will definitely go ahead and give the Developer Edition a go as I wish I had heard about it prior so thank you for bringing that option to my attention.

Pomohla vám táto odpoveď?

more options

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

Kyle Parker said

I will definitely go ahead and give the Developer Edition a go as I wish I had heard about it prior so thank you for bringing that option to my attention.

Hi Kyle, I got your message that once you enabled Sync in developer edition you lost your dark theme.

I think this came up in another thread, but I can't remember whether it worked. There is a specific preference to control whether the active theme -- this is the theme for the toolbar area -- sync. You could try disabling it and see whether that lets you theme different Firefoxes differently:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste services.sync.prefs.sync.extensions.activeThemeID and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.