Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are all docs I output to PDF now turned into Firefox HTML files? It needs to stop!

  • 6 odpovedí
  • 2 majú tento problém
  • 27 zobrazení
  • Posledná odpoveď od Wesley Branton

more options

Ever since I installed the last update, 84, which caused a host of problems I will not go into, an unanticipated one was that I can non longer output to PDF as Firefox automatically changes it to Firefox HTML Files. I can view them in Acrobat, but the subtle difference makes it impossible for Word Perfect to recognise them if I need to import them back (as in when something gets lost and all I have is the PDF). Please, community, do NOT tell me all I need to do is use MS Word to fix this. This is NEVER going to happen, now or ever! Now that this made clear, what, if anything can I do? And why would Firefox have anything to DO with me converting WP files into PDF? Clearly there is some greedy little finger stuck somewhere, because the proof is in the long list of files I now have that are no longer PDF. I have opened them in Acrobat and saved them again, but they still show up as FIrefox HTML Files. Aaargh! Help, please! It's driving me mad!

Vybrané riešenie

If you right click on the PDF file that's saved on your computer outside of Firefox, select Properties. On that window, the type of file will be "Firefox HTML Document (.pdf)". That means that the file is still a PDF file, but that Firefox is just the default reader in Windows.

You can press the Change... button on that window and select Acrobat as the reader and that should set the default reader back to Acrobat. Admittedly, it's been a while since I've used Windows 7, but that should work.

If that doesn't work, open Adobe Acrobat and select Edit from the top menu bar. Then pick Preferences from that drop-down menu. From the left side of that preferences window, select General. At the very bottom of the general section, there should be a button that says Select As Default PDF Handler. That should either change it as the default or open steps on how to change the default.

If all else fails, this Windows support page explains how to manually change the default program for a file type.

Hope this helps.

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (6)

more options

Based on the fact that you can open these files with Adobe Acrobat still, that would mean that these are indeed still PDF files, not HTML files. Adobe Acrobat can't open HTML files. My guess is that your default PDF reader is set to Firefox, in which case the PDF would open in Firefox and PDF files would show a Firefox icon.

If you go to the Firefox settings and scroll down to the Applications section, you should see PDF (or Portable Document File) listed there along with the default action for that file. You can change that to a viewer other than Firefox.

In some cases, it could also be that Windows has set Firefox as the default PDF viewer. There are multiple ways to change the default PDF viewer in Windows. The easiest way is probably to use the Set as default viewer button in the General section of the Adobe Acrobat settings or by changing the default program in Windows manually.

Pomohla vám táto odpoveď?

more options

Thanks for trying, but I've tried most every one of those things to no avail.

Firefox was not set as the default reader - in fact, nothing was, I'd chosen "Save File" there, but tried it anyway and then made another PDF hoping to see it back to having the Acrobat icon, but no, they all say Firefox HTML. And mind you, I do mean all, including ones that I made months ago. They all arbitrarily got changed when I installed that wretched update to 84, I was so sick of getting the "reminder" box every time I opened Firefox. It wiped out all my toolbars and got rid of all my bookmarks too! It took my husband, who is a software engineer half an hour at least to figure out how to get all of it back. I didn't notice the HTML thing at first, until two days ago didn't care as it all seemed to look OK, but when I lost an entire night's work (I'm an author and yes, I should have backed up, but I was tired and forgot), the only copy being the PDF, that I realised that WP now saw them as an unknown format. I already did the last thing you suggested. No change. I'm out of ideas and patience. Sorry, but I think it might be time for a new browser after more than twenty years. I certainly am never downloading another update and lose all my bookmarks and toolbars again! And just FYI, I am not the typical senior citizen who barely knows how to turn the computer on - I started working with computers in 1973 and was a text editor for decades. This is a real thing and I saw postings on this as far back as 2014, so it isn't "just me" and there were a variety of problems that this issue caused.

Thanks again.

Pomohla vám táto odpoveď?

more options

You shouldn't lose bookmarks and toolbars when updating. Should we circle back to that problem?

The way Windows describes and opens files with a .pdf extension are based on Windows file associations saved in the Registry. If you double-click a PDF in Windows Explorer, what program does Windows use to open it? If it uses Acrobat but the files are mis-described as Firefox files, the entry in the Registry got corrupted. I don't know the best way to fix that, but changing Firefox settings isn't going to fix it. Maybe switching the default app setting around a few times will straighten out the setting.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

If you right click on the PDF file that's saved on your computer outside of Firefox, select Properties. On that window, the type of file will be "Firefox HTML Document (.pdf)". That means that the file is still a PDF file, but that Firefox is just the default reader in Windows.

You can press the Change... button on that window and select Acrobat as the reader and that should set the default reader back to Acrobat. Admittedly, it's been a while since I've used Windows 7, but that should work.

If that doesn't work, open Adobe Acrobat and select Edit from the top menu bar. Then pick Preferences from that drop-down menu. From the left side of that preferences window, select General. At the very bottom of the general section, there should be a button that says Select As Default PDF Handler. That should either change it as the default or open steps on how to change the default.

If all else fails, this Windows support page explains how to manually change the default program for a file type.

Hope this helps.

Pomohla vám táto odpoveď?

more options

I did as suggested in Wesley's second post and the minute I opened the "Properties" and changed the reader to Acrobat, all the icons changed - dozens of them! File is still not recogised by Word Perfect but that's another problem with nothing to do with Firefox.

As for "you shouldn't lose your bookmarks and toolbars" when upgrading...no, you shouldn't, but I did! I thought I was going to lose my mind too! In case it happens again I am NOT updating Firefox any time soon. My husband cannot help me right now as he is not well and I would never be able to figure out how he managed to get them back. It was complicated enough that an experienced software engineer found it time consuming.

And I assure you it wasn't just a case of they'd been deselected or something and a simple click brought them back. He had to dig for them in folder after folder, in obscure places you'd never even know existed. A total nightmare.

I do think it might be time to part ways - not from my husband, but from Forefox. I hate to do it, but I think we've reached the end of the road. I probably won't - what a hassle - talk about losing all my bookmarks! But I'm thinking about it.

Thanks to Wesley for your excellent and well explained suggestions and anyone else who responded. Almost makes me change my mind. Maybe. Be safe out there!

Pomohla vám táto odpoveď?

more options

In regards to losing data after an update, it's certainly not supposed to happen, but it's also sadly not that uncommon.

Essentially, there are multiple different versions of Firefox that you can download (Developer Edition, Beta, etc). Every Firefox version used to share the same data, but that's something that a lot of people didn't like if they run more than one version of Firefox on the same computer. So the developers decided to make every new installation of Firefox create its own copy of data.

What sometimes happens after an update is that Firefox wrongly thinks that it's a new installation, not an update. In that case, it makes a new blank version of data. Generally, it's a fairly easy process to make Firefox load the old data back.

If you lose your data again after an update, the steps on the Recover user data missing after Firefox update page can usually bring that data back.

Regardless, I'm glad I was able to help with the PDF problem :)

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.