Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

pulseaudio high CPU with no audio playing

  • 5 odpovedí
  • 1 má tento problém
  • 28 zobrazení
  • Posledná odpoveď od yarma22

more options

Hey there,

I have the following issue with Firefox, is this maybe something I should report to the Ubuntu support or directly to Bugzilla?

Steps to reproduce: ---

  1. Open Firefox
  2. Go to a page that contains an embedded video that is not playing automatically, e.g. https://www.rottentomatoes.com/m/sound_of_metal
  3. Do not play the video

Environment --- User Agent: Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:83.0) Gecko/20100101 Firefox/83.0 Firefox version: 83.0 (64-bit) pulseaudio version: 13.99.2 OS: Ubuntu 20.10 64-bit Gnome version: 3.38.1 Windowing system: Wayland CPU: Intel® Core™ i7-8565U CPU @ 1.80GHz × 8 RAM: 15,5 GiB GPU: Mesa Intel® UHD Graphics 620 (WHL GT2)

Actual results --- pulseaudio process is spawned and rapidly becomes the most CPU consuming process on my machine (especially after a few seconds, when the Web Content ones start to cool down). Even though no sound is actually played! When switching to another tab with no embedded video, pulseaudio keeps overloading the CPU. This only stops after closing Firefox.

Expected results --- I'm not sure this is what should be expected, but I'll give it a shot:

  • pulseaudio process should only be spawned when actually playing a media that requires audio
  • pulseaudio should not be the #1 CPU consuming process
  • pulseaudio process should at the very least not massively use CPU when no sound is playing

Vybrané riešenie

Does it happen on any other sites like YouTube or Vimeo?

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (5)

more options

Interesting... nothing for me and I did not play the video.

Operating System: openSUSE Tumbleweed 20201211 KDE Plasma Version: 5.20.4 KDE Frameworks Version: 5.76.0 Qt Version: 5.15.2 Kernel Version: 5.9.12-1-default OS Type: 64-bit Processors: 8 × Intel® Core™ i7-4810MQ CPU @ 2.80GHz Memory: 31.0 GiB of RAM Graphics Processor: Mesa DRI Intel® HD Graphics 4600

Upravil(a) jonzn4SUSE dňa

Pomohla vám táto odpoveď?

more options

Hi,

Happy new year to all the Mozilla community!

Is there any other feedback about the above? I still have the same issue with the latest version of Firefox 84.0.2 (64-bit). I forgot to mention the version of my kernel, in case that helps: 5.8.0-36-generic.

I reported the issue here since the bug ticket I initially opened on Bugzilla was closed with the following explanation "Please link to previous discussions in the support forum or issue tracker of your distribution which led you to believe that this is something to fix in Firefox upstream code".

If there's no other feedback here, should I then open an issue on the Ubuntu bug tracker and see what they suggest before re-opening the Bugzilla ticket?

Thanks for your support and hopefully we will get this fixed :)

Upravil(a) yarma22 dňa

Pomohla vám táto odpoveď?

more options

I am not seeing the issue, Did you ever post screenshots showing the high cpu? see screenshot. Need to see the system monitor info when the issue is happening.

Upravil(a) jonzn4SUSE dňa

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

Does it happen on any other sites like YouTube or Vimeo?

Upravil(a) jonzn4SUSE dňa

Pomohla vám táto odpoveď?

more options

Thanks @jonzn4SUSE for the quick feedback!

I attached a screenshot of the CPU consumption. It may not seem very high but beware that I have a powerful CPU and the pulseaudio process is always the most consuming one, which eventually has an impact on my battery life.

I tried on Vimeo and on a page with embedded Youtube videos that are not playing automatically and indeed, pulseaudio is not spawned in that case. Also, on Vimeo, Youtube and Netflix, whenever a video is playing, pulseaudio is using way less CPU than on the Rotten Tomatoes page when the video is not playing.

So this has to mean the Rotten Tomatoes video player is "rotten" (sorry, I couldn't help myself), good catch!

Thanks for your help, I'll mark this as resolved :)

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.