Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Add-Ons don't work; Apple MacBook Air M1

  • 3 odpovede
  • 3 majú tento problém
  • 598 zobrazení
  • Posledná odpoveď od cor-el

more options

When I wan't to use add-ons in Firefox for Mac, they just don't work. I can install them but they do not open. I have tried re-installing Firefox, installing the Firefox Beta (which supports Apple Silicon but crashed a lot) and restarting my computer, as well as re-installing the Add-Ons. Nothing works. How can I fix this?

When I wan't to use add-ons in Firefox for Mac, they just don't work. I can install them but they do not open. I have tried re-installing Firefox, installing the Firefox Beta (which supports Apple Silicon but crashed a lot) and restarting my computer, as well as re-installing the Add-Ons. Nothing works. How can I fix this?
Priložené obrázky

Vybrané riešenie

I would almost guarantee that your problem is that Firefox does not really support the M1 Chip yet! The only 2 Browsers that I know of that does actually support it is Chrome (when you down load it will ask you what you have), and of course Safari. Give it time for Mozilla to catch up or use one of those 2 till then. Not much of a answer but the M1 is new and using the ARM Chip. I found this Article that might help:

Using Apps on a Apple M1 Machine

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (3)

more options

It’s possible that there is a problem with the file(s) that store the extensions registry.

Type about:support in the address bar and press enter.

Under the page logo on the left side, you will see Application Basics. Under this find Profile Folder. To its right press the button Show Folder. This will open your file browser to the current Firefox profile. Now Close Firefox.

Windows: Show Folder; Linux: Open Directory; Mac: Show in Finder

Linux: Under the page logo on the left side, you will see Application Basics. Under this find Profile Directory. To its right press the button Open Directory.

Delete all extensions* files and compatibility.ini in the Firefox profile folder to reset the extensions registry.

New files will be created when required.

After, restart Firefox.

See "Corrupt extension files":

+++++++++++++++++++++++++++ You will have to approve the updating one last time.

more options

Vybrané riešenie

I would almost guarantee that your problem is that Firefox does not really support the M1 Chip yet! The only 2 Browsers that I know of that does actually support it is Chrome (when you down load it will ask you what you have), and of course Safari. Give it time for Mozilla to catch up or use one of those 2 till then. Not much of a answer but the M1 is new and using the ARM Chip. I found this Article that might help:

Using Apps on a Apple M1 Machine

Upravil(a) Tom J dňa

more options

I think that Firefox 83 is running via the Rosetta 2 emulator, so probably best is to disable hardware acceleration in Firefox.