Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Get rid of "This Time Search With.

  • 5 odpovedí
  • 1 má tento problém
  • 140 zobrazení
  • Posledná odpoveď od r.thomas.wright

more options

I hate the "This time, search with" in the URL bar. When I want to search, I use the Search bar for that. I don't need extra icons that I'm not going to use taking up space in the URL bar. I've seen it suggested that they can be removed in the Search options page. But when I've tried that, it also removes them from the Search bar.

Here's what I want: for the URL bar to only have space for a URL, no "This time, search with" nonsense, but the Search bar left completely intact, with all the search engines I use.

I hate the "This time, search with" in the URL bar. When I want to search, I use the Search bar for that. I don't need extra icons that I'm not going to use taking up space in the URL bar. I've seen it suggested that they can be removed in the Search options page. But when I've tried that, it also removes them from the Search bar. Here's what I want: for the URL bar to only have space for a URL, no "This time, search with" nonsense, but the Search bar left completely intact, with all the search engines I use.
Priložené obrázky

Vybrané riešenie

Currently, there is no way to remove that row of icons only from the address bar drop-down and not from the search bar drop-down.

You can use custom style rules in an optional userChrome.css file to hide the row, but this won't actually remove it, so it would become a "Bermuda triangle" for the selection bar if you arrow key into that area. I guess since you aren't showing any suggestions from bookmarks or history, arrowing down isn't a likely scenario.

If that sounds okay:

Have you already created a userChrome.css file? You would add this rule:

  #urlbar .search-one-offs:not([hidden]) {
    display: none !important;
  }

If it's your first time, I or another support volunteer can lay out the steps.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (5)

more options

Vybrané riešenie

Currently, there is no way to remove that row of icons only from the address bar drop-down and not from the search bar drop-down.

You can use custom style rules in an optional userChrome.css file to hide the row, but this won't actually remove it, so it would become a "Bermuda triangle" for the selection bar if you arrow key into that area. I guess since you aren't showing any suggestions from bookmarks or history, arrowing down isn't a likely scenario.

If that sounds okay:

Have you already created a userChrome.css file? You would add this rule:

  #urlbar .search-one-offs:not([hidden]) {
    display: none !important;
  }

If it's your first time, I or another support volunteer can lay out the steps.

more options

Thanks! That worked perfectly!

more options

Okay, this no longer works. Ever since the most recent Firefox update, those annoying "This time search" icons are back. The userChrome.css is still there; it's just not working.

more options

Do you mean it's not working in Firefox 88 (current release) or in Firefox 89-90 (beta/Developer/Nightly)? It should still work in Firefox 88, but there are major UI changes in Firefox 89-90 that I haven't tested yet.

In case some preferences got reset in your profile, double-check this preference:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste toolkit.legacyUserProfileCustomizations.stylesheets and pause while the list is filtered

(3) If the preference has its default value of false, double-click it to switch the value to true

more options

Thanks. Shortly after I posted this, I found that someplace else on the web. Firefox had changed my custom settings. Again. I really wish these updates wouldn't do that.

But thanks, that right there was exactly what solved the problem.