Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Only first few images load on website

  • 2 odpovede
  • 2 majú tento problém
  • 8 zobrazení
  • Posledná odpoveď od royyeo

more options

Hello,

I've recently encountered an issue where only the first few images on a website load and the rest are just blank. For now, I'm noticing it happening on Boredpanda.com, but there were other sites on which I noticed the same problem. I'm running Firefox 81.0.2 on a MacBook Pro, Mojave. Any advice on how to fix this? I cleared the cache to no avail. The site runs fine on other browsers.

Všetky odpovede (2)

more options

Hmm, I don't think I'm missing images on that site.

There are some sites that use "lazy loading" to speed up the initial page appearance. In that case images may not be loaded until you scroll down closer to that part of the page. If a site is using this method and their loading script is paused or blocked, that could cause the issue. However, I don't think Bored Panda uses that, so it must be something else.

If a site is generally known to work in Firefox, these are standard suggestions to try when it stops working normally:

Double-check content blockers: Firefox's Tracking Protection feature, and extensions that counter ads and tracking, may break websites that embed third party content (meaning, from a secondary server).

(A) The shield icon toward the left end of the address bar usually turns a bit purplish when content is blocked. Click the icon to learn more or make an exception. See: Enhanced Tracking Protection in Firefox for desktop.

(B) Extensions such as Adblock Plus, Blur, Disconnect, DuckDuckGo Privacy Essentials, Ghostery, NoScript, Privacy Badger, uBlock Origin or uMatrix usually provide a toolbar button to manage blocked content in a page. There may or may not be a number on the icon indicating the number of blocked items; you sometimes need to click the button to see what's going on and test whether you need to make an exception for this site.

Cache and Cookies: When you have a problem with one particular site, a good "first thing to try" is clearing your Firefox cache and deleting your saved cookies for the site.

(1) Clear Firefox's Cache (you mentioned already doing this)

See: How to clear the Firefox cache

If you have a large hard drive, this might take a few minutes.

(2) Remove the site's cookies (save any pending work first). While viewing a page on the site, click the lock icon at the left end of the address bar. After a moment, a "Clear Cookies and Site Data" button should appear at the bottom. Go ahead and click that.

In the dialog that opens, you will see one or more matches to the current address so you can remove the site's cookies individually without affecting other sites.

Then try reloading the page. Does that help?

Testing in Firefox's Safe Mode: In its Safe Mode, Firefox temporarily deactivates extensions, hardware acceleration, and some other advanced features to help you assess whether these are causing the problem.

If Firefox is running: You can restart Firefox in Safe Mode using either:

  • "3-bar" menu button > "?" Help > Restart with Add-ons Disabled
  • (menu bar) Help menu > Restart with Add-ons Disabled

and OK the restart. A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

If Firefox is not running: Hold down the option/alt key when starting Firefox. (On Windows, hold down the Shift key instead of the option/alt key.) A small dialog should appear. Click "Start in Safe Mode" (not Refresh).

Any improvement?

Pomohla vám táto odpoveď?

more options

Thanks for your response! I'm using uBlock Origins and Privacy Badger, so I thought they might be the cause of the problem. So I deactivated them one at a time, then both, but still the same thing.

I figured it can't be anyway, since I use the same extensions on Chrome and the site works fine there.

I've not tried restarting Firefox in Safe Mode yet though, but if it works, I'll let you know. Thanks again, appreciate the help.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.