Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Keyword bookmark with special chars removed in Firefox81? How to Make it work again?

  • 8 odpovedí
  • 1 má tento problém
  • 32 zobrazení
  • Posledná odpoveď od Ricardo Martins

more options

I always used keyword bookmark, but in Firefox 81+ if my query parameter (%s) contains special chars (like ?) it doesn't work anymore.

What have changed? How can I make it work again?

Priložené obrázky

Vybrané riešenie

Yes, I'm aware that a ? at the end triggers using the default search engine instead of using the keyword bookmark.

I do not know of any way to change that behavior, which I think is new in Firefox 81.

If this doesn't come up very often, the quickest workaround that comes to mind is to type something (other than a space, a space doesn't work) after the ? in your query.

Čítať túto odpoveď v kontexte 👍 1

Všetky odpovede (8)

more options

The ? has a special meaning if found at the beginning or end of your query, which is to use the default search engine.

If you regularly need to send queries to the bookmarked site that have a question mark at the end, you may need to modify your bookmark or set up a second one. Here's the idea:

Regular keyword bookmark:

Location: https://translate.google.com.br/#view=home&op=translate&sl=en&tl=pt&text=%s

Use: type keyword, space, query, Return (or Alt+Return for new tab)

JavaScript keyword bookmark (bookmarklet):

Location: javascript:var kw=prompt('Enter text or 0 to cancel');if(kw){if(kw!='0' && kw.length>0) u='https://translate.google.com.br/#view=home&op=translate&sl=en&tl=pt&text='+encodeURIComponent(kw); window.open(u,'_blank');} void 0;

Use: type keyword, Return; in popup type query, Return (opens in new tab)

Do you want to give it a try?

Pomohla vám táto odpoveď?

more options

That's a very good workaround, @jscher2000. In the previous version, Firefox automatically converted the content to urlencode.. Do you know if the word used as "keyword" is available inside the Location field in some variable?

Pomohla vám táto odpoveď?

more options

Hi Ricardo, I'm not sure if you're asking about how Firefox does it or how my script does it?

In my script, there's no reference to the keyword assigned to the bookmarklet. Or the name, or tags, or anything outside of the script. I'm not aware of a way to access that.

Pomohla vám táto odpoveď?

more options

I meant Firefox in general, so I wouldn't need to open the prompt before... In my example, there would be no use to open a prompt.. I usually use this particular snippet to translate any text. This could be a word or a paragraph. In the past (prior to Firefox 81), I just paste the content in the address bar.

Now, if it contains any special char, doesn't work. If I need to type anything else and ENTER, wouldn't make sense... I could start typing "tep" > opens google translate with the translation field on focus where I can paste my content and get instant translation.

I'm wondering if this new "bug" is just a new feature that I can disable in about:config or something like that.

Pomohla vám táto odpoveď?

more options

I'm not aware of way to have Firefox ignore the ? character at the end of the query. You can type a period after it to make it not the last character, although perhaps that could affect the translation.

What other characters are causing the problem?

Pomohla vám táto odpoveď?

more options

Try this:

Location https://translate.google.com.br/#view=home&op=translate&sl=en&tl=pt&text=%s Keyword tep


And then try this on the browser:

tep dogs

and

tep how many dogs do you have?


If you're using Firefox 81, after typing ? it will lose the bookmark.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

Yes, I'm aware that a ? at the end triggers using the default search engine instead of using the keyword bookmark.

I do not know of any way to change that behavior, which I think is new in Firefox 81.

If this doesn't come up very often, the quickest workaround that comes to mind is to type something (other than a space, a space doesn't work) after the ? in your query.

Pomohla vám táto odpoveď?

more options

Hi @jscher2000. Thanks for the insight. Adding anything (but space) after the ? solved the problem. :)

Thanks a lot.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.