Vyhľadajte odpoveď

Vyhnite sa podvodom s podporou. Nikdy vás nebudeme žiadať, aby ste zavolali alebo poslali SMS na telefónne číslo alebo zdieľali osobné informácie. Nahláste prosím podozrivú aktivitu použitím voľby “Nahlásiť zneužitie”.

Learn More

Attempting to set new tab with firefox.cfg yields 'Failed to read the configuration file'

  • Žiadne odpovede
  • 1 má tento problém
  • 9 zobrazení
more options

I'm attempting to set the new tab page using the autoconfig.cfg and autoconfig.js files. I have the following (Ubuntu 20.0.4):

/usr/lib/firefox/autoconfig.cfg ``` // set new tab page var {classes:Cc,interfaces:Ci,utils:Cu} = Components; aboutNewTabService = Cc["@mozilla.org/browser/aboutnewtab-service;1"].getService(Ci.nsIAboutNewTabService); aboutNewTabService.newTabURL = "file:///home/Desktop/index.html"; ```

/usr/lib/firefox/defaults/pref/autoconfig.js ``` pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0); pref("general.config.sandbox_enabled", false); ```

When I restart firefox, a dialogue pops up saying 'Failed to read the configuration file. Please contact your system administrator.' The new tab is unchanged. Am I doing something wrong? I've seen [thread] and believe I've followed everything that was said.

I'm attempting to set the new tab page using the autoconfig.cfg and autoconfig.js files. I have the following (Ubuntu 20.0.4): /usr/lib/firefox/autoconfig.cfg ``` // set new tab page var {classes:Cc,interfaces:Ci,utils:Cu} = Components; aboutNewTabService = Cc["@mozilla.org/browser/aboutnewtab-service;1"].getService(Ci.nsIAboutNewTabService); aboutNewTabService.newTabURL = "file:///home/Desktop/index.html"; ``` /usr/lib/firefox/defaults/pref/autoconfig.js ``` pref("general.config.filename", "autoconfig.cfg"); pref("general.config.obscure_value", 0); pref("general.config.sandbox_enabled", false); ``` When I restart firefox, a dialogue pops up saying 'Failed to read the configuration file. Please contact your system administrator.' The new tab is unchanged. Am I doing something wrong? I've seen [[https://support.mozilla.org/en-US/questions/1251199#answer-1199709|this thread]] and believe I've followed everything that was said.