Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

use of Themes

  • 6 odpovedí
  • 1 má tento problém
  • 8 zobrazení
  • Posledná odpoveď od Gordon Foy

more options

I was recently playing with "Themes" by adding and deleting some. Now, when Firefox starts, the theme "Light" is always used as the default. When I look at the themes page, my preferred one is shown as"enabled" and "Light" is shown as "disabled", but it is Light that is actually displayed in the banner display. If I disable, then enable my preferred one, it is then the one displayed. How can I stop "Light" from being the actual default? Firefox does not allow me to delete the Light theme.

Vybrané riešenie

Does this still happen if you disconnect Sync ?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also:

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (6)

more options

Are you possibly using Sync ?

You can check extensions.activeThemeID on the about:config page.

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Pomohla vám táto odpoveď?

more options

Hi and thank you for your response. Yes, I am synced with a second Windows computer for bookmarks in Firefox but the theme displayed on that computer is the one I want and it doesn't change when starting Firefox. I opened the about:config page as you suggested and I found the extensions.activeThemeID entry. Do I just delete that? If the long string needs to be changed, I wouldn't have any idea what to change it to.

Pomohla vám táto odpoveď?

more options

No, you shouldn't edit this pref.

This pref has a corresponding services.sync.prefs.sync.extensions.activeThemeID and that means that it is part of Sync and all devices would get the same theme when possible.

You can toggle services.sync.prefs.sync.extensions.activeThemeID = false via a double-click on the about:config page to prevent extensions.activeThemeID from getting synced.

Pomohla vám táto odpoveď?

more options

Thank you again. I did toggle the setting as you suggested. I went back and verified that the change was retained. But it didn't fix the issue. The theme changes from the requested one to "Light" a few seconds after starting Firefox. If it is relevant, the computer with the problem is a Win 7 machine, while the one without the problem is a Win 10 device.

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

Does this still happen if you disconnect Sync ?

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Safe Mode start window

See also:

Pomohla vám táto odpoveď?

more options

The problem turned out to be the version of the extension "Firefox Color" that I had installed. There appear not to be any options or a way to update this extension. The symptoms were strange: - I had loaded Firefox Color into my Win 10 computer several weeks ago. Because I was operating in sync, I guess it got loaded automatically into the Win 7 computer. - There were no problems ever on the Win 10 machine and they only started occurring on the Win 7 machine some time later.

Thank you again. I don't think I would ever have found the issue without your suggestions.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.