Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Bookmarked file (*.pdf) will not open with Acrobat

  • 4 odpovede
  • 2 majú tento problém
  • 100 zobrazení
  • Posledná odpoveď od jscher2000

more options

In the past, I have bookmarked frequently used pdf's. Retrieving the bookmark always loaded the file into acrobat. Now, however, the file is loaded into the Firefox pdf reader. If I open the pdf from windows explorer it opens into acrobat. Is there a way to go from bookmark to acrobat?

Vybrané riešenie

You create bookmarks to locally saved files? Apparently the rules for how to handle web content don't apply to bookmarks to locally saved PDFs like file:///C:/Users/username/Downloads/test.pdf

If you never ever want to use the PDF Viewer, you have the option to fully disable it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs and pause while the list is filtered

(3) Double-click the pdfjs.disabled preference to switch the value from false to true

More info on about:config: Configuration Editor for Firefox.

You could file a new bug:

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (4)

more options

Hi kkayser, Firefox handles bookmarked URLs and links the same way, so you can direct Firefox to open all bookmarked URLs and links to PDFs to open in your preferred external viewer. This article has the steps:

View PDF files in Firefox or choose another viewer

Upravil(a) jscher2000 dňa

more options

That works with files directly clicked, but not with bookmarks. The only way I can get a bookmarked file to open with Acrobat is to find it with Windows explorer and open it there.

more options

There have been issues reported with opening PDF files from the download manager window, so maybe bookmarks are affected as well.

  • Bug 1653807 - PDF handling from Download panel is broken (no longer uses OS handler)

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

more options

Vybrané riešenie

You create bookmarks to locally saved files? Apparently the rules for how to handle web content don't apply to bookmarks to locally saved PDFs like file:///C:/Users/username/Downloads/test.pdf

If you never ever want to use the PDF Viewer, you have the option to fully disable it:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste pdfjs and pause while the list is filtered

(3) Double-click the pdfjs.disabled preference to switch the value from false to true

More info on about:config: Configuration Editor for Firefox.

You could file a new bug: