Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Block autoplay being ignored on Firefox 78

  • 5 odpovedí
  • 2 majú tento problém
  • 121 zobrazení
  • Posledná odpoveď od zgwstores

more options

Prior to the latest version, I had set "media.autoplay.enabled.user-gestures-needed" in about:config to False in addition to blocking both audio and video within the settings so that nothing would autoplay without my input.

I updated to version 78 yesterday, and it seems that "media.autoplay.enabled.user-gestures-needed" is now gone from within about:config. I'm getting videos autoplaying within sites like YouTube, despite me setting both audio and video to not autoplay.

Is there anything I can do to ensure that nothing starts playing without me allowing it?

Vybrané riešenie

It appears that media.autoplay.enabled.user-gestures-needed has been replaced by media.autoplay.blocking_policy.
You can try to set media.autoplay.blocking_policy = 2 to see if that has effect.

See also:


  • Bug 1509933 - Use transient user activation as the default way to detect if the action is an user-input for `click-to-play` [78]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (5)

more options

Hello,

The Refresh feature (called "Reset" in older Firefox versions) can fix many issues by restoring Firefox to its factory default state while saving your bookmarks, history, passwords, cookies, and other essential information.

Note: When you use this feature, you will lose any extensions, toolbar customizations, and some preferences. See the Refresh Firefox - reset add-ons and settings article for more information.

To Refresh Firefox:

  1. Open the Troubleshooting Information page using one of these methods:
    • Click the menu button New Fx Menu , click help Help-29 and select Troubleshooting Information. A new tab containing your troubleshooting information should open.
    • If you're unable to access the Help menu, type about:support in your address bar to bring up the Troubleshooting Information page.
  2. At the top right corner of the page, you should see a button that says "Refresh Firefox" ("Reset Firefox" in older Firefox versions). Click on it.
  3. Firefox will close. After the refresh process is completed, Firefox will show a window with the information that is imported.
  4. Click Finish and Firefox will reopen.

Did this fix the problem? Please report back to us!

Thank you.

Upravil(a) Ram Mozi dňa

Pomohla vám táto odpoveď?

more options

Blocking autoplay within the settings never affected YouTube for some reason, so the behavior I'm getting is "as intended", and refreshing the browser won't resolve it. I did refresh the browser and this was confirmed.

Prior to the latest version, I could get YouTube to stop autoplaying videos by setting media.autoplay.enabled.user-gestures-needed" to False in about:config, but it seems that this was removed in version 78 for some reason.

Is there any other workaround to not let YouTube autoplay? Also, why doesn't the block autoplay setting work across the board?

Pomohla vám táto odpoveď?

more options

Vybrané riešenie

It appears that media.autoplay.enabled.user-gestures-needed has been replaced by media.autoplay.blocking_policy.
You can try to set media.autoplay.blocking_policy = 2 to see if that has effect.

See also:


  • Bug 1509933 - Use transient user activation as the default way to detect if the action is an user-input for `click-to-play` [78]

(please do not comment in bug reports
https://bugzilla.mozilla.org/page.cgi?id=etiquette.html
)

Upravil(a) cor-el dňa

Pomohla vám táto odpoveď?

more options

Yep, that did it. Thank you!

Pomohla vám táto odpoveď?

more options

I have this problem. Videos are playing in Yahoo. I am able to disable the sound. I have performed all actions listed in this thread. I have restarted my PC.

Same issue.

Pomohla vám táto odpoveď?

Položiť otázku

Ak chcete pridať odpoveď, musíte sa prihlásiť k svojmu účtu. Ak účet doteraz nemáte, položte novú otázku.