Vyhľadajte odpoveď

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 77 opens to newtab page instead of homepage

  • 16 odpovedí
  • 3 majú tento problém
  • 810 zobrazení
  • Posledná odpoveď od jscher2000

more options

When opening firefox it opens to newtab instead of my homepage which is Yahoo. If I click on the home button it will go to my homepage but I shouldn't have to do that every time. I have cleared the cache and it will work once or twice only then back to the newtab page.

Vybrané riešenie

Nothing worked until I tried this link to download a fresh copy from. The original was downloaded from their main web site. Why this one worked and the other one didn't is a real mystery. I added all my add ons and have opened and closed it 15 times and it still works. Very strange. Thanks everyone for your help. Hopefully this will be over.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

Čítať túto odpoveď v kontexte 👍 0

Všetky odpovede (16)

more options

Hi densyl93, glad to see you on Mozilla Support Forum.

  • Click on menu icon.
  • Click on options.
  • In left pane, click on Home menu icon.
  • In this menu, you will find an option New Windows and Tabs.
  • In this option, you will find a dropdown menu named Homepage and New Windows.
  • and, choose Firefox Home (Default).

If it doesn't solved your problem, then feel free to ask in Reply section. Thanks for raising your question in Mozilla Support Forum.

more options

This is what it opens to now (see image below). It still says newtab. Either way I need it to open to Yahoo.com which it does if I click the homepage button only.

more options

We'll show you how to automatically open any web page you want when you launch Firefox or click the Home button . Table of Contents Set or change your home page Set your home page through Firefox options Set multiple pages as your home page Having problems?

https://support.mozilla.org/en-US/kb/how-to-set-the-home-page#w_set-or-change-your-home-page

Set or change your home page

1.Open the web page you want to use as your home page. 2.Drag and drop that tab onto the Home button on your toolbar (it's on the left side by default).

3.Click Yeson the prompt to set this page as your home page.

Set your home page through Firefox options

1.Click the menu button and select Options. 2.Click the Home panel. 3.Click the menu next to Homepage and new windows and choose to show the default Firefox Home page, custom URLs or a blank page.

Set multiple pages as your home page

You can set a group of pages as your home page. Open each page in a separate tab, select Custom URLs… in the Homepage and new windows drop-down menu and click on Use Current Pages.

Having problems? We have solutions:

If you keep getting the "Firefox has just updated" tab every time Firefox starts, see the article Firefox says it's just updated every time it starts - how to fix. If your home page settings are not saved, see How to fix preferences that won't save. If you can't see the Home button, have a look at Customize Firefox controls, buttons and toolbars. If your home page was hijacked or automatically changed, see Remove a toolbar that has taken over your Firefox search or home page. If a page keeps opening even after you've removed a third-party toolbar and restored your home page, see Wrong home page opens when I start Firefox - How to fix. An extension may be controlling your home page. For more information, see An extension changed my New Tab page.

Share this article: http://mzl.la/1BAQNzv

Upravil(a) Pallavi kumari dňa

more options

As you can see by the first image my settings for the homepage is correct. Looking at the second image you can see what my page opens to - a blank page that says new tab. Something is not working.

more options

Hi densyl93,

You have to disable New Tab Override Extension. Then, Click on New tab Dropdown menu and choose that custom URL option.

Hope it helps. Thank You.

more options

I am trying to change my homepage not the new tab page. The new tab override changes the new tab to Bing. Disabling that does nothing for my homepage. When opening firefox it immediately goes to a blank newtab page instead of my homepage which is YAHOO.

more options

Hi densyl93, does it make any difference if you change your home page URL to the full URL with the protocol and trailing slash:

https://www.yahoo.com/

Just in case Firefox is getting pickier about having a protocol at the beginning.

more options

I was really hoping that would work but there is no change.

more options

Over the years, a few users reported a similar problem where Firefox failed to load the home page, even though it worked in other contexts such as a new window (Ctrl+n). This may have been related to deferred clean-ups that Firefox performed at startup (for example, if Firefox is set to clear history when it closes but it didn't finish at that time and needed to finish at startup) or a filter that wasn't ready for the first request from Firefox when it started.

Since clearing the cache helps, I wonder whether the cache is somehow getting corrupted?

more options

I completely uninstalled and reinstalled firefox with nothing else added. It worked the first time but back the the blank new tab page thereafter.

more options

Two more threads about problems loading the home page when it is set to Yahoo:

Mysterious.

more options

Vybrané riešenie

Nothing worked until I tried this link to download a fresh copy from. The original was downloaded from their main web site. Why this one worked and the other one didn't is a real mystery. I added all my add ons and have opened and closed it 15 times and it still works. Very strange. Thanks everyone for your help. Hopefully this will be over.

https://www.mozilla.org/en-US/firefox/all/#product-desktop-release

more options

Hi densyl93,

Firefox may repeatedly open new, empty tabs or windows after you click on a link, forcing you to close Firefox. The same untitled tabs or blank windows may open the next time you start Firefox if the previous session is restored. This usually happens because you chose Firefox as the program to always use for a particular action, such as opening a certain type of file or launching an application to send mail.


Note: The Refresh Firefox feature can fix many issues by restoring Firefox to its default state while saving your essential information. Consider using it before going through a lengthy troubleshooting process.

https://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=&cad=rja&uact=8&ved=2ahUKEwiDgZf7iurpAhXPzDgGHS2XBa0QFjAAegQIBRAB&url=https%3A%2F%2Fsupport.mozilla.org%2Fen-US%2Fkb%2Ffirefox-repeatedly-opens-empty-tabs-or-windows&usg=AOvVaw0pD-BdyA4T-UbLN9EN-7pH

more options

The problem has already been solved

more options

Pallavi kumari said

3.Click the menu next to Homepage and new windows and choose to show the default Firefox Home page, custom URLs or a blank page.

I've set my homepage to my own "site" (a set of links I built years ago, and the homepage is the main index for those groups of sites. I also set the new tab option to Firefox Home Page ... but it opens some stupid page of icons (I know the name for that...but chemobrain from cancer #1 is not letting me have that name right now and it's being very stubborn about it---it's named "Top Sites" but it's not even remotely close to any of my most-used sites...more like mostly sites I never use, but that's irrelevant, as it's not what's supposed to open there) instead of my homepage's index.html, where it's supposed to be opening the Home page I configured for Firefox.

So how do I get my custom homepage setting (the aforementioned index.html) to open for new tabs, too? I KNOW it's possible...I used to have that working perfectly. But now, for some reason, it opens to that other crap instead of what I set it for (my Firefox homepage, i.e., the index.html file).

Currently running 68.8.0esr (64-bit). Not upgrading anytime soon, because every time I do, an extension I use regularly stops working.

Thanks

more options

Hi jim174, this thread is about a problem with a custom home page not showing when you start Firefox 77. It is not about how to install a custom new tab page. You should start a new question for that.

https://support.mozilla.org/questions/new/desktop

Scroll down past unrelated threads to continue with the new question form.

Alternately, you could search for other threads on your topic. If you had a local file set up as your new tab page in Firefox 57 or later, the two possible methods were:

(A) Importing a local file into the New Tab Override extension (B) Setting up a pair of files in Firefox's program folder (Customizing Firefox Using AutoConfig)

Those are both beyond the scope of this thread.